summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-29 22:26:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-29 22:26:24 +0000
commit3d04b66acf2481f49c0c8f2918034b269dc39e13 (patch)
tree5362f7389cb4a17fda3e9cfee9d85c1527d82f3d /net-libs/libtorrent
parentStable on amd64. (diff)
downloadhistorical-3d04b66acf2481f49c0c8f2918034b269dc39e13.tar.gz
historical-3d04b66acf2481f49c0c8f2918034b269dc39e13.tar.bz2
historical-3d04b66acf2481f49c0c8f2918034b269dc39e13.zip
Added patch to fix warnings (errors) about integer/pointer mismatch.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/ChangeLog6
-rw-r--r--net-libs/libtorrent/Manifest11
-rw-r--r--net-libs/libtorrent/files/libtorrent-0.6.2-warns.patch24
-rw-r--r--net-libs/libtorrent/libtorrent-0.6.2.ebuild7
4 files changed, 39 insertions, 9 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index c910f25274d5..eff86b3e4a96 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.8 2005/05/25 11:57:27 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.9 2005/05/29 22:26:24 flameeyes Exp $
+
+ 29 May 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/libtorrent-0.6.2-warns.patch, libtorrent-0.6.2.ebuild:
+ Added patch to fix warnings (errors) about integer/pointer mismatch.
25 May 2005; Diego Pettenò <flameeyes@gentoo.org>
+files/libtorrent-0.6.2-fbsd.patch, libtorrent-0.6.2.ebuild:
diff --git a/net-libs/libtorrent/Manifest b/net-libs/libtorrent/Manifest
index d41890584696..773508869ce4 100644
--- a/net-libs/libtorrent/Manifest
+++ b/net-libs/libtorrent/Manifest
@@ -1,21 +1,22 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 32db51528899dafab4eb725ca73dc812 ChangeLog 1730
+MD5 c2db0fb67cfd7f12000899ff4a06514f ChangeLog 1919
MD5 2ea9378fd91b526ac1e4c80014fc0d4e libtorrent-0.3.5.ebuild 981
MD5 dec802261d55c538f2facb00e499b14f libtorrent-0.3.7.ebuild 981
MD5 1b8dfc70fa729659931a20c79dec23e5 libtorrent-0.4.1.ebuild 981
-MD5 0c16d376b38c61e19dc6e0b055f18b6b libtorrent-0.6.2.ebuild 892
+MD5 0d924f9962a83ecc942d934b06c8c526 libtorrent-0.6.2.ebuild 959
MD5 b59f615ff4e1c464f88d1667a66f6b5d metadata.xml 224
MD5 9624018f42b92526ba13e1bb6eba02b4 files/digest-libtorrent-0.3.5 68
MD5 d92db0dead5f5ee4d2bc579695950695 files/digest-libtorrent-0.3.7 68
MD5 60450079b16686733eeaf7b85e320de3 files/digest-libtorrent-0.4.1 68
MD5 fed0b1d9f0637d8bec0610b06bc48f09 files/digest-libtorrent-0.6.2 68
MD5 335ec65aa07b3ccf5efa7a7bc06ff4a5 files/libtorrent-0.6.2-fbsd.patch 1305
+MD5 fa7178b92b0fe229d3b56215dff10599 files/libtorrent-0.6.2-warns.patch 1166
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFClGdEj5H05b2HAEkRAigIAKCBHsiMp3w8BzdETxGPxXBh4CgWhQCfd2Gv
-1ERcRgoj22W8e9e7dA0mpWI=
-=A+wx
+iD8DBQFCmkChj5H05b2HAEkRAiSrAKCIznMvW52l6pWH5Cl15EkUfqo3sgCfazJ1
+Km/fegl3GBgwXeBCkdKD9sA=
+=MzMk
-----END PGP SIGNATURE-----
diff --git a/net-libs/libtorrent/files/libtorrent-0.6.2-warns.patch b/net-libs/libtorrent/files/libtorrent-0.6.2-warns.patch
new file mode 100644
index 000000000000..a87ac23cff64
--- /dev/null
+++ b/net-libs/libtorrent/files/libtorrent-0.6.2-warns.patch
@@ -0,0 +1,24 @@
+diff -x '*~' -ur libtorrent-0.6.2/src/data/file.cc libtorrent-0.6.2-gcc4/src/data/file.cc
+--- libtorrent-0.6.2/src/data/file.cc 2005-04-21 20:39:39.000000000 +0200
++++ libtorrent-0.6.2-gcc4/src/data/file.cc 2005-05-30 00:08:45.358865976 +0200
+@@ -102,7 +102,7 @@
+
+ if (((prot & MemoryChunk::prot_read) && !is_readable()) ||
+ ((prot & MemoryChunk::prot_write) && !is_writable())) {
+- int buf = get_size();
++ off_t buf = get_size();
+
+ throw internal_error(std::string((char*)buf, 4));
+ // throw internal_error("File::get_chunk() permission denied");
+diff -x '*~' -ur libtorrent-0.6.2/src/data/memory_chunk.cc libtorrent-0.6.2-gcc4/src/data/memory_chunk.cc
+--- libtorrent-0.6.2/src/data/memory_chunk.cc 2005-04-14 21:45:04.000000000 +0200
++++ libtorrent-0.6.2-gcc4/src/data/memory_chunk.cc 2005-05-29 23:51:27.853590752 +0200
+@@ -53,7 +53,7 @@
+ if (page_align() >= m_pagesize)
+ throw internal_error("MemoryChunk::MemoryChunk(...) received an page alignment >= page size");
+
+- if ((uint32_t)ptr % m_pagesize)
++ if ((ptrdiff_t)ptr % m_pagesize)
+ throw internal_error("MemoryChunk::MemoryChunk(...) is not aligned to a page");
+ }
+
diff --git a/net-libs/libtorrent/libtorrent-0.6.2.ebuild b/net-libs/libtorrent/libtorrent-0.6.2.ebuild
index cba52dccfbec..e028f95a826e 100644
--- a/net-libs/libtorrent/libtorrent-0.6.2.ebuild
+++ b/net-libs/libtorrent/libtorrent-0.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.6.2.ebuild,v 1.2 2005/05/25 11:57:27 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.6.2.ebuild,v 1.3 2005/05/29 22:26:24 flameeyes Exp $
inherit eutils
@@ -23,6 +23,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${P}-fbsd.patch
+ epatch ${FILESDIR}/${P}-warns.patch
./autogen.sh
}
@@ -31,8 +32,8 @@ src_compile() {
econf \
$(use_enable debug) \
--disable-dependency-tracking \
- || die
- emake || die
+ || die "econf failed"
+ emake || die "emake failed"
}
src_install() {