summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-09-29 00:57:46 +0000
committerJeroen Roovers <jer@gentoo.org>2009-09-29 00:57:46 +0000
commit18ae7603988240e4c6614bdffd735b7cfcfeacba (patch)
treeae4d737b7b0a994b58aefa7f9397b1692f5d405f /net-libs/libssh/libssh-0.3.4.ebuild
parentAdd fix for bug #281484. (diff)
downloadhistorical-18ae7603988240e4c6614bdffd735b7cfcfeacba.tar.gz
historical-18ae7603988240e4c6614bdffd735b7cfcfeacba.tar.bz2
historical-18ae7603988240e4c6614bdffd735b7cfcfeacba.zip
Version bump thanks to Thomas Beinicke (bug #286860).
Package-Manager: portage-2.2_rc42/cvs/Linux i686
Diffstat (limited to 'net-libs/libssh/libssh-0.3.4.ebuild')
-rw-r--r--net-libs/libssh/libssh-0.3.4.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-libs/libssh/libssh-0.3.4.ebuild b/net-libs/libssh/libssh-0.3.4.ebuild
new file mode 100644
index 000000000000..b18c5630f088
--- /dev/null
+++ b/net-libs/libssh/libssh-0.3.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh/libssh-0.3.4.ebuild,v 1.1 2009/09/29 00:57:46 jer Exp $
+
+# Maintainer: check IUSE-defaults at DefineOptions.cmake
+
+EAPI="2"
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Access a working SSH implementation by means of a library"
+HOMEPAGE="http://www.libssh.org/"
+SRC_URI="http://www.libssh.org/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~s390 ~x86"
+SLOT="0"
+IUSE="debug gcrypt examples +sftp ssh1 server static-libs zlib"
+
+DEPEND="
+ zlib? ( >=sys-libs/zlib-1.2 )
+ !gcrypt? ( >=dev-libs/openssl-0.9.8 )
+ gcrypt? ( >=dev-libs/libgcrypt-1.4 )
+"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS README ChangeLog"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.0-automagic-crypt.patch"
+)
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with debug DEBUG_CRYPTO)
+ $(cmake-utils_use_with gcrypt)
+ $(cmake-utils_use_with zlib LIBZ)
+ $(cmake-utils_use_with sftp)
+ $(cmake-utils_use_with ssh1)
+ $(cmake-utils_use_with server)
+ $(cmake-utils_use_with static-libs STATIC_LIB)
+ "
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use examples; then
+ insinto "${ROOT}"usr/share/doc/"${PF}"/examples
+ doins sample.c samplesshd.c
+ fi
+}