summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-05-31 21:53:46 +0000
committerCédric Krier <cedk@gentoo.org>2008-05-31 21:53:46 +0000
commitb4dd7997495f714c02eeb96a958f2928b86cb892 (patch)
tree8df180829b78856d38c24bad1c7dc6bff523022e /net-libs/libnfnetlink/libnfnetlink-0.0.38.ebuild
parentVersion bump. (diff)
downloadhistorical-b4dd7997495f714c02eeb96a958f2928b86cb892.tar.gz
historical-b4dd7997495f714c02eeb96a958f2928b86cb892.tar.bz2
historical-b4dd7997495f714c02eeb96a958f2928b86cb892.zip
Version bump
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'net-libs/libnfnetlink/libnfnetlink-0.0.38.ebuild')
-rw-r--r--net-libs/libnfnetlink/libnfnetlink-0.0.38.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libnfnetlink/libnfnetlink-0.0.38.ebuild b/net-libs/libnfnetlink/libnfnetlink-0.0.38.ebuild
new file mode 100644
index 000000000000..a166d325f880
--- /dev/null
+++ b/net-libs/libnfnetlink/libnfnetlink-0.0.38.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/libnfnetlink-0.0.38.ebuild,v 1.1 2008/05/31 21:53:46 cedk Exp $
+
+inherit linux-info
+
+DESCRIPTION="the low-level library for netfilter related kernel/userspace communication"
+HOMEPAGE="http://www.netfilter.org/projects/libnfnetlink/"
+SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 6 18 ; then
+ die "${PN} requires at least 2.6.18 kernel version"
+ fi
+
+ #netfilter core team has changed some option names with kernel 2.6.20
+ if kernel_is lt 2 6 20 ; then
+ CONFIG_CHECK="IP_NF_CONNTRACK_NETLINK"
+ else
+ CONFIG_CHECK="NF_CT_NETLINK"
+ ERROR_NF_CT_NETLINK="CONFIG_NF_CT_NETLINK:\t is not set when it should be. You can activate it in the Core Netfilter Configuration"
+ fi
+
+ check_extra_config
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}