summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-10-07 14:03:48 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-10-07 14:03:48 +0000
commit8cbafc39dfe27cb0e261215af55f426bb4062bb3 (patch)
tree00b7b3297ef429c8272f7a9febf15751951262da /net-libs/libeXosip
parentVersion bump for new snapshot. Remove older version. (diff)
downloadhistorical-8cbafc39dfe27cb0e261215af55f426bb4062bb3.tar.gz
historical-8cbafc39dfe27cb0e261215af55f426bb4062bb3.tar.bz2
historical-8cbafc39dfe27cb0e261215af55f426bb4062bb3.zip
Version bump.
Package-Manager: portage-2.2.0_alpha134/cvs/Linux x86_64
Diffstat (limited to 'net-libs/libeXosip')
-rw-r--r--net-libs/libeXosip/ChangeLog9
-rw-r--r--net-libs/libeXosip/libeXosip-3.6.0.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/net-libs/libeXosip/ChangeLog b/net-libs/libeXosip/ChangeLog
index 1b40a98ef465..8b31b0ee1e32 100644
--- a/net-libs/libeXosip/ChangeLog
+++ b/net-libs/libeXosip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libeXosip
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libeXosip/ChangeLog,v 1.24 2012/01/06 15:04:46 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libeXosip/ChangeLog,v 1.25 2012/10/07 14:03:48 chithanh Exp $
+
+*libeXosip-3.6.0 (07 Oct 2012)
+
+ 07 Oct 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +libeXosip-3.6.0.ebuild:
+ Version bump.
06 Jan 2012; Brent Baude <ranger@gentoo.org> libeXosip-3.5.0.ebuild:
Marking libeXosip-3.5.0 ppc stable for bug 363311
@@ -97,4 +103,3 @@
21 Aug 2005; Daniel Black <dragonheart@gentoo.org> +metadata.xml,
+libeXosip-0.9.0.ebuild, +libeXosip-1.9.1_pre16.ebuild:
Initial import as per bug #94919. Thanks to Christoph Mockenhaupt
-
diff --git a/net-libs/libeXosip/libeXosip-3.6.0.ebuild b/net-libs/libeXosip/libeXosip-3.6.0.ebuild
new file mode 100644
index 000000000000..6c53dd23f435
--- /dev/null
+++ b/net-libs/libeXosip/libeXosip-3.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libeXosip/libeXosip-3.6.0.ebuild,v 1.1 2012/10/07 14:03:48 chithanh Exp $
+
+EAPI="2"
+
+inherit eutils
+
+MY_PV=${PV%.?}-${PV##*.}
+MY_PV=${PV}
+MY_P=${PN}2-${MY_PV}
+DESCRIPTION="library that hides the complexity of using the SIP protocol for multimedia session establishement"
+HOMEPAGE="http://savannah.nongnu.org/projects/exosip/"
+SRC_URI="http://download.savannah.nongnu.org/releases/exosip/${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x86-macos"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="+srv ssl"
+
+DEPEND=">=net-libs/libosip-3.6.0
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ --enable-mt \
+ $(use_enable ssl openssl) \
+ $(use_enable srv srvrec)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}