summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-11-02 18:11:18 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-11-02 18:11:18 +0000
commitfb305979ba398a224fda9698b552213b1c9dfa55 (patch)
tree6e291955a13d813b3fc36e367b986414ad4d84c1 /net-libs/daq
parentStable for HPPA (bug #343069). (diff)
downloadhistorical-fb305979ba398a224fda9698b552213b1c9dfa55.tar.gz
historical-fb305979ba398a224fda9698b552213b1c9dfa55.tar.bz2
historical-fb305979ba398a224fda9698b552213b1c9dfa55.zip
Initial commit. Ebuild provided by Jason Wallace #341009
Package-Manager: portage-2.2.0_alpha3/cvs/Linux x86_64
Diffstat (limited to 'net-libs/daq')
-rw-r--r--net-libs/daq/ChangeLog10
-rw-r--r--net-libs/daq/daq-0.2.ebuild61
-rw-r--r--net-libs/daq/metadata.xml21
3 files changed, 92 insertions, 0 deletions
diff --git a/net-libs/daq/ChangeLog b/net-libs/daq/ChangeLog
new file mode 100644
index 000000000000..b25d1bc43a28
--- /dev/null
+++ b/net-libs/daq/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-libs/daq
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/daq/ChangeLog,v 1.1 2010/11/02 18:11:18 patrick Exp $
+
+*daq-0.2 (02 Nov 2010)
+
+ 02 Nov 2010; Patrick Lauer <patrick@gentoo.org> +daq-0.2.ebuild,
+ +metadata.xml:
+ Initial commit. Ebuild provided by Jason Wallace #341009
+
diff --git a/net-libs/daq/daq-0.2.ebuild b/net-libs/daq/daq-0.2.ebuild
new file mode 100644
index 000000000000..3996f0e2e5ac
--- /dev/null
+++ b/net-libs/daq/daq-0.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/daq/daq-0.2.ebuild,v 1.1 2010/11/02 18:11:18 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Data Acquisition library, for packet I/O"
+HOMEPAGE="http://www.snort.org/"
+SRC_URI="http://www.snort.org/downloads/263 -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 afpacket dump +pcap"
+
+DEPEND="pcap? ( >=net-libs/libpcap-1.0.0 )
+ dump? ( >=net-libs/libpcap-1.0.0 )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable pcap pcap-module) \
+ $(use_enable afpacket afpacket-module) \
+ $(use_enable dump dump-module) \
+ --disable-ipfw-module \
+ --disable-bundled-modules
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog README
+
+}
+
+pkg_postinst() {
+
+ elog
+ elog "The Data Acquisition library (DAQ) for packet I/O replaces direct"
+ elog "calls to PCAP functions with an abstraction layer that facilitates"
+ elog "operation on a variety of hardware and software interfaces without"
+ elog "requiring changes to application such as Snort."
+ elog
+ elog "The only DAQ modules supported with this ebuild are AFpacket, PCAP,"
+ elog "and Dump. IPQ and NFQ will be supported in future versions of this"
+ elog "package."
+ elog
+ elog "Please see the README file for DAQ for information about specific"
+ elog "DAQ modules."
+ ewarn
+ ewarn "If you are reinstalling this package, you should also reinstall"
+ ewarn "packages that use this library for packet capture."
+ ewarn
+
+}
diff --git a/net-libs/daq/metadata.xml b/net-libs/daq/metadata.xml
new file mode 100644
index 000000000000..47ec1a590f61
--- /dev/null
+++ b/net-libs/daq/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>jason.r.wallace@gmail.com</email>
+ <name>Jason Wallace</name>
+</maintainer>
+<maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+</maintainer>
+
+<herd>netmon</herd>
+<longdescription>Data Acquisition library, for packet I/O with Snort 2.9 and later</longdescription>
+<use>
+<flag name='afpacket'>Build the AFPacket data acquisition module</flag>
+<flag name='dump'>Build the Dump data acquisition module</flag>
+<flag name='pcap'>Build the PCAP data acquisition module</flag>
+</use>
+</pkgmetadata>
+