summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-09-05 15:14:32 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-09-05 15:14:32 +0000
commit3e2104bf1d1e85cb85f7f25b7887420c2aa7052c (patch)
treeccab8d3fb312c7ad4997cf9bf826f3a2e32ae5ed /net-irc
parentmasked new xchat (diff)
downloadhistorical-3e2104bf1d1e85cb85f7f25b7887420c2aa7052c.tar.gz
historical-3e2104bf1d1e85cb85f7f25b7887420c2aa7052c.tar.bz2
historical-3e2104bf1d1e85cb85f7f25b7887420c2aa7052c.zip
new version, masked, removed a gnome/perl use check.
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog10
-rw-r--r--net-irc/xchat/files/digest-xchat-1.8.101
-rw-r--r--net-irc/xchat/xchat-1.8.10.ebuild103
3 files changed, 113 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index c193090091b0..bb9d2c18b6ce 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,7 +1,15 @@
# ChangeLog for net-irc/xchat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.15 2002/08/31 21:22:24 jmorgan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.16 2002/09/05 15:14:32 spider Exp $
+
+*xchat-1.8.10 (05 Sep 2002)
+ 05 Sep 2002; Spider <spider@gentoo.org> xchat-1.8.10.ebuild :
+ removed the perl/gnome code. this should be reimplemented.
+ updated the version
+ removed euIRC patch
+
+
*xchat-1.9.2-r1.ebuild (06 Aug 2002)
31 Aug 2002; Jack Morgan <jmorgan@gentoo.org> xchat-1.9.2-r1.ebuild/xchat-1.8.9-r3.ebuild:
diff --git a/net-irc/xchat/files/digest-xchat-1.8.10 b/net-irc/xchat/files/digest-xchat-1.8.10
new file mode 100644
index 000000000000..dfe9b6320489
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.8.10
@@ -0,0 +1 @@
+MD5 9295830df5d040d7723620322a65f89c xchat-1.8.10.tar.bz2 824407
diff --git a/net-irc/xchat/xchat-1.8.10.ebuild b/net-irc/xchat/xchat-1.8.10.ebuild
new file mode 100644
index 000000000000..65e4997be089
--- /dev/null
+++ b/net-irc/xchat/xchat-1.8.10.ebuild
@@ -0,0 +1,103 @@
+# Copyrigth 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.10.ebuild,v 1.1 2002/09/05 15:14:32 spider Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X-Chat is a graphical IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/1.8/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ python? ( >=dev-lang/python-2.2-r7 )
+ perl? ( >=sys-devel/perl-5.6.1 )
+ gnome? ( <gnome-base/gnome-panel-1.5.0
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ cp configure configure.orig
+
+ use python && ( \
+ local mylibs=`/usr/bin/python-config`
+ sed -e 's:PY_LIBS=".*":PY_LIBS="'"$mylibs"'":' \
+ configure.orig > configure
+ )
+}
+
+src_compile() {
+
+ local myopts myflags
+ use gnome \
+ && myopts="${myopts} --enable-gnome --enable-panel" \
+ || myopts="${myopts} --enable-gtkfe --disable-gnome --disable-zvt --disable-gdk-pixbuf"
+
+ use gnome \
+ && CFLAGS="${CFLAGS} -I/usr/include/orbit-1.0" \
+ || myopts="${myopts} --disable-gnome"
+
+ use gtk \
+ || myopts="${myopts} --disable-gtkfe"
+
+ use ssl \
+ && myopts="${myopts} --enable-openssl"
+
+ use perl \
+ || myopts="${myopts} --disable-perl"
+
+ use nls \
+ && myopts="${myopts} --enable-hebrew --enable-japanese-conv" \
+ || myopts="${myopts} --disable-nls"
+
+ if use x86
+ then
+ use mmx \
+ && myopts="${myopts} --enable-mmx" \
+ || myopts="${myopts} --disable-mmx"
+ fi
+
+ use ipv6 \
+ && myopts="${myopts} --enable-ipv6"
+
+ use python \
+ && myflags="`python-config`" \
+ && myopts="${myopts} --enable-python"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myopts} || die
+
+ emake || die
+}
+
+src_install() {
+
+ use kde && ( \
+ make \
+ prefix=${D}/usr \
+ utildir=${D}${KDEDIR}/share/applnk/Internet \
+ install || die
+ ) || ( \
+ make \
+ prefix=${D}/usr \
+ install || die
+ )
+
+ use gnome && ( \
+ insinto /usr/share/gnome/apps/Internet
+ doins xchat.desktop
+ )
+
+ dodoc AUTHORS COPYING ChangeLog README
+}