summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-11-03 07:33:46 +0000
committerSven Wegener <swegener@gentoo.org>2005-11-03 07:33:46 +0000
commit3e947a5a371435b3fd4e4f63619f3ccb3763e998 (patch)
tree31d790c958c6ad45d20c564e9d8bfc511590d6fb /net-irc/xchat-gnome
parentold (diff)
downloadhistorical-3e947a5a371435b3fd4e4f63619f3ccb3763e998.tar.gz
historical-3e947a5a371435b3fd4e4f63619f3ccb3763e998.tar.bz2
historical-3e947a5a371435b3fd4e4f63619f3ccb3763e998.zip
Version bump, bug #110766
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'net-irc/xchat-gnome')
-rw-r--r--net-irc/xchat-gnome/ChangeLog7
-rw-r--r--net-irc/xchat-gnome/files/digest-xchat-gnome-0.61
-rw-r--r--net-irc/xchat-gnome/xchat-gnome-0.6.ebuild68
3 files changed, 75 insertions, 1 deletions
diff --git a/net-irc/xchat-gnome/ChangeLog b/net-irc/xchat-gnome/ChangeLog
index 18ebed8acc43..ec5d150a8746 100644
--- a/net-irc/xchat-gnome/ChangeLog
+++ b/net-irc/xchat-gnome/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat-gnome
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.6 2005/08/28 12:06:10 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/ChangeLog,v 1.7 2005/11/03 07:33:46 swegener Exp $
+
+*xchat-gnome-0.6 (03 Nov 2005)
+
+ 03 Nov 2005; Sven Wegener <swegener@gentoo.org> +xchat-gnome-0.6.ebuild:
+ Version bump, bug #110766
*xchat-gnome-0.5 (28 Aug 2005)
diff --git a/net-irc/xchat-gnome/files/digest-xchat-gnome-0.6 b/net-irc/xchat-gnome/files/digest-xchat-gnome-0.6
new file mode 100644
index 000000000000..26a9d2237383
--- /dev/null
+++ b/net-irc/xchat-gnome/files/digest-xchat-gnome-0.6
@@ -0,0 +1 @@
+MD5 ef76823773da1e216c580cc0e289d2b4 xchat-gnome-0.6.tar.bz2 2191441
diff --git a/net-irc/xchat-gnome/xchat-gnome-0.6.ebuild b/net-irc/xchat-gnome/xchat-gnome-0.6.ebuild
new file mode 100644
index 000000000000..38416cfffb43
--- /dev/null
+++ b/net-irc/xchat-gnome/xchat-gnome-0.6.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-gnome/xchat-gnome-0.6.ebuild,v 1.1 2005/11/03 07:33:46 swegener Exp $
+
+inherit gnome2
+
+DESCRIPTION="GNOME frontend for the popular X-Chat IRC client"
+HOMEPAGE="http://xchat-gnome.navi.cx/"
+SRC_URI="http://flapjack.navi.cx/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="perl tcltk python ssl mmx ipv6 nls"
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ >=gnome-base/libgnome-2
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-vfs-2
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ python? ( dev-lang/python )
+ tcltk? ( dev-lang/tcl )
+ dbus? ( >=sys-apps/dbus-0.35 )
+ !net-irc/xchat"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ # We disable gtkfe and textfe, if you want them please use net-irc/xchat instead!
+ econf \
+ --disable-textfe \
+ --disable-gtkfe \
+ --enable-gnomefe \
+ --enable-shm \
+ $(use_enable ssl openssl) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcltk tcl) \
+ $(use_enable mmx) \
+ $(use_enable ipv6) \
+ $(use_enable dbus) \
+ $(use_enable nls) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install"
+
+ rm -f \
+ "${D}"/usr/share/applications/xchat.desktop \
+ "${D}"/usr/share/pixmaps/xchat.png
+
+ # install plugin development header
+ insinto /usr/include/xchat
+ doins src/common/xchat-plugin.h || die "doins failed"
+
+ dodoc src/fe-gnome/{BUGS,ChangeLog,TODO} || die "dodoc failed"
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+}