summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-09-20 19:10:45 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-09-20 19:10:45 +0000
commitc3710fd88aa33f5a29976cfe661f83b26ffe6eb7 (patch)
treecbbec9c6fbed5304d89a7fded4eb673c35626eb7 /net-irc/epic4
parent- fix improper use of hardened flag when pic flag should be used (diff)
downloadhistorical-c3710fd88aa33f5a29976cfe661f83b26ffe6eb7.tar.gz
historical-c3710fd88aa33f5a29976cfe661f83b26ffe6eb7.tar.bz2
historical-c3710fd88aa33f5a29976cfe661f83b26ffe6eb7.zip
Version bump
Package-Manager: portage-2.1.3.9
Diffstat (limited to 'net-irc/epic4')
-rw-r--r--net-irc/epic4/ChangeLog7
-rw-r--r--net-irc/epic4/epic4-2.8.ebuild94
-rw-r--r--net-irc/epic4/files/digest-epic4-2.89
3 files changed, 109 insertions, 1 deletions
diff --git a/net-irc/epic4/ChangeLog b/net-irc/epic4/ChangeLog
index 96547e28302e..f57b9f055316 100644
--- a/net-irc/epic4/ChangeLog
+++ b/net-irc/epic4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/epic4
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/ChangeLog,v 1.75 2007/05/14 16:50:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/ChangeLog,v 1.76 2007/09/20 19:10:44 armin76 Exp $
+
+*epic4-2.8 (20 Sep 2007)
+
+ 20 Sep 2007; Raúl Porcel <armin76@gentoo.org> +epic4-2.8.ebuild:
+ Version bump
14 May 2007; Raúl Porcel <armin76@gentoo.org>
-files/2.0-toggle-stop-screen.patch, -epic4-2.4.ebuild:
diff --git a/net-irc/epic4/epic4-2.8.ebuild b/net-irc/epic4/epic4-2.8.ebuild
new file mode 100644
index 000000000000..f43b1c230e83
--- /dev/null
+++ b/net-irc/epic4/epic4-2.8.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/epic4/epic4-2.8.ebuild,v 1.1 2007/09/20 19:10:44 armin76 Exp $
+
+inherit flag-o-matic eutils
+
+HELP_V="20050315"
+
+DESCRIPTION="Epic4 IRC Client"
+HOMEPAGE="http://epicsol.org/"
+SRC_URI="ftp://ftp.epicsol.org/pub/epic/EPIC4-PRODUCTION/${P}.tar.bz2
+ ftp://prbh.org/pub/epic/EPIC4-PRODUCTION/epic4-help-${HELP_V}.tar.gz
+ mirror://gentoo/epic4-local.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="ipv6 perl ssl"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( >=dev-libs/openssl-0.9.5 )"
+
+pkg_setup() {
+ if use perl && built_with_use dev-lang/perl ithreads
+ then
+ error "You need perl compiled with USE=\"-ithreads\" to be able to compile epic4."
+ die "perl with USE=\"-ithreads\" needed"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/epic-defaultserver.patch
+
+ rm -f ${WORKDIR}/help/Makefile
+ find ${WORKDIR}/help -type d -name CVS -print0 | xargs -0 rm -r
+}
+
+src_compile() {
+ replace-flags "-O?" "-O"
+
+ econf \
+ --libexecdir=/usr/lib/misc \
+ $(use_with ipv6) \
+ $(use_with perl) \
+ $(use_with ssl) \
+ || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install () {
+ einstall \
+ sharedir=${D}/usr/share \
+ libexecdir=${D}/usr/lib/misc || die "einstall failed"
+
+ dodoc BUG_FORM COPYRIGHT README KNOWNBUGS VOTES
+
+ cd ${S}/doc
+ docinto doc
+ dodoc \
+ *.txt colors EPIC* IRCII_VERSIONS local_vars missing new-load \
+ nicknames outputhelp SILLINESS TS4
+
+ insinto /usr/share/epic/help
+ doins -r ${WORKDIR}/help/* || die "doins failed"
+}
+
+pkg_postinst() {
+ if [ ! -f ${ROOT}/usr/share/epic/script/local ]
+ then
+ elog "/usr/share/epic/script/local does not exist, I will now"
+ elog "create it. If you do not like the look/feel of this file, or"
+ elog "if you'd prefer to use your own script, simply remove this"
+ elog "file. If you want to prevent this file from being installed"
+ elog "in the future, simply create an empty file with this name."
+ cp ${WORKDIR}/epic4-local ${ROOT}/usr/share/epic/script/local
+ elog
+ elog "This provided local startup script adds a number of nifty"
+ elog "features to Epic including tab completion, a comprehensive set"
+ elog "of aliases, and channel-by-channel logging. To prevent"
+ elog "unintentional conflicts with your own scripting, if either the"
+ elog "~/.ircrc or ~/.epicrc script files exist, then the local script"
+ elog "is *not* run. If you like the script but want to make careful"
+ elog "additions (such as selecting your usual servers or setting your"
+ elog "nickname), simply copy /usr/share/epic/script/local to ~/.ircrc"
+ elog "and then add your additions to the copy."
+ fi
+
+ # Fix for bug 59075
+ chmod 755 ${ROOT}/usr/share/epic/help
+}
diff --git a/net-irc/epic4/files/digest-epic4-2.8 b/net-irc/epic4/files/digest-epic4-2.8
new file mode 100644
index 000000000000..aa23de0a6098
--- /dev/null
+++ b/net-irc/epic4/files/digest-epic4-2.8
@@ -0,0 +1,9 @@
+MD5 606d1d9d36af1d491721e29425cb5069 epic4-2.8.tar.bz2 628431
+RMD160 e50d5baf7213afa24c75aa7fe2e5ccbc100b5cfa epic4-2.8.tar.bz2 628431
+SHA256 007f1cdb4ebd216104e7ac98237caac761b4f83170626e6f3acb034d574c2853 epic4-2.8.tar.bz2 628431
+MD5 9888d1af465ca72bf9a02487264071a5 epic4-help-20050315.tar.gz 332502
+RMD160 b4237357e905468ab4fd7710283d6bffee067c5e epic4-help-20050315.tar.gz 332502
+SHA256 714afd07348731e6ac82e1f6548acc12e84539b3106ab27fa5d00ed5696256f7 epic4-help-20050315.tar.gz 332502
+MD5 9e55061deeb335b75b3a9a293d2c190c epic4-local.bz2 6530
+RMD160 ed7e0d3f8c9d24794b4a9718ae31982934e4056f epic4-local.bz2 6530
+SHA256 4509ac8e491ac0b75dc5ddcef845b02b3610804dd98de9b5b98d58630be322cd epic4-local.bz2 6530