summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPhil Bordelon <sunflare@gentoo.org>2002-09-25 22:20:50 +0000
committerPhil Bordelon <sunflare@gentoo.org>2002-09-25 22:20:50 +0000
commitf7e26df5febf9ce2804bb5aa551e143ada5705df (patch)
treecca8444c9b14e0109fce3ccb7bf358d75f9818e2 /net-im
parentVersion update, which fixes a number of bugs. Also cleaned out old versions ... (diff)
downloadhistorical-f7e26df5febf9ce2804bb5aa551e143ada5705df.tar.gz
historical-f7e26df5febf9ce2804bb5aa551e143ada5705df.tar.bz2
historical-f7e26df5febf9ce2804bb5aa551e143ada5705df.zip
Updated version; fixes a number of crash bugs.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/silc-client/ChangeLog6
-rw-r--r--net-im/silc-client/files/digest-silc-client-0.9.5.11
-rw-r--r--net-im/silc-client/silc-client-0.9.5.1.ebuild56
3 files changed, 62 insertions, 1 deletions
diff --git a/net-im/silc-client/ChangeLog b/net-im/silc-client/ChangeLog
index e3a419d1de3f..d9af32eb2f3a 100644
--- a/net-im/silc-client/ChangeLog
+++ b/net-im/silc-client/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/ChangeLog,v 1.3 2002/06/25 20:18:29 sunflare Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/ChangeLog,v 1.4 2002/09/25 22:20:50 sunflare Exp $
+
+*silc-client-0.9.5.1 (25 Sep 2002)
+ 25 Sep 2002; Phil Bordelon <sunflare@gentoo.org> silc-client-0.9.5.1.ebuild :
+ Version bump. Fixes a number of crashes and the like.
*silc-client-0.9.4 (25 Jun 2002)
diff --git a/net-im/silc-client/files/digest-silc-client-0.9.5.1 b/net-im/silc-client/files/digest-silc-client-0.9.5.1
new file mode 100644
index 000000000000..f31a14ed60f6
--- /dev/null
+++ b/net-im/silc-client/files/digest-silc-client-0.9.5.1
@@ -0,0 +1 @@
+MD5 5d12658655f9eb681fe769b0e2bd0d89 silc-client-0.9.5.1.tar.bz2 1401244
diff --git a/net-im/silc-client/silc-client-0.9.5.1.ebuild b/net-im/silc-client/silc-client-0.9.5.1.ebuild
new file mode 100644
index 000000000000..ec93b9179fe3
--- /dev/null
+++ b/net-im/silc-client/silc-client-0.9.5.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/silc-client-0.9.5.1.ebuild,v 1.1 2002/09/25 22:20:50 sunflare Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An IRSSI-based text client for Secure Internet Live Conferencing."
+SRC_URI="http://www.silcnet.org/download/client/sources/${P}.tar.bz2"
+HOMEPAGE="http://silcnet.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="=dev-libs/glib-1.2*
+ perl? ( sys-devel/perl )
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ myconf="--with-ncurses"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ use socks5 && myconf="${myconf} --with-socks5"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/silc \
+ --with-helpdir=/usr/share/silc/help \
+ --with-docdir=/usr/share/doc/${P} \
+ --with-simdir=/usr/lib/silc/modules \
+ --with-logsdir=/var/log/silc \
+ ${myconf} || die "./configure failed"
+
+ make || die "make failed"
+}
+
+src_install () {
+ myflags=""
+ if [ "`use perl`" ]
+ then
+ R1="s/installsitearch='//"
+ R2="s/';//"
+ perl_sitearch="`perl -V:installsitearch | sed -e ${R1} -e ${R2}`"
+ myflags="${myflags} INSTALLPRIVLIB=${D}/usr"
+ myflags="${myflags} INSTALLARCHLIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITELIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITEARCH=${D}/${perl_sitearch}"
+ fi
+
+ make DESTDIR=${D} ${myflags} install || die "make install failed"
+ rmdir ${D}/usr/include
+}
+