summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-08-23 19:46:02 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-08-23 19:46:02 +0000
commit587c282004347d0e3525a125a4f6bf54283e728e (patch)
tree702c13844f952666f6cf95a1ec90d074156ebb8b /net-im
parentMask media-libs/opencv[ipp] instead of the whole package (diff)
downloadhistorical-587c282004347d0e3525a125a4f6bf54283e728e.tar.gz
historical-587c282004347d0e3525a125a4f6bf54283e728e.tar.bz2
historical-587c282004347d0e3525a125a4f6bf54283e728e.zip
Add net-im/leechcraft-azoth
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64
Diffstat (limited to 'net-im')
-rw-r--r--net-im/leechcraft-azoth/ChangeLog12
-rw-r--r--net-im/leechcraft-azoth/Manifest5
-rw-r--r--net-im/leechcraft-azoth/leechcraft-azoth-0.4.85.ebuild67
-rw-r--r--net-im/leechcraft-azoth/leechcraft-azoth-9999.ebuild65
-rw-r--r--net-im/leechcraft-azoth/metadata.xml26
5 files changed, 175 insertions, 0 deletions
diff --git a/net-im/leechcraft-azoth/ChangeLog b/net-im/leechcraft-azoth/ChangeLog
new file mode 100644
index 000000000000..1be35a51208f
--- /dev/null
+++ b/net-im/leechcraft-azoth/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for net-im/leechcraft-azoth
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/ChangeLog,v 1.1 2011/08/23 19:46:02 maksbotan Exp $
+
+*leechcraft-azoth-9999 (23 Aug 2011)
+*leechcraft-azoth-0.4.85 (23 Aug 2011)
+
+ 23 Aug 2011; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-azoth-0.4.85.ebuild, +leechcraft-azoth-9999.ebuild,
+ +metadata.xml:
+ Copy net-im/leechcraft-azoth from rion-overlay, thanks to 0xd34df00d
+
diff --git a/net-im/leechcraft-azoth/Manifest b/net-im/leechcraft-azoth/Manifest
new file mode 100644
index 000000000000..1ea9ea7c6cf0
--- /dev/null
+++ b/net-im/leechcraft-azoth/Manifest
@@ -0,0 +1,5 @@
+DIST leechcraft-0.4.85.tar.bz2 4048479 RMD160 e1a57dbe445ee595da73ea31028d7cd74dc1da95 SHA1 f755543d758e073068bbe2cda927212ce2733532 SHA256 8653262be3f922bff1cddb6c165743ddce803751226bc494fd952387058300c2
+EBUILD leechcraft-azoth-0.4.85.ebuild 2283 RMD160 dc198effedd21e50cddfa386f9c360aaa142931f SHA1 c4751eb4c37b6e0092444ffe419f132e9286e87d SHA256 7e3e103fb688bcf7525f9e6a5f3c1427147ae0157b754df5528a5ea8a117d08d
+EBUILD leechcraft-azoth-9999.ebuild 2270 RMD160 28cbef8a0f1f68030956478f93b072f51cb49bbd SHA1 3ec23530ccf957858ba5cf63ade7bb7e0ac39577 SHA256 7c9814c28962f2452069a5d7a377de5d2d25e3bac06aae909db9c849d78e5c55
+MISC ChangeLog 506 RMD160 35319352f086bb0ef7da8b645922d0a3a37ad3c4 SHA1 1ed17eaf88abc1d9744653948ad720c93602fc3c SHA256 e8818866d8314cfe18a91e7a7edce700112934229c98bf79b02fac8beb223cb4
+MISC metadata.xml 1746 RMD160 983445c48decedbf2d5d88bfcef8ea95f97996f6 SHA1 680086c85596a2789c1ef5fe3ab33a9bc7e6f749 SHA256 0e712e506a7978cd8c2919028aa8f15269babc03d1216b7d6fa9888afb789f92
diff --git a/net-im/leechcraft-azoth/leechcraft-azoth-0.4.85.ebuild b/net-im/leechcraft-azoth/leechcraft-azoth-0.4.85.ebuild
new file mode 100644
index 000000000000..d0540ca51725
--- /dev/null
+++ b/net-im/leechcraft-azoth/leechcraft-azoth-0.4.85.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/leechcraft-azoth-0.4.85.ebuild,v 1.1 2011/08/23 19:46:02 maksbotan Exp $
+
+EAPI="2"
+
+inherit leechcraft
+
+DESCRIPTION="Azoth, the modular IM client for LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +acetamide +adiumstyles +autoidler +autopaste +chathistory +crypt
+ +depester +embedmedia +herbicide +hili +juick +lastseen metacontacts
+ +modnok +nativeemoticons +p100q +rosenthal +standardstyles +xoox
+ +xtazy"
+
+DEPEND="=net-misc/leechcraft-core-${PV}
+ x11-libs/qt-webkit
+ x11-libs/qt-multimedia
+ xoox? ( net-libs/qxmpp[extras] media-libs/speex )
+ crypt? ( app-crypt/qca app-crypt/qca-gnupg )
+ "
+RDEPEND="${DEPEND}
+ modnok? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable crypt CRYPT)
+ $(cmake-utils_use_enable acetamide AZOTH_ACETAMIDE)
+ $(cmake-utils_use_enable adiumstyles AZOTH_ADIUMSTYLES)
+ $(cmake-utils_use_enable autoidler AZOTH_AUTOIDLER)
+ $(cmake-utils_use_enable autopaste AZOTH_AUTOPASTE)
+ $(cmake-utils_use_enable chathistory AZOTH_CHATHISTORY)
+ $(cmake-utils_use_enable depester AZOTH_DEPESTER)
+ $(cmake-utils_use_enable embedmedia AZOTH_EMBEDMEDIA)
+ $(cmake-utils_use_enable herbicide AZOTH_HERBICIDE)
+ $(cmake-utils_use_enable hili AZOTH_HILI)
+ $(cmake-utils_use_enable juick AZOTH_JUICK)
+ $(cmake-utils_use_enable lastseen AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable metacontacts AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable modnok AZOTH_MODNOK)
+ $(cmake-utils_use_enable nativeemoticons AZOTH_NATIVEEMOTICONS)
+ $(cmake-utils_use_enable p100q AZOTH_P100Q)
+ $(cmake-utils_use_enable rosenthal AZOTH_ROSENTHAL)
+ $(cmake-utils_use_enable standardstyles AZOTH_STANDARDSTYLES)
+ $(cmake-utils_use_enable xoox AZOTH_XOOX)
+ $(cmake-utils_use_enable xtazy AZOTH_XTAZY)
+ "
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use rosenthal; then
+ elog "You have enabled the Azoth Rosenthal plugin for"
+ elog "spellchecking. It uses Hunspell/Myspell dictionaries,"
+ elog "so install the ones for languages you use to enable"
+ elog "spellchecking."
+ fi
+}
diff --git a/net-im/leechcraft-azoth/leechcraft-azoth-9999.ebuild b/net-im/leechcraft-azoth/leechcraft-azoth-9999.ebuild
new file mode 100644
index 000000000000..36f46541ecbf
--- /dev/null
+++ b/net-im/leechcraft-azoth/leechcraft-azoth-9999.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/leechcraft-azoth/leechcraft-azoth-9999.ebuild,v 1.1 2011/08/23 19:46:02 maksbotan Exp $
+
+EAPI="2"
+
+inherit leechcraft
+
+DESCRIPTION="Azoth, the modular IM client for LeechCraft."
+
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +acetamide +adiumstyles +autoidler +autopaste +chathistory +crypt
+ +depester +embedmedia +herbicide +hili +juick +lastseen metacontacts
+ +modnok +nativeemoticons +p100q +rosenthal +standardstyles +xoox
+ +xtazy"
+
+DEPEND="=net-misc/leechcraft-core-${PV}
+ x11-libs/qt-webkit
+ x11-libs/qt-multimedia
+ xoox? ( =net-libs/qxmpp-9999[extras] media-libs/speex )
+ crypt? ( app-crypt/qca app-crypt/qca-gnupg )"
+RDEPEND="${DEPEND}
+ modnok? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ virtual/latex-base
+ )"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable crypt CRYPT)
+ $(cmake-utils_use_enable acetamide AZOTH_ACETAMIDE)
+ $(cmake-utils_use_enable adiumstyles AZOTH_ADIUMSTYLES)
+ $(cmake-utils_use_enable autoidler AZOTH_AUTOIDLER)
+ $(cmake-utils_use_enable autopaste AZOTH_AUTOPASTE)
+ $(cmake-utils_use_enable chathistory AZOTH_CHATHISTORY)
+ $(cmake-utils_use_enable depester AZOTH_DEPESTER)
+ $(cmake-utils_use_enable embedmedia AZOTH_EMBEDMEDIA)
+ $(cmake-utils_use_enable herbicide AZOTH_HERBICIDE)
+ $(cmake-utils_use_enable hili AZOTH_HILI)
+ $(cmake-utils_use_enable juick AZOTH_JUICK)
+ $(cmake-utils_use_enable lastseen AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable metacontacts AZOTH_LASTSEEN)
+ $(cmake-utils_use_enable modnok AZOTH_MODNOK)
+ $(cmake-utils_use_enable nativeemoticons AZOTH_NATIVEEMOTICONS)
+ $(cmake-utils_use_enable p100q AZOTH_P100Q)
+ $(cmake-utils_use_enable rosenthal AZOTH_ROSENTHAL)
+ $(cmake-utils_use_enable standardstyles AZOTH_STANDARDSTYLES)
+ $(cmake-utils_use_enable xoox AZOTH_XOOX)
+ $(cmake-utils_use_enable xtazy AZOTH_XTAZY)"
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use rosenthal; then
+ elog "You have enabled the Azoth Rosenthal plugin for"
+ elog "spellchecking. It uses Hunspell/Myspell dictionaries,"
+ elog "so install the ones for languages you use to enable"
+ elog "spellchecking."
+ fi
+}
diff --git a/net-im/leechcraft-azoth/metadata.xml b/net-im/leechcraft-azoth/metadata.xml
new file mode 100644
index 000000000000..57efff395d9c
--- /dev/null
+++ b/net-im/leechcraft-azoth/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>leechcraft</herd>
+<use>
+ <flag name="acetamide">Build Acetamide, the IRC protocol support</flag>
+ <flag name="adiumstyles">Build support for Adium styles</flag>
+ <flag name="autoidler">Build support for automatic status changing according to user idle time</flag>
+ <flag name="autopaste">Build Autopaste for pasting long texts to pastebins</flag>
+ <flag name="chathistory">Build ChatHistory which stories chat history</flag>
+ <flag name="depester">Build Depester which enables to ignore MUC participants</flag>
+ <flag name="embedmedia">Build EmbedMedia for embedding flash videos and images directly into chat windows</flag>
+ <flag name="herbicide">Build Herbicide, a basic antispam plugin</flag>
+ <flag name="hili">Build HiLi which allows to customize highlight settings in MUCs</flag>
+ <flag name="juick">Build plugin for the Juick.com microblogging service</flag>
+ <flag name="lastseen">Build plugin for client-side recording of the last online/available time</flag>
+ <flag name="metacontacts">Build plugin for metacontacts support</flag>
+ <flag name="modnok">Build Modnok for in-chat LaTeX formulae rendering</flag>
+ <flag name="nativeemoticons">Build support for native Azoth's emoticons packs</flag>
+ <flag name="p100q">Build p100q, plugin for psto.net microblogging service</flag>
+ <flag name="rosenthal">Build Rosenthal, the spellchecker plugin</flag>
+ <flag name="standardstyles">Build support for standard Azoth styles engine</flag>
+ <flag name="xoox">Build Xoox, gloox-based plugin for XMPP support</flag>
+ <flag name="xtazy">Build Xtazy for publishing currently playing tune</flag>
+</use>
+</pkgmetadata>