summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-05-31 20:54:34 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-05-31 20:54:34 +0000
commit52b05f06b671f20db2710c4bd02f7c43997b3197 (patch)
tree9a46cfc7cf230612eaf5c4612c326b2f9b1f09c9 /net-im
parentBump (diff)
downloadhistorical-52b05f06b671f20db2710c4bd02f7c43997b3197.tar.gz
historical-52b05f06b671f20db2710c4bd02f7c43997b3197.tar.bz2
historical-52b05f06b671f20db2710c4bd02f7c43997b3197.zip
Bump
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/Manifest4
-rw-r--r--net-im/gaim/files/digest-gaim-0.642
-rw-r--r--net-im/gaim/gaim-0.64.ebuild66
3 files changed, 70 insertions, 2 deletions
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index f3eb736b17a5..17321eadcf2f 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -1,10 +1,10 @@
MD5 12a99349f51ace3e6b5fd7b890eeaee7 gaim-0.62.ebuild 1849
MD5 99e0839b0b59b7ad6e2555b2fda15189 gaim-0.63-r1.ebuild 1839
-MD5 99e0839b0b59b7ad6e2555b2fda15189 gaim-0.64.ebuild 1839
+MD5 a8968336cdead7d4e4642d1a7689be66 gaim-0.64.ebuild 1836
MD5 d528dcaebdb49a6e3e6b062b5023a37a gaim-0.61.ebuild 1437
MD5 c312c7f2f86088e2cbae1c306fb009ee gaim-0.59.9-r1.ebuild 2173
MD5 5595ecee5df10f1cfa16a675fcc5cf06 gaim-0.63.ebuild 2133
-MD5 1d25ec1e43d931bcebabdcc5e4b77b46 ChangeLog 8272
+MD5 4dbdcad9464138ae74b0e5a752a1489d ChangeLog 8362
MD5 07beb4e67f5dd8cafed146e45b919144 files/digest-gaim-0.59.9-r1 128
MD5 9bed88f159974c776176e6ba02d778c2 files/digest-gaim-0.61 126
MD5 9f365202815e1944216b14ce27f288dd files/digest-gaim-0.62 126
diff --git a/net-im/gaim/files/digest-gaim-0.64 b/net-im/gaim/files/digest-gaim-0.64
new file mode 100644
index 000000000000..8a3820f0c994
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.64
@@ -0,0 +1,2 @@
+MD5 8876251a650a8341ca6969a4f5334082 gaim-0.64.tar.bz2 2559531
+MD5 c008810b46ba1ea4ea581615acdc68b6 encrypt-1.20.tar.gz 38074
diff --git a/net-im/gaim/gaim-0.64.ebuild b/net-im/gaim/gaim-0.64.ebuild
new file mode 100644
index 000000000000..a27b6fbfde5e
--- /dev/null
+++ b/net-im/gaim/gaim-0.64.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.64.ebuild,v 1.1 2003/05/31 20:54:23 lostlogic Exp $
+
+IUSE="nls perl spell ssl nas"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+EV=1.20
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2
+ ssl? ( mirror://sourceforge/gaim-encryption/encrypt-${EV}.tar.gz )"
+
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ nls? ( sys-devel/gettext )
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( dev-libs/openssl )
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ use ssl && {
+ cd ${S}/plugins
+ unpack encrypt-${EV}.tar.gz
+ cd encrypt
+ epatch patchfile.0.63
+ }
+}
+
+src_compile() {
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+
+ econf ${myconf} || die "Configuration failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS HACKING INSTALL NEWS README TODO ChangeLog
+}
+
+pkg_postinst() {
+ if [ `use ssl` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=ssl') to install"
+ ewarn "the gaim-encryption plugin ( http://gaim-encryption.sf.net )"
+ ewarn "this plugin is NOT supported by the Gaim project, and if you"
+ ewarn "expierence problems related to it, contact the Gentoo project"
+ ewarn "via http://bugs.gentoo.rog or the gaim-encryption project."
+ ewarn
+ fi
+}