summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2006-08-03 16:37:04 +0000
committerMarinus Schraal <foser@gentoo.org>2006-08-03 16:37:04 +0000
commit3d220f11d6003d3912de9751cde5652471cf628a (patch)
tree5ac24d7d276b97e8b62f25ba3042d8569afbb258 /net-im
parentfix the fix (diff)
downloadhistorical-3d220f11d6003d3912de9751cde5652471cf628a.tar.gz
historical-3d220f11d6003d3912de9751cde5652471cf628a.tar.bz2
historical-3d220f11d6003d3912de9751cde5652471cf628a.zip
fix connection issue on ppc
Package-Manager: portage-2.1
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gossip/ChangeLog8
-rw-r--r--net-im/gossip/files/digest-gossip-0.13-r13
-rw-r--r--net-im/gossip/files/gossip-0.13-ppc_conn_fix.patch63
-rw-r--r--net-im/gossip/gossip-0.13-r1.ebuild55
4 files changed, 128 insertions, 1 deletions
diff --git a/net-im/gossip/ChangeLog b/net-im/gossip/ChangeLog
index 8286019e835c..b5a8237ec2c0 100644
--- a/net-im/gossip/ChangeLog
+++ b/net-im/gossip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/gossip
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gossip/ChangeLog,v 1.43 2006/07/31 23:20:19 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gossip/ChangeLog,v 1.44 2006/08/03 16:37:04 foser Exp $
+
+*gossip-0.13-r1 (03 Aug 2006)
+
+ 03 Aug 2006; Marinus Schraal <foser@gentoo.org> gossip-0.13-r1.ebuild,
+ files/gossip-0.13-ppc_conn_fix.patch :
+ Add fix for connection issues on PPC
*gossip-0.13 (31 Jul 2006)
diff --git a/net-im/gossip/files/digest-gossip-0.13-r1 b/net-im/gossip/files/digest-gossip-0.13-r1
new file mode 100644
index 000000000000..32dcf8715cc0
--- /dev/null
+++ b/net-im/gossip/files/digest-gossip-0.13-r1
@@ -0,0 +1,3 @@
+MD5 d690a8f78e847ed3bbbb2fd183d17582 gossip-0.13.tar.bz2 1235572
+RMD160 8635631abd159a97966c7bbabe6801b8da07c005 gossip-0.13.tar.bz2 1235572
+SHA256 7f2d512fcf83ebc45e7d22c648994e580fe8f8e5fcf5a53dbcfda8803e4efff2 gossip-0.13.tar.bz2 1235572
diff --git a/net-im/gossip/files/gossip-0.13-ppc_conn_fix.patch b/net-im/gossip/files/gossip-0.13-ppc_conn_fix.patch
new file mode 100644
index 000000000000..e752c5a72f72
--- /dev/null
+++ b/net-im/gossip/files/gossip-0.13-ppc_conn_fix.patch
@@ -0,0 +1,63 @@
+diff -uNr gossip-0.13/protocols/jabber/gossip-sha.c gossip-0.13.patched/protocols/jabber/gossip-sha.c
+--- gossip-0.13/protocols/jabber/gossip-sha.c 2006-07-21 13:49:32.000000000 +0200
++++ gossip-0.13.patched/protocols/jabber/gossip-sha.c 2006-08-03 17:55:03.000000000 +0200
+@@ -67,9 +67,9 @@
+ extern "C" {
+ #endif
+
+-void SHA1Init (SHA1Context *sc);
+-void SHA1Update (SHA1Context *sc, const void *udata, guint32 len);
+-void SHA1Final (SHA1Context *sc, guint8 hash[SHA1_HASH_SIZE]);
++static void SHA1Init (SHA1Context *sc);
++static void SHA1Update (SHA1Context *sc, const void *udata, guint32 len);
++static void SHA1Final (SHA1Context *sc, guint8 hash[SHA1_HASH_SIZE]);
+
+ #ifdef __cplusplus
+ }
+@@ -77,7 +77,7 @@
+
+ #ifndef lint
+ static const char rcsid[] =
+- "$Id: gossip-0.13-ppc_conn_fix.patch,v 1.1 2006/08/03 16:37:04 foser Exp $";
++ "$Id: gossip-0.13-ppc_conn_fix.patch,v 1.1 2006/08/03 16:37:04 foser Exp $";
+ #endif /* !lint */
+
+ #define ROTL(x, n) (((x) << (n)) | ((x) >> (32 - (n))))
+@@ -182,7 +182,7 @@
+ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00
+ };
+
+-void
++static void
+ SHA1Init (SHA1Context *sc)
+ {
+ #ifdef RUNTIME_ENDIAN
+@@ -490,7 +490,7 @@
+ sc->hash[4] += e;
+ }
+
+-void
++static void
+ SHA1Update (SHA1Context *sc, const void *udata, guint32 len)
+ {
+ guint32 bufferBytesLeft;
+@@ -566,7 +566,7 @@
+ burnStack (sizeof (guint32[86]) + sizeof (guint32 *[5]) + sizeof (int));
+ }
+
+-void
++static void
+ SHA1Final (SHA1Context *sc, guint8 hash[SHA1_HASH_SIZE])
+ {
+ guint32 bytesToPad;
+diff -uNr gossip-0.13/protocols/jabber/Makefile.am gossip-0.13.patched/protocols/jabber/Makefile.am
+--- gossip-0.13/protocols/jabber/Makefile.am 2006-07-30 14:19:41.000000000 +0200
++++ gossip-0.13.patched/protocols/jabber/Makefile.am 2006-08-03 17:54:48.000000000 +0200
+@@ -2,6 +2,7 @@
+ -I. \
+ -I$(top_srcdir) \
+ -DPROTOCOLSDIR=\"$(datadir)/gossip/protocols\" \
++ -DRUNTIME_ENDIAN \
+ $(GOSSIP_JABBER_CFLAGS) $(WARN_CFLAGS)
+
+ noinst_LTLIBRARIES = libgossip-jabber.la
diff --git a/net-im/gossip/gossip-0.13-r1.ebuild b/net-im/gossip/gossip-0.13-r1.ebuild
new file mode 100644
index 000000000000..190de23d19ef
--- /dev/null
+++ b/net-im/gossip/gossip-0.13-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gossip/gossip-0.13-r1.ebuild,v 1.1 2006/08/03 16:37:04 foser Exp $
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="Lightweight Jabber client for GNOME"
+HOMEPAGE="http://developer.imendio.com/wiki/Gossip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="spell dbus libnotify"
+
+RDEPEND="|| ( x11-libs/libXScrnSaver
+ virtual/x11 )
+ >=dev-libs/glib-2.8
+ >=x11-libs/gtk+-2.8
+ >=gnome-base/libglade-2
+ >=gnome-base/gconf-1.2
+ >=dev-libs/libxml2-2.6.16
+ >=dev-libs/libxslt-1
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2
+ >=net-libs/loudmouth-1
+ spell? ( app-text/aspell )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )
+ dbus? ( >=sys-apps/dbus-0.31 )"
+
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.3.2
+ app-text/scrollkeeper
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35"
+
+G2CONF="${G2CONF} \
+ $(use_enable dbus) \
+ $(use_enable libnotify) \
+ $(use_enable spell aspell) "
+
+DOCS="AUTHORS README COPYING ChangeLog INSTALL NEWS README CONTRIBUTORS TODO"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # fix connection issues on ppc
+ epatch ${FILESDIR}/${P}-ppc_conn_fix.patch
+
+ eautomake
+
+}
+