summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2002-12-01 21:20:43 +0000
committerHannes Mehnert <hannes@gentoo.org>2002-12-01 21:20:43 +0000
commit3374428852474855cd7ce1363c05759fd0fe6a61 (patch)
treebbff0bcba5bb39460551db873cff3eed796601db /net-im
parentcorrect version, typo (diff)
downloadhistorical-3374428852474855cd7ce1363c05759fd0fe6a61.tar.gz
historical-3374428852474855cd7ce1363c05759fd0fe6a61.tar.bz2
historical-3374428852474855cd7ce1363c05759fd0fe6a61.zip
added fix for qt-3.1
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq/ChangeLog8
-rw-r--r--net-im/licq/files/1.2.0a-qt31.patch38
-rw-r--r--net-im/licq/files/digest-licq-1.2.0a-r21
-rw-r--r--net-im/licq/licq-1.2.0a-r2.ebuild74
4 files changed, 120 insertions, 1 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index 515d58069417..39262af99519 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/licq
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.5 2002/08/15 17:52:52 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.6 2002/12/01 21:20:42 hannes Exp $
+
+*licq-1.2.0a-r2 (01 Dec 2002)
+
+ 01 Dec 2002; Hannes Mehnert <hannes@gentoo.org> licq-1.2.0a-r2.ebuild:
+ added patch to work with qt-3.1. Thanks to toojays@toojays.net (John Steele
+ Scott) for submission (bug #11423)
*licq-1.2.0a-r1 (13 Aug 2002)
diff --git a/net-im/licq/files/1.2.0a-qt31.patch b/net-im/licq/files/1.2.0a-qt31.patch
new file mode 100644
index 000000000000..e7eda788032c
--- /dev/null
+++ b/net-im/licq/files/1.2.0a-qt31.patch
@@ -0,0 +1,38 @@
+Index: licq/plugins/qt-gui-1.2.0/src/awaymsgdlg.cpp
+===================================================================
+RCS file: /cvsroot/licq/qt-gui-1.2.0/src/awaymsgdlg.cpp,v
+retrieving revision 1.48
+diff -u -3 -p -r1.48 awaymsgdlg.cpp
+--- licq/plugins/qt-gui-1.2.0/src/awaymsgdlg.cpp 23 Feb 2001 10:28:43 -0000 1.48
++++ licq/plugins/qt-gui-1.2.0/src/awaymsgdlg.cpp 15 Nov 2002 15:39:00 -0000
+@@ -167,6 +167,13 @@ AwayMsgDlg::~AwayMsgDlg()
+ emit done();
+ }
+
++// Since QT3.1 final somehow this qdialog does not accept() the
++// closeEvent, so we force it to do so :)
++void AwayMsgDlg::closeEvent(QCloseEvent *e)
++{
++ e->accept();
++}
++
+ void AwayMsgDlg::slot_hints()
+ {
+ QString h = tr(hints);
+Index: licq/plugins/qt-gui-1.2.0/src/awaymsgdlg.h
+===================================================================
+RCS file: /cvsroot/licq/qt-gui-1.2.0/src/awaymsgdlg.h,v
+retrieving revision 1.21
+diff -u -3 -p -r1.21 awaymsgdlg.h
+--- licq/plugins/qt-gui-1.2.0/src/awaymsgdlg.h 12 Jul 2001 00:20:53 -0000 1.21
++++ licq/plugins/qt-gui-1.2.0/src/awaymsgdlg.h 15 Nov 2002 15:39:00 -0000
+@@ -14,6 +14,9 @@ public:
+ AwayMsgDlg(QWidget *parent = 0);
+ ~AwayMsgDlg();
+ void SelectAutoResponse(unsigned short status);
++
++private:
++ void closeEvent(QCloseEvent *);
+
+ protected:
+ MLEditWrap *mleAwayMsg;
diff --git a/net-im/licq/files/digest-licq-1.2.0a-r2 b/net-im/licq/files/digest-licq-1.2.0a-r2
new file mode 100644
index 000000000000..7b91e3648cbf
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.2.0a-r2
@@ -0,0 +1 @@
+MD5 3f977d83b36b26d1bc716be3e3336315 licq-1.2.0a.tar.bz2 1741476
diff --git a/net-im/licq/licq-1.2.0a-r2.ebuild b/net-im/licq/licq-1.2.0a-r2.ebuild
new file mode 100644
index 000000000000..c3739704f364
--- /dev/null
+++ b/net-im/licq/licq-1.2.0a-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.2.0a-r2.ebuild,v 1.1 2002/12/01 21:20:43 hannes Exp $
+
+IUSE="ssl socks5 qt kde"
+
+DESCRIPTION="ICQ Client with v8 support"
+HOMEPAGE="http://www.licq.org"
+LICENSE="GPL-2"
+
+DEPEND="${DEPEND}
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ qt? ( >=x11-libs/qt-3.0.0 )"
+
+SRC_URI="http://download.sourceforge.net/licq/${P}.tar.bz2"
+SLOT="2"
+KEYWORDS="x86"
+S=${WORKDIR}/${P}
+
+use kde && inherit kde-base
+use kde && need-kde 3.0
+
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${PV}-config.patch || die
+ patch -p1 < ${FILESDIR}/${PV}-qt31.patch || die
+}
+
+src_compile() {
+
+ local first_conf
+ use ssl || first_conf = "${first_conf} --disable-openssl"
+ use socks5 && first_conf = "${first_conf} --enable-socks5"
+
+ ./configure --host=${CHOST} --prefix=/usr ${first_conf} || die
+ emake || die
+
+ if [ "`use qt`" ]
+ then
+ # A hack to build against the latest QT:
+ local v
+ for v in /usr/qt/[0-9]
+ do
+ [ -d "${v}" ] && export QTDIR="${v}"
+ done
+ use kde && kde_src_compile myconf
+ use kde && second_conf="${second_conf} ${myconf} --with-kde"
+
+ # note! watch the --prefix=/usr placement;
+ # licq itself installs into /usr, but the
+ # optional kde/qt interface (to which second_conf belogns)
+ # installs its files in $KDE3DIR/{lib,share}/licq
+
+ cd plugins/qt-gui-1.2.0
+ ./configure --host=${CHOST} ${second_conf} --prefix=/usr || die
+ emake || die
+ fi
+
+}
+
+src_install() {
+
+ cd ${S}
+ make DESTDIR=${D} install || die
+ if [ "`use qt`" ]
+ then
+ cd plugins/qt-gui-1.2.0
+ make DESTDIR=${D} install || die
+ fi
+
+}