summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2004-07-06 11:32:45 +0000
committerGustavo Felisberto <humpback@gentoo.org>2004-07-06 11:32:45 +0000
commit4455d2e08ac45b71767bc6c89d45f91e8365259e (patch)
treecc2d3cc9dedc1fe4db507842914dae366c7a1db4 /net-im/yahoo-transport/yahoo-transport-2.3.2.ebuild
parentAdded to ~ppc (diff)
downloadhistorical-4455d2e08ac45b71767bc6c89d45f91e8365259e.tar.gz
historical-4455d2e08ac45b71767bc6c89d45f91e8365259e.tar.bz2
historical-4455d2e08ac45b71767bc6c89d45f91e8365259e.zip
version bump
Diffstat (limited to 'net-im/yahoo-transport/yahoo-transport-2.3.2.ebuild')
-rw-r--r--net-im/yahoo-transport/yahoo-transport-2.3.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-im/yahoo-transport/yahoo-transport-2.3.2.ebuild b/net-im/yahoo-transport/yahoo-transport-2.3.2.ebuild
new file mode 100644
index 000000000000..1b66b09eb281
--- /dev/null
+++ b/net-im/yahoo-transport/yahoo-transport-2.3.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/yahoo-transport/yahoo-transport-2.3.2.ebuild,v 1.1 2004/07/06 11:32:45 humpback Exp $
+
+inherit eutils
+
+DESCRIPTION="Open Source Jabber Server Yahoo transport"
+HOMEPAGE="http://yahoo-transport-2.jabberstudio.org/"
+SRC_URI="http://www.jabberstudio.org/files/yahoo-transport-2/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~hppa ~sparc"
+SLOT="0"
+IUSE=""
+DEPEND="=net-im/jabberd-1.4*"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ epatch ${FILESDIR}/yahoo-makefile.patch
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dodir /etc/jabber /usr/lib/jabberd
+ insinto /usr/lib/jabberd
+ doins yahoo-transport.so
+ insinto /etc/jabber
+ doins ${FILESDIR}/yahootrans.xml
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/yahoo-transport.init yahoo-transport
+ dodoc README ${FILESDIR}/README.Gentoo
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read /usr/share/doc/${P}/README.Gentoo.gz"
+ einfo "And please notice that now yahoo-transport comes with a init.d script"
+ einfo "dont forget to add it to your runlevel."
+ einfo
+}