summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-08-31 16:59:14 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-08-31 16:59:14 +0000
commitfa1bb77262762e0d53fbd71670bcb740b0a7895c (patch)
treef9802c837b6acd86a17dc011dcc34a28decf9a1d /net-im/silc-plugin
parentKEYWORDS amd64. (diff)
downloadhistorical-fa1bb77262762e0d53fbd71670bcb740b0a7895c.tar.gz
historical-fa1bb77262762e0d53fbd71670bcb740b0a7895c.tar.bz2
historical-fa1bb77262762e0d53fbd71670bcb740b0a7895c.zip
ChangeLog bug# fix, some QA fixes in ebuild
Diffstat (limited to 'net-im/silc-plugin')
-rw-r--r--net-im/silc-plugin/ChangeLog7
-rw-r--r--net-im/silc-plugin/Manifest4
-rw-r--r--net-im/silc-plugin/silc-plugin-1.0.1.ebuild32
3 files changed, 21 insertions, 22 deletions
diff --git a/net-im/silc-plugin/ChangeLog b/net-im/silc-plugin/ChangeLog
index 925769bed728..3c2c7a153127 100644
--- a/net-im/silc-plugin/ChangeLog
+++ b/net-im/silc-plugin/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for net-im/silc-plugin
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-plugin/ChangeLog,v 1.2 2004/08/31 15:33:45 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-plugin/ChangeLog,v 1.3 2004/08/31 16:59:14 ticho Exp $
+
+ 31 Aug 2004; <ticho@gentoo.org> silc-plugin-1.0.1.ebuild:
+ Some QA fixes (thanks to seemant)
*silc-plugin-1.0.1 (31 Aug 2004)
31 Aug 2004; <ticho@gentoo.org> +metadata.xml, +silc-plugin-1.0.1.ebuild:
- Initial import, closes bug #61189. Marked unstable on x86 and sparc.
+ Initial import, closes bug #60189. Marked unstable on x86 and sparc.
diff --git a/net-im/silc-plugin/Manifest b/net-im/silc-plugin/Manifest
index 35e02b5d03a6..ddfe9d62d060 100644
--- a/net-im/silc-plugin/Manifest
+++ b/net-im/silc-plugin/Manifest
@@ -1,4 +1,4 @@
-MD5 8ef83170bd497c5c2ec6b4fd2dd10b33 silc-plugin-1.0.1.ebuild 2540
-MD5 999313ba333b79e1a1f591609a00a17e ChangeLog 390
+MD5 88754ad1d690def5814c94c92a8553e0 silc-plugin-1.0.1.ebuild 2938
+MD5 a6e5bf81314803399c31efd69d8ee771 ChangeLog 487
MD5 3d21d1bc81cfd81bfd0b0b3b2123b71c metadata.xml 271
MD5 ce1069db2e4cfc5c0b0d4b988c6c053c files/digest-silc-plugin-1.0.1 202
diff --git a/net-im/silc-plugin/silc-plugin-1.0.1.ebuild b/net-im/silc-plugin/silc-plugin-1.0.1.ebuild
index 8d054ed2f061..aba2d420d893 100644
--- a/net-im/silc-plugin/silc-plugin-1.0.1.ebuild
+++ b/net-im/silc-plugin/silc-plugin-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-plugin/silc-plugin-1.0.1.ebuild,v 1.1 2004/08/31 15:11:48 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-plugin/silc-plugin-1.0.1.ebuild,v 1.2 2004/08/31 16:59:14 ticho Exp $
IRSSI_PV=0.8.9
@@ -8,7 +8,7 @@ DESCRIPTION="A SILC plugin for Irssi"
HOMEPAGE="http://penguin-breeder.org/silc/"
SRC_URI="http://irssi.org/files/irssi-${IRSSI_PV}.tar.bz2
http://silcnet.org/download/client/sources/silc-client-${PV}.tar.gz
- http://penguin-breeder.org/silc/download/silc-plugin-${PV}.tar.gz"
+ http://penguin-breeder.org/silc/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -23,11 +23,6 @@ S_SILC="${S}/../silc-client-${PV}"
S_IRSSI="${S}/../irssi-${IRSSI_PV}"
src_compile() {
- local myconf
-
- echo ${S_SILC}
- use debug && myconf="${myconf} --enable-debug"
- use pic && myconf="${myconf} --with-pic"
echo
einfo "Preparing silc-client\n"
@@ -35,33 +30,34 @@ src_compile() {
econf --with-helpdir=${D}/usr/share/irssi/help/silc/ \
--without-libtoolfix \
--enable-static \
- ${myconf}
- make -C lib
+ `use_with pic` \
+ `use_enable debug` || die "silc-client configure failed"
+ make -C lib || die "silc-client's lib compilation failed"
echo
einfo "Patching irssi source for silc-plugin\n"
cd ${S}
- make patch IRSSI=${S_IRSSI} SILC=${S_SILC}
+ make patch IRSSI=${S_IRSSI} SILC=${S_SILC} || die "patching irssi sources failed"
echo
einfo "Configuring irssi\n"
cd ${S_IRSSI}
- econf --sysconfdir=/etc
+ econf --sysconfdir=/etc || die "irssi configure failed"
echo
einfo "Compiling silc-plugin\n"
- make -C src/perl
- make -C src/fe-common/silc
- make -C src/silc/core
+ make -C src/perl || die "irssi's src/perl compilation failed"
+ make -C src/fe-common/silc || die "irssi's src/fe-common/silc compilation failed"
+ make -C src/silc/core || die "irssi's src/silc/core compilation failed"
}
src_install() {
cd ${S_IRSSI}
- make -C src/perl/silc DESTDIR=${D} install
- make -C src/fe-common/silc DESTDIR=${D} install
- make -C src/silc/core install DESTDIR=${D} install
+ make -C src/perl/silc DESTDIR=${D} install || die "irssi's src/perl/silc installation failed"
+ make -C src/fe-common/silc DESTDIR=${D} install || die "irssi's src/fe-common/silc installation failed"
+ make -C src/silc/core install DESTDIR=${D} install || die "irssi's src/silc/core installation failed"
cd ${S_SILC}
- make -C irssi/docs/help install
+ make -C irssi/docs/help install || die "silc-client's helpfiles installation failed"
cd ${S}
insinto /usr/share/irssi/scripts