summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-25 16:02:44 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-25 16:02:44 +0000
commite238048b7783f57af26f3a51419a6c62831564aa (patch)
tree8863c3d0bd91b55a6425a8af22022afa1439eab2 /net-im/licq
parenttouchups (diff)
downloadhistorical-e238048b7783f57af26f3a51419a6c62831564aa.tar.gz
historical-e238048b7783f57af26f3a51419a6c62831564aa.tar.bz2
historical-e238048b7783f57af26f3a51419a6c62831564aa.zip
touchups
Diffstat (limited to 'net-im/licq')
-rw-r--r--net-im/licq/licq-1.2.6.ebuild48
1 files changed, 21 insertions, 27 deletions
diff --git a/net-im/licq/licq-1.2.6.ebuild b/net-im/licq/licq-1.2.6.ebuild
index 881af24a5f60..d62d1dc66339 100644
--- a/net-im/licq/licq-1.2.6.ebuild
+++ b/net-im/licq/licq-1.2.6.ebuild
@@ -1,34 +1,32 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.2.6.ebuild,v 1.1 2003/04/22 22:36:12 drobbins Exp $
-
-IUSE="ssl socks5 qt kde gtk ncurses"
-
-DESCRIPTION="ICQ Client with v8 support"
-HOMEPAGE="http://www.licq.org"
-LICENSE="GPL-2"
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.2.6.ebuild,v 1.2 2003/04/25 16:02:44 vapier Exp $
inherit kde-base
need-kde 3.0
-#we can't have conditional dependencies so "use kde && inherit kde-base"
-#won't work -- messes up dep caching.
+DESCRIPTION="ICQ Client with v8 support"
+HOMEPAGE="http://www.licq.org/"
+SRC_URI="http://download.sourceforge.net/licq/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="x86"
+IUSE="ssl socks5 qt kde gtk ncurses"
-#need-kde and their eclass friends inject things into DEPEND. But we only
-#want them enabled if the kde USE flag is set. We get around this in the
-#following dep lines:
+# we can't have conditional dependencies so "use kde && inherit kde-base"
+# won't work -- messes up dep caching.
-RDEPEND="kde? ( $DEPEND )"
-DEPEND="kde? ( $DEPEND )
+# need-kde and their eclass friends inject things into DEPEND. But we only
+# want them enabled if the kde USE flag is set. We get around this in the
+# following dep lines:
+RDEPEND="kde? ( ${DEPEND} )"
+DEPEND="kde? ( ${DEPEND} )
ssl? ( >=dev-libs/openssl-0.9.6 )
- qt? ( >=x11-libs/qt-3.0.0 )
+ qt? ( >=x11-libs/qt-3.0.0 )
gtk? ( =x11-libs/gtk+-1.2* )
ncurses? ( sys-libs/ncurses )"
-SRC_URI="http://download.sourceforge.net/licq/${P}.tar.bz2"
-SLOT="2"
-KEYWORDS="x86"
-
src_unpack() {
unpack ${A}
@@ -62,14 +60,12 @@ src_unpack() {
}
src_compile() {
-
local first_conf
use ssl || first_conf="${first_conf} --disable-openssl"
use socks5 && first_conf="${first_conf} --enable-socks5"
econf ${first_conf} || die
emake || die
-
# Create the various plug-ins
@@ -108,10 +104,10 @@ src_compile() {
# Now the console plug-in
if [ "`use ncurses `" ]
then
- cd ${S}/plugins/console
- einfo "Compiling the Console plug-in"
- econf || die
- emake || die
+ cd ${S}/plugins/console
+ einfo "Compiling the Console plug-in"
+ econf || die
+ emake || die
fi
# The Auto-Responder plug-in
@@ -128,8 +124,6 @@ src_compile() {
}
src_install() {
-
- cd ${S}
make DESTDIR=${D} install || die
dodoc ChangeLog INSTALL README*