summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-01-18 04:04:21 +0000
committerDon Seiler <rizzo@gentoo.org>2004-01-18 04:04:21 +0000
commitea2b63ba255c74975dc85a62b3043e1e4ca00083 (patch)
tree31dde87db3fd889eb1c55843b1039a2294e8beb2 /net-im/gaim
parentPatch to fix some signal handling on big-endian (non x86) machines. Found in... (diff)
downloadhistorical-ea2b63ba255c74975dc85a62b3043e1e4ca00083.tar.gz
historical-ea2b63ba255c74975dc85a62b3043e1e4ca00083.tar.bz2
historical-ea2b63ba255c74975dc85a62b3043e1e4ca00083.zip
Patch to fix some signal handling on big-endian (non x86) machines. Found in gaim bug tracker
Diffstat (limited to 'net-im/gaim')
-rw-r--r--net-im/gaim/Manifest4
-rw-r--r--net-im/gaim/files/digest-gaim-0.75-r51
-rw-r--r--net-im/gaim/files/gaim-0.76cvs-varargs.diff41
-rw-r--r--net-im/gaim/gaim-0.75-r5.ebuild102
4 files changed, 146 insertions, 2 deletions
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index f25a5a2fe4d6..676bac5bf92f 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -1,7 +1,7 @@
MD5 ad0496c54abd8bcefbbca7bb90960162 gaim-0.74-r1.ebuild 3813
MD5 5fe791bbf70387b44fd2d1d5e857d5cc gaim-0.67.ebuild 2183
MD5 b3e470f59582b9b3379db2326e647e77 gaim-0.72-r2.ebuild 3331
-MD5 39fedcc40fdcd4c31ef62dc538a46219 gaim-0.75-r5.ebuild 3211
+MD5 815977e3668d398244588c9414a0fe14 gaim-0.75-r5.ebuild 3211
MD5 a45de72081c78f61dfc3c17285997f7c gaim-0.75-r2.ebuild 3505
MD5 4a8680f8755cca3c465dc0e05bca0c23 gaim-0.75.ebuild 3918
MD5 78be5b331aa107c0ef01b5252eb8c87e gaim-0.72-r1.ebuild 2890
@@ -9,7 +9,7 @@ MD5 2123f7e893431bde56239a40bc7b9d91 gaim-0.75-r4.ebuild 3165
MD5 cecb719b31af4ea5759fffa397de52be gaim-0.72.ebuild 2508
MD5 9b0c0eb504517576c7d18406c8c52324 gaim-0.74-r2.ebuild 3858
MD5 456550d7203f82316e7e598a7655c2fa gaim-0.75-r1.ebuild 3505
-MD5 d898d1de143c06a21afd482c4abf77d0 ChangeLog 19945
+MD5 586a751edd51ac597ec1afa4694131b6 ChangeLog 20175
MD5 19b3cafbbe380403d46cccc45a984b80 metadata.xml 481
MD5 80a22e998261eddcd12f4b93c227bd55 gaim-0.75-r3.ebuild 3116
MD5 4989dc76d941288934c783f52931762d files/gaim-0.75-static-prpls.patch 3710
diff --git a/net-im/gaim/files/digest-gaim-0.75-r5 b/net-im/gaim/files/digest-gaim-0.75-r5
new file mode 100644
index 000000000000..63510235452c
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.75-r5
@@ -0,0 +1 @@
+MD5 9935155985c25dfc9b59183de0da3c30 gaim-0.75.tar.bz2 3370977
diff --git a/net-im/gaim/files/gaim-0.76cvs-varargs.diff b/net-im/gaim/files/gaim-0.76cvs-varargs.diff
new file mode 100644
index 000000000000..fcafd00bdfc8
--- /dev/null
+++ b/net-im/gaim/files/gaim-0.76cvs-varargs.diff
@@ -0,0 +1,41 @@
+Index: src/signals.c
+===================================================================
+RCS file: /cvsroot/gaim/gaim/src/signals.c,v
+retrieving revision 1.13
+retrieving revision 1.14
+diff -u -u -r1.13 -r1.14
+--- src/signals.c 10 Jan 2004 04:04:56 -0000 1.13
++++ src/signals.c 13 Jan 2004 02:15:46 -0000 1.14
+@@ -415,6 +415,7 @@
+ GaimSignalData *signal_data;
+ GaimSignalHandlerData *handler_data;
+ GList *l, *l_next;
++ va_list tmp;
+
+ g_return_if_fail(instance != NULL);
+ g_return_if_fail(signal != NULL);
+@@ -440,16 +441,22 @@
+
+ handler_data = (GaimSignalHandlerData *)l->data;
+
++ /* This is necessary because a va_list may only be
++ * evaluated once */
++ va_copy(tmp, args);
++
+ if (handler_data->use_vargs)
+ {
+- ((void (*)(va_list, void *))handler_data->cb)(args,
++ ((void (*)(va_list, void *))handler_data->cb)(tmp,
+ handler_data->data);
+ }
+ else
+ {
+- signal_data->marshal(handler_data->cb, args,
++ signal_data->marshal(handler_data->cb, tmp,
+ handler_data->data, NULL);
+ }
++
++ va_end(tmp);
+ }
+ }
+
diff --git a/net-im/gaim/gaim-0.75-r5.ebuild b/net-im/gaim/gaim-0.75-r5.ebuild
new file mode 100644
index 000000000000..c5e970b1c9f5
--- /dev/null
+++ b/net-im/gaim/gaim-0.75-r5.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.75-r5.ebuild,v 1.1 2004/01/18 04:04:13 rizzo Exp $
+
+IUSE="nls perl spell nas mozilla cjk debug ssl"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2"
+RESTRICT="nomirror"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1
+ >=sys-apps/sed-4.0.0 )
+ mozilla? ( net-www/mozilla )
+ !mozilla? ( dev-libs/nss )
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+PDEPEND="ssl? ( net-im/gaim-encryption )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2 || die
+ cd ${S}
+ epatch ${FILESDIR}/gaim-0.75-static-prpls.patch
+ epatch ${FILESDIR}/gaim-0.76cvs-varargs.diff
+ use cjk && epatch ${FILESDIR}/gaim-0.74_cjk_gtkconv.patch
+}
+
+src_compile() {
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+ use debug && myconf="${myconf} --enable-debug"
+
+ NSS_LIB=/usr/lib
+ NSS_INC=/usr/include
+ use mozilla || {
+ # Only need to specify this if no pkgconfig from mozilla
+ myconf="${myconf} --with-nspr-includes=${NSS_INC}/nspr"
+ myconf="${myconf} --with-nss-includes=${NSS_INC}/nss"
+ myconf="${myconf} --with-nspr-libs=${NSS_LIB}"
+ myconf="${myconf} --with-nss-libs=${NSS_LIB}"
+ }
+
+ econf ${myconf} || die "Configuration failed"
+ use perl && sed -i -e 's:^\(PERL_MM_PARAMS =.*PREFIX=\)\(.*\):\1'${D}'\2:' plugins/perl/Makefile
+
+ einfo "Replacing -Os CFLAG with -O2"
+ replace-flags -Os -O2
+
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
+
+ # Copy header files for gaim plugin use
+ dodir /usr/include/gaim/src
+ cp config.h ${D}/usr/include/gaim/
+ cd ${S}/src
+ #tar cf - `find . -name \*.h` | (cd ${D}/usr/include/gaim/src ; tar xvf -)
+ tar cf - *.h | (cd ${D}/usr/include/gaim/src ; tar xvf -)
+ assert "Failed to install header files to /usr/include/gaim"
+}
+
+pkg_postinst() {
+ if [ `use cjk` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=cjk') to compile with"
+ ewarn "a patch for CJK support. Please be aware that this patch"
+ ewarn "causes problems with skkinput. kinput2 works fine. Details"
+ ewarn "can be found at http://bugs.gentoo.org/show_bug.cgi?id=24657#c23"
+ ewarn
+ fi
+
+ if [ `use ssl` ]; then
+ einfo
+ einfo "The gaim-encryption package is now it's own package in portage"
+ einfo "To install it run:"
+ einfo
+ einfo "emerge gaim-encryption"
+ einfo
+ einfo "All of your existing gaim-encryption settings are still"
+ einfo "in place and will be recognized when gaim-encryption is"
+ einfo "installed. You may need to re-enable gaim-encryption in"
+ einfo "your gaim preferences."
+ einfo
+ fi
+}