summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2003-08-19 17:54:53 +0000
committerDon Seiler <rizzo@gentoo.org>2003-08-19 17:54:53 +0000
commit0852d79c6c9038c35ff8f5d2068af924612f9480 (patch)
tree3bc18689063b3339cd52ad0a3cda1fddbfff97ea /net-im/gaim
parentVersion bump for gaim and gaim-encryption. (diff)
downloadhistorical-0852d79c6c9038c35ff8f5d2068af924612f9480.tar.gz
historical-0852d79c6c9038c35ff8f5d2068af924612f9480.tar.bz2
historical-0852d79c6c9038c35ff8f5d2068af924612f9480.zip
Version bump for gaim and gaim-encryption.
Diffstat (limited to 'net-im/gaim')
-rw-r--r--net-im/gaim/Manifest4
-rw-r--r--net-im/gaim/files/digest-gaim-0.672
-rw-r--r--net-im/gaim/gaim-0.67.ebuild78
3 files changed, 82 insertions, 2 deletions
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index d33d2ef2e932..148927f162f8 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -1,11 +1,11 @@
-MD5 842c2dcbb846ba0a28abdf271f183be5 gaim-0.67.ebuild 2101
+MD5 2644363a2af5679ca70cb373699454f9 gaim-0.67.ebuild 2191
MD5 63f5d5add45a34870e61e2e39d70b919 gaim-0.63-r1.ebuild 1835
MD5 b7dbbfc3c88f5a2f775f6eaf0a7e5f90 gaim-0.66-r4.ebuild 1996
MD5 563bfa3942598d75f097aaf618e9bfe3 gaim-0.66.ebuild 2163
MD5 c312c7f2f86088e2cbae1c306fb009ee gaim-0.59.9-r1.ebuild 2173
MD5 a7d996e60f8521e458599e249267645f gaim-0.66-r3.ebuild 1994
MD5 75b5b8d5565abeeca9fdad904cc765d6 gaim-0.65-r1.ebuild 2167
-MD5 fc6d27623640fe2a5a6e5a0e13f196b8 ChangeLog 11980
+MD5 d7b0ee9d6553fba660924d32d8874597 ChangeLog 11980
MD5 769049deda9ae8a4f818bc6b74a5baff metadata.xml 506
MD5 00c380b0a716b59b0c7e2c6eca2d3510 gaim-0.66-r2.ebuild 1951
MD5 07beb4e67f5dd8cafed146e45b919144 files/digest-gaim-0.59.9-r1 128
diff --git a/net-im/gaim/files/digest-gaim-0.67 b/net-im/gaim/files/digest-gaim-0.67
new file mode 100644
index 000000000000..38f228e59918
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.67
@@ -0,0 +1,2 @@
+MD5 1b28da4a480e2217f0b653bb95a5e4c5 gaim-0.67.tar.bz2 2934003
+MD5 14ec83a64c56c0dd97e7f64e7e799851 gaim-encryption-2.06.tar.gz 221115
diff --git a/net-im/gaim/gaim-0.67.ebuild b/net-im/gaim/gaim-0.67.ebuild
new file mode 100644
index 000000000000..5f0928c7339a
--- /dev/null
+++ b/net-im/gaim/gaim-0.67.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.67.ebuild,v 1.1 2003/08/19 17:54:46 rizzo Exp $
+
+IUSE="nls perl spell nas ssl"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+EV=2.06
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2
+ ssl? ( mirror://sourceforge/gaim-encryption/gaim-encryption-${EV}.tar.gz )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ppc ~alpha ~sparc"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( dev-libs/nss )
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ use ssl && {
+ cd ${S}/plugins
+ unpack gaim-encryption-${EV}.tar.gz
+ }
+ #use cjk && {
+ #cd ${S}/src
+ #epatch ${FILESDIR}/gaim_gtkimcontext_patch.diff
+ #}
+}
+
+src_compile() {
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+
+ econf ${myconf} || die "Configuration failed"
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+
+ use ssl && {
+ cd ${S}/plugins/gaim-encryption-${EV}
+ econf || die "Configuration failed for encryption"
+ emake || die "Make failed for encryption"
+ }
+}
+
+src_install() {
+ einstall || die "Install failed"
+ use ssl && {
+ cd ${S}/plugins/gaim-encryption-${EV}
+ einstall || die "Install failed for encryption"
+ cd ${S}
+ }
+ dodoc ABOUT-NLS AUTHORS HACKING INSTALL NEWS README TODO ChangeLog
+}
+
+pkg_postinst() {
+ if [ `use ssl` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=ssl') to install"
+ ewarn "the gaim-encryption plugin ( http://gaim-encryption.sf.net/ )"
+ ewarn "this plugin is NOT supported by the Gaim project, and if you"
+ ewarn "expierence problems related to it, contact the Gentoo project"
+ ewarn "via http://bugs.gentoo.org/ or the gaim-encryption project."
+ ewarn
+ fi
+}