summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-09 04:19:08 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-09 04:19:08 +0000
commite75e44c47bcdfe2d6c97ba5485faf78a445ed849 (patch)
tree271c5996dd3e5e6ad3efccae82d997cf323c6625 /net-ftp
parent*** empty log message *** (diff)
downloadhistorical-e75e44c47bcdfe2d6c97ba5485faf78a445ed849.tar.gz
historical-e75e44c47bcdfe2d6c97ba5485faf78a445ed849.tar.bz2
historical-e75e44c47bcdfe2d6c97ba5485faf78a445ed849.zip
*** empty log message ***
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lukemftp/files/digest-lukemftp-1.51
-rw-r--r--net-ftp/lukemftp/lukemftp-1.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/net-ftp/lukemftp/files/digest-lukemftp-1.5 b/net-ftp/lukemftp/files/digest-lukemftp-1.5
new file mode 100644
index 000000000000..51571a363bc9
--- /dev/null
+++ b/net-ftp/lukemftp/files/digest-lukemftp-1.5
@@ -0,0 +1 @@
+MD5 0cd0fc2e3fca21ca56647b2e1142a01a lukemftp-1.5.tar.gz
diff --git a/net-ftp/lukemftp/lukemftp-1.5.ebuild b/net-ftp/lukemftp/lukemftp-1.5.ebuild
new file mode 100644
index 000000000000..a80724ce8992
--- /dev/null
+++ b/net-ftp/lukemftp/lukemftp-1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2000-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Michael Nazaroff <newandcreative@yahoo.com>
+# net-ftp/ftp/lukemftp-1.5-r1.ebuild,v 1
+
+P=lukemftp-1.5
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="NetBSD FTP client"
+SRC_URI="ftp://ftp.netbsd.org/pub/NetBSD/misc/lukemftp/${A}"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1"
+
+src_compile() {
+ try ./configure --host=$${CHOST} --prefix=/usr --enable-editcomplete --program-prefix=lukemftp
+ try make
+}
+
+src_install() {
+ newbin src/ftp lukemftp
+ newman src/ftp.1 lukemftp.1
+ dodoc COPYING ChangeLog README* THANKS NEWS
+}
+
+pkg_postinst() {
+ if [ ! -e ${ROOT}usr/bin/ftp ]
+ then
+ ln -s lukemftp ${ROOT}/usr/bin/ftp
+ fi
+}
+