summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJerry Alexandratos <jerry@gentoo.org>2001-07-20 17:56:53 +0000
committerJerry Alexandratos <jerry@gentoo.org>2001-07-20 17:56:53 +0000
commit79eaf906f11f9bb17781fea803f153f00bc57bd7 (patch)
treecd597a42348f23bad30a8f44a906d30d490c8249 /net-ftp
parentupdated to 1.8.1 (diff)
downloadhistorical-79eaf906f11f9bb17781fea803f153f00bc57bd7.tar.gz
historical-79eaf906f11f9bb17781fea803f153f00bc57bd7.tar.bz2
historical-79eaf906f11f9bb17781fea803f153f00bc57bd7.zip
General cleanup. Mostly formatting. Changed sysconfdir to point to
/etc/proftpd instead of /etc/proftp (prog name is proftpd).
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/proftpd/files/proftpd.conf35
-rw-r--r--net-ftp/proftpd/proftpd-1.2.1.ebuild88
-rw-r--r--net-ftp/proftpd/proftpd-1.2.2_rc3.ebuild88
3 files changed, 107 insertions, 104 deletions
diff --git a/net-ftp/proftpd/files/proftpd.conf b/net-ftp/proftpd/files/proftpd.conf
index b201a1b94df2..69498d53bd90 100644
--- a/net-ftp/proftpd/files/proftpd.conf
+++ b/net-ftp/proftpd/files/proftpd.conf
@@ -3,16 +3,16 @@
# and a single anonymous login. It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.
-ServerName "ProFTPD Default Installation"
-ServerType inetd
-DefaultServer on
-AuthPAM off
-AuthPAMConfig ftp
+ServerName "ProFTPD Default Installation"
+ServerType inetd
+DefaultServer on
+AuthPAM off
+AuthPAMConfig ftp
# Port 21 is the standard FTP port.
-Port 21
+Port 21
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
-Umask 022
+Umask 022
# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
@@ -20,31 +20,31 @@ Umask 022
# in inetd mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
-MaxInstances 30
+MaxInstances 30
# Set the user and group that the server normally runs at.
-User nobody
-Group nogroup
+User nobody
+Group nogroup
# Normally, we want files to be overwriteable.
<Directory /*>
- AllowOverwrite on
+ AllowOverwrite on
</Directory>
# A basic anonymous configuration, no upload directories.
<Anonymous ~ftp>
- User ftp
- Group ftp
+ User ftp
+ Group ftp
# We want clients to be able to login with "anonymous" as well as "ftp"
- UserAlias anonymous ftp
+ UserAlias anonymous ftp
# Limit the maximum number of anonymous logins
- MaxClients 10
+ MaxClients 10
# We want 'welcome.msg' displayed at login, and '.message' displayed
# in each newly chdired directory.
- DisplayLogin welcome.msg
- DisplayFirstChdir .message
+ DisplayLogin welcome.msg
+ DisplayFirstChdir .message
# Limit WRITE everywhere in the anonymous chroot
<Limit WRITE>
@@ -52,4 +52,3 @@ Group nogroup
</Limit>
</Anonymous>
-
diff --git a/net-ftp/proftpd/proftpd-1.2.1.ebuild b/net-ftp/proftpd/proftpd-1.2.1.ebuild
index 78454ea07be3..e4940d566ed1 100644
--- a/net-ftp/proftpd/proftpd-1.2.1.ebuild
+++ b/net-ftp/proftpd/proftpd-1.2.1.ebuild
@@ -1,23 +1,22 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.1.ebuild,v 1.1 2001/04/29 19:32:17 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.1.ebuild,v 1.2 2001/07/20 17:56:53 jerry Exp $
S=${WORKDIR}/${P}
DESCRIPTION="proftpd."
SRC_URI="ftp://ftp.proftpd.org/distrib/${P}.tar.bz2
- http://www.lastditcheffort.org/aah/src/mod_sql-3.1.5.patch.tar.gz"
+ http://www.lastditcheffort.org/aah/src/mod_sql-3.1.5.patch.tar.gz"
HOMEPAGE="http://www.proftpd.net/"
DEPEND="virtual/glibc
- pam? ( >=sys-libs/pam-0.75 )
- mysql? ( >=dev-db/mysql-3.23.26 )
- ldap? ( >=net-nds/openldap-1.2.11 )
- postgres? ( >=dev-db/postgresql-7.1 )"
+ pam? ( >=sys-libs/pam-0.75 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ postgres? ( >=dev-db/postgresql-7.1 )"
src_unpack() {
-
unpack ${P}.tar.bz2
cd ${S}
gzip -dc ${DISTDIR}/mod_sql-3.1.5.patch.tar.gz | patch -p0
@@ -27,52 +26,55 @@ src_compile() {
local modules
local myinc
modules="mod_ratio:mod_readme:mod_linuxprivs"
- if [ "`use pam`" ] ; then
- modules="$modules:mod_pam"
+
+ if [ "`use pam`" ]; then
+ modules="$modules:mod_pam"
fi
- if [ "`use mysql`" ] ; then
- modules="$modules:mod_sql:mod_sql_mysql"
- else
- if [ "`use postgres`" ] ; then
- modules="$modules:mod_sql:mod_sql_postgres"
- myinc="/usr/include/postgresql"
- fi
+
+ if [ "`use mysql`" ]; then
+ modules="$modules:mod_sql:mod_sql_mysql"
+ elif [ "`use postgres`" ]; then
+ modules="$modules:mod_sql:mod_sql_postgres"
+ myinc="/usr/include/postgresql"
fi
- if [ "`use ldap`" ] ; then
- modules="$modules:mod_ldap"
+
+ if [ "`use ldap`" ]; then
+ modules="$modules:mod_ldap"
fi
- if [ "$myinc" ] ; then
- myinc="--with-includes=$myinc"
+ if [ "$myinc" ]; then
+ myinc="--with-includes=$myinc"
fi
-
+
./configure --host=${CHOST} --prefix=/usr --sbindir=/usr/sbin \
- --sysconfdir=/etc/proftp --localstatedir=/var/run --mandir=/usr/share/man \
- --with-modules=$modules --disable-sendfile --enable-shadow --enable-autoshadow $myinc
- try make
+ --sysconfdir=/etc/proftpd --localstatedir=/var/run \
+ --mandir=/usr/share/man --with-modules=$modules \
+ --disable-sendfile --enable-shadow --enable-autoshadow $myinc
+ try make
}
src_install() {
- try make install prefix=${D}/usr sysconfdir=${D}/etc/proftp \
- mandir=${D}/usr/share/man \
- localstatedir=${D}/var/run sbindir=${D}/usr/sbin
-
- into /usr
- dodir /home/ftp
- dobin contrib/genuser.pl
- dodoc COPYING CREDITS ChangeLog NEWS
- dodoc README*
- cd doc
- dodoc API Changes-1.2.0pre3 license.txt GetConf ShowUndocumented
- dodoc Undocumented.txt development.notes
- docinto html
- dodoc *.html
- docinto rfc
- dodoc rfc/*.txt
- cp ${FILESDIR}/proftpd.conf ${D}/etc/proftp
-}
-
+ try make install prefix=${D}/usr sysconfdir=${D}/etc/proftpd \
+ mandir=${D}/usr/share/man localstatedir=${D}/var/run \
+ sbindir=${D}/usr/sbin
+ into /usr
+ dodir /home/ftp
+ dobin contrib/genuser.pl
+ dodoc COPYING CREDITS ChangeLog NEWS
+ dodoc README*
+ cd doc
+ dodoc API Changes-1.2.0pre3 license.txt GetConf ShowUndocumented
+ dodoc Undocumented.txt development.notes
+ docinto html
+ dodoc *.html
+ docinto rfc
+ dodoc rfc/*.txt
+ cp ${FILESDIR}/proftpd.conf ${D}/etc/proftpd
+ insinto /etc/rc.d/init.d
+ insopts -m 0755
+ doins ${FILESDIR}/proftpd
+}
diff --git a/net-ftp/proftpd/proftpd-1.2.2_rc3.ebuild b/net-ftp/proftpd/proftpd-1.2.2_rc3.ebuild
index c34ff81f098d..c37f83cf6afc 100644
--- a/net-ftp/proftpd/proftpd-1.2.2_rc3.ebuild
+++ b/net-ftp/proftpd/proftpd-1.2.2_rc3.ebuild
@@ -1,24 +1,23 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.2_rc3.ebuild,v 1.1 2001/06/23 21:34:37 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.2_rc3.ebuild,v 1.2 2001/07/20 17:56:53 jerry Exp $
P=${PN}-1.2.2rc3
S=${WORKDIR}/${P}
DESCRIPTION="proftpd."
SRC_URI="ftp://ftp.proftpd.org/distrib/${P}.tar.bz2
- http://www.lastditcheffort.org/aah/src/mod_sql-3.2.2.tar.gz"
+ http://www.lastditcheffort.org/aah/src/mod_sql-3.2.2.tar.gz"
HOMEPAGE="http://www.proftpd.net/"
DEPEND="virtual/glibc
- pam? ( >=sys-libs/pam-0.75 )
- mysql? ( >=dev-db/mysql-3.23.26 )
- ldap? ( >=net-nds/openldap-1.2.11 )
- postgres? ( >=dev-db/postgresql-7.1 )"
+ pam? ( >=sys-libs/pam-0.75 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ postgres? ( >=dev-db/postgresql-7.1 )"
src_unpack() {
-
unpack ${P}.tar.bz2
cd ${S}/contrib
unpack mod_sql-3.2.2.tar.gz
@@ -28,52 +27,55 @@ src_compile() {
local modules
local myinc
modules="mod_ratio:mod_readme:mod_linuxprivs"
- if [ "`use pam`" ] ; then
- modules="$modules:mod_pam"
+
+ if [ "`use pam`" ]; then
+ modules="$modules:mod_pam"
fi
- if [ "`use mysql`" ] ; then
- modules="$modules:mod_sql:mod_sql_mysql"
- else
- if [ "`use postgres`" ] ; then
- modules="$modules:mod_sql:mod_sql_postgres"
- myinc="/usr/include/postgresql"
- fi
+
+ if [ "`use mysql`" ]; then
+ modules="$modules:mod_sql:mod_sql_mysql"
+ elif [ "`use postgres`" ]; then
+ modules="$modules:mod_sql:mod_sql_postgres"
+ myinc="/usr/include/postgresql"
fi
- if [ "`use ldap`" ] ; then
- modules="$modules:mod_ldap"
+
+ if [ "`use ldap`" ]; then
+ modules="$modules:mod_ldap"
fi
- if [ "$myinc" ] ; then
- myinc="--with-includes=$myinc"
+ if [ "$myinc" ]; then
+ myinc="--with-includes=$myinc"
fi
-
+
./configure --host=${CHOST} --prefix=/usr --sbindir=/usr/sbin \
- --sysconfdir=/etc/proftp --localstatedir=/var/run --mandir=/usr/share/man \
- --with-modules=$modules --disable-sendfile --enable-shadow --enable-autoshadow $myinc
- try make
+ --sysconfdir=/etc/proftpd --localstatedir=/var/run \
+ --mandir=/usr/share/man --with-modules=$modules \
+ --disable-sendfile --enable-shadow --enable-autoshadow $myinc
+ try make
}
src_install() {
- try make install prefix=${D}/usr sysconfdir=${D}/etc/proftp \
- mandir=${D}/usr/share/man \
- localstatedir=${D}/var/run sbindir=${D}/usr/sbin
-
- into /usr
- dodir /home/ftp
- dobin contrib/genuser.pl
- dodoc COPYING CREDITS ChangeLog NEWS
- dodoc README* contrib/README.mod_sql
- cd doc
- dodoc API Changes-1.2.0pre3 license.txt GetConf ShowUndocumented
- dodoc Undocumented.txt development.notes
- docinto html
- dodoc *.html
- docinto rfc
- dodoc rfc/*.txt
- cp ${FILESDIR}/proftpd.conf ${D}/etc/proftp
-}
-
+ try make install prefix=${D}/usr sysconfdir=${D}/etc/proftpd \
+ mandir=${D}/usr/share/man localstatedir=${D}/var/run \
+ sbindir=${D}/usr/sbin
+ into /usr
+ dodir /home/ftp
+ dobin contrib/genuser.pl
+ dodoc COPYING CREDITS ChangeLog NEWS
+ dodoc README* contrib/README.mod_sql
+ cd doc
+ dodoc API Changes-1.2.0pre3 license.txt GetConf ShowUndocumented
+ dodoc Undocumented.txt development.notes
+ docinto html
+ dodoc *.html
+ docinto rfc
+ dodoc rfc/*.txt
+ cp ${FILESDIR}/proftpd.conf ${D}/etc/proftpd
+ insinto /etc/rc.d/init.d
+ insopts -m 0755
+ doins ${FILESDIR}/proftpd
+}