summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorParag Mehta <pm@gentoo.org>2001-07-03 05:34:34 +0000
committerParag Mehta <pm@gentoo.org>2001-07-03 05:34:34 +0000
commit689e0f9a9edadd56dcdf75424b5acf0cb381f52e (patch)
treea992fe3fa888547cb3bb565b03aeccb782fc7cbe /net-ftp
parentBuild CD instructions. (diff)
downloadhistorical-689e0f9a9edadd56dcdf75424b5acf0cb381f52e.tar.gz
historical-689e0f9a9edadd56dcdf75424b5acf0cb381f52e.tar.bz2
historical-689e0f9a9edadd56dcdf75424b5acf0cb381f52e.zip
Made modifications to start pure-ftpd with system users in pkg_config().
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/pure-ftpd/files/digest-pure-ftpd-0.98.7-r11
-rw-r--r--net-ftp/pure-ftpd/pure-ftpd-0.98.7-r1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/net-ftp/pure-ftpd/files/digest-pure-ftpd-0.98.7-r1 b/net-ftp/pure-ftpd/files/digest-pure-ftpd-0.98.7-r1
new file mode 100644
index 000000000000..f6c4a53075df
--- /dev/null
+++ b/net-ftp/pure-ftpd/files/digest-pure-ftpd-0.98.7-r1
@@ -0,0 +1 @@
+MD5 381169cc31fdebfa2d414cd264d8485b pure-ftpd-0.98.7.tar.gz
diff --git a/net-ftp/pure-ftpd/pure-ftpd-0.98.7-r1.ebuild b/net-ftp/pure-ftpd/pure-ftpd-0.98.7-r1.ebuild
new file mode 100644
index 000000000000..c5269a86ce08
--- /dev/null
+++ b/net-ftp/pure-ftpd/pure-ftpd-0.98.7-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Prakash Shetty (Crux) <ps@gnuos.org>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A Fast Production Quality FTP Server"
+SRC_URI="http://prdownloads.sourceforge.net/pureftpd/${A}"
+HOMEPAGE="http://pureftpd.sourceforge.net"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/pam-0.75"
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr --with-throttling --with-virtualhosts\
+ --with-ratios --with-largefile
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make DESTDIR=${D} install
+ dodoc COPYING ChangeLog README README.Configuration-File
+ dodoc README.Contrib README.LDAP README.Netfilter
+ dodir /etc/pure-ftpd
+}
+
+pkg_config() {
+ echo "This config script will add pftpd lines to your /etc/xinetd.conf."
+ echo "Press control-C to abort, hit Enter to continue."
+ echo
+ read
+ cat ${FILESDIR}/pftpd.xinetd >> ${ROOT}etc/xinetd.conf
+ ln -s /dev/null /etc/pure-ftpd/127.0.0.1
+ /etc/rc.d/init.d/svc-xinetd restart
+ echo "Modifications applied."
+}
+
+
+