summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-01-31 04:47:49 +0000
committerDonny Davies <woodchip@gentoo.org>2002-01-31 04:47:49 +0000
commitbe41bcb315d8966d64c5947c9868f4d8b133a6cb (patch)
tree6a3f3dc4d602e86bd27f342af74b318d1e85afaf /net-ftp/lftp
parentupdato (diff)
downloadhistorical-be41bcb315d8966d64c5947c9868f4d8b133a6cb.tar.gz
historical-be41bcb315d8966d64c5947c9868f4d8b133a6cb.tar.bz2
historical-be41bcb315d8966d64c5947c9868f4d8b133a6cb.zip
updated version.
also close bug #192.
Diffstat (limited to 'net-ftp/lftp')
-rw-r--r--net-ftp/lftp/files/digest-lftp-2.4.91
-rw-r--r--net-ftp/lftp/lftp-2.4.9.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/net-ftp/lftp/files/digest-lftp-2.4.9 b/net-ftp/lftp/files/digest-lftp-2.4.9
new file mode 100644
index 000000000000..f8a8a45c1f52
--- /dev/null
+++ b/net-ftp/lftp/files/digest-lftp-2.4.9
@@ -0,0 +1 @@
+MD5 a92f6259b052ba49ae0b45ff8faa8633 lftp-2.4.9.tar.bz2 1101824
diff --git a/net-ftp/lftp/lftp-2.4.9.ebuild b/net-ftp/lftp/lftp-2.4.9.ebuild
new file mode 100644
index 000000000000..2d5aface6c4f
--- /dev/null
+++ b/net-ftp/lftp/lftp-2.4.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/lftp/lftp-2.4.9.ebuild,v 1.1 2002/01/31 04:47:49 woodchip Exp $
+
+DESCRIPTION="Groovy little ftp client"
+HOMEPAGE="http://ftp.yars.free.net/projects/lftp/"
+
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/${P}.tar.bz2
+ http://metalab.unc.edu/pub/Linux/system/network/file-transfer/${P}.tar.bz2"
+
+RDEPEND="virtual/glibc >=sys-libs/ncurses-5.1 ssl? ( >=dev-libs/openssl-0.9.6 )"
+DEPEND="${RDEPEND} nls? ( sys-devel/gettext )"
+
+src_compile() {
+
+ local myconf
+ use nls || myconf="--disable-nls"
+ use ssl || myconf="${myconf} --without-ssl"
+
+ export CFLAGS="-fno-exceptions -fno-rtti ${CFLAGS}"
+ export CXXFLAGS="-fno-exceptions -fno-rtti ${CXXFLAGS}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/lftp \
+ --without-modules \
+ --mandir=/usr/share/man \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+
+ make install DESTDIR=${D} || die
+
+ #hrmph, empty..
+ rm -rf ${D}/usr/lib
+
+ dodoc BUGS COPYING ChangeLog FAQ FEATURES MIRRORS \
+ NEWS README* THANKS TODO
+
+}