summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-06-13 13:24:06 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-06-13 13:24:06 +0000
commite8eff3bc586ed5b9b463559b9afe58aa4cf6c919 (patch)
treea15ac9435933158f56ad61be0b1372c3565b77bf /net-ftp/ftp
parentssl/tls enabled ftp client (diff)
downloadhistorical-e8eff3bc586ed5b9b463559b9afe58aa4cf6c919.tar.gz
historical-e8eff3bc586ed5b9b463559b9afe58aa4cf6c919.tar.bz2
historical-e8eff3bc586ed5b9b463559b9afe58aa4cf6c919.zip
ssl/tls enabled ftp client
Diffstat (limited to 'net-ftp/ftp')
-rw-r--r--net-ftp/ftp/Manifest4
-rw-r--r--net-ftp/ftp/files/digest-ftp-0.17-r31
-rw-r--r--net-ftp/ftp/files/netkit-ftp-0.17+ssl-0.2+auth.diff12
-rw-r--r--net-ftp/ftp/ftp-0.17-r3.ebuild46
4 files changed, 61 insertions, 2 deletions
diff --git a/net-ftp/ftp/Manifest b/net-ftp/ftp/Manifest
index da399fa52d4d..469085e4f460 100644
--- a/net-ftp/ftp/Manifest
+++ b/net-ftp/ftp/Manifest
@@ -1,7 +1,7 @@
-MD5 50c1973e8c1fb0c3ca3bb19139a7234f ftp-0.17-r3.ebuild 1064
+MD5 422779f038ee24a20f4e7252397a006a ftp-0.17-r3.ebuild 1066
MD5 c1e0ead72511622c46ceb36967104042 ftp-0.17-r2.ebuild 994
MD5 ea292842e221c5ff4ce55de024122b93 ftp-0.17-r1.ebuild 803
-MD5 d89ba5a0a9ef9d94434d21b70e97187b ChangeLog 1515
+MD5 df47ecc1607fa4bf30aacb8f3970cb28 ChangeLog 1826
MD5 b2e1a338f350747a22bc8bf6ea438c4f files/netkit-ftp-0.17+ssl-0.2.diff 45639
MD5 036b2200a177f3266c5cbb3f4d5e4ed5 files/digest-ftp-0.17-r1 66
MD5 036b2200a177f3266c5cbb3f4d5e4ed5 files/digest-ftp-0.17-r2 66
diff --git a/net-ftp/ftp/files/digest-ftp-0.17-r3 b/net-ftp/ftp/files/digest-ftp-0.17-r3
new file mode 100644
index 000000000000..d98bdd29a960
--- /dev/null
+++ b/net-ftp/ftp/files/digest-ftp-0.17-r3
@@ -0,0 +1 @@
+MD5 94441610c9b86ef45c4c6ec609444060 netkit-ftp-0.17.tar.gz 53934
diff --git a/net-ftp/ftp/files/netkit-ftp-0.17+ssl-0.2+auth.diff b/net-ftp/ftp/files/netkit-ftp-0.17+ssl-0.2+auth.diff
new file mode 100644
index 000000000000..8bbf23a8e241
--- /dev/null
+++ b/net-ftp/ftp/files/netkit-ftp-0.17+ssl-0.2+auth.diff
@@ -0,0 +1,12 @@
+diff -urN netkit-ftp-0.17.old/ftp/ftp.c netkit-ftp-0.17.new/ftp/ftp.c
+--- netkit-ftp-0.17.old/ftp/ftp.c 2003-03-18 18:33:49.000000000 -0300
++++ netkit-ftp-0.17.new/ftp/ftp.c 2003-03-18 18:37:17.000000000 -0300
+@@ -1811,7 +1811,7 @@
+ */
+ if (ssl_secure_flag)
+ return ERROR;
+- } else if (n == CONTINUE ) {
++ } else if (n == CONTINUE || n == COMPLETE) {
+ /* do SSL */
+ ssl_con=(SSL *)SSL_new(ssl_ctx);
+
diff --git a/net-ftp/ftp/ftp-0.17-r3.ebuild b/net-ftp/ftp/ftp-0.17-r3.ebuild
new file mode 100644
index 000000000000..e9de034440b4
--- /dev/null
+++ b/net-ftp/ftp/ftp-0.17-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftp/ftp-0.17-r3.ebuild,v 1.1 2003/06/13 13:24:03 seemant Exp $
+
+IUSE="ssl"
+
+inherit eutils
+
+MY_P=netkit-${P}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Standard Linux FTP client with optional SSL support"
+SRC_URI="ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/${MY_P}.tar.gz"
+HOMEPAGE="http://www.hcs.harvard.edu/~dholland/computers/netkit.html"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ ssl? ( dev-libs/openssl )"
+
+DEPEND=">=sys-apps/sed-4
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ if [ "`use ssl`" ]; then
+ epatch ${FILESDIR}/${MY_P}+ssl-0.2.diff
+ epatch ${FILESDIR}/${MY_P}+ssl-0.2+auth.diff
+ fi
+}
+
+src_compile() {
+ ./configure --prefix=/usr || die
+ sed -i "s:-pipe -O2:${CFLAGS}:" MCONFIG
+ emake || die
+}
+
+src_install() {
+ into /usr
+ dobin ftp/ftp
+ doman ftp/ftp.1 ftp/netrc.5
+ dodoc ChangeLog README BUGS
+}