summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-05-29 03:28:42 +0000
committerDonny Davies <woodchip@gentoo.org>2003-05-29 03:28:42 +0000
commitc66492473185a03e1bfe4a55fb56d031192aa47e (patch)
tree37ad1d23d42e47e8485ebcee8660651ffbb2c200 /net-fs
parentAdd SAMBA_3_0 CVS snapshot from 20030528 (diff)
downloadhistorical-c66492473185a03e1bfe4a55fb56d031192aa47e.tar.gz
historical-c66492473185a03e1bfe4a55fb56d031192aa47e.tar.bz2
historical-c66492473185a03e1bfe4a55fb56d031192aa47e.zip
Add SAMBA_3_0 CVS snapshot from 20030528
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/Manifest4
-rw-r--r--net-fs/samba/files/digest-samba-3.0_alpha24-r12
-rw-r--r--net-fs/samba/files/samba-pdb_ldap-exop.patch116
-rw-r--r--net-fs/samba/samba-3.0_alpha24-r1.ebuild368
4 files changed, 488 insertions, 2 deletions
diff --git a/net-fs/samba/Manifest b/net-fs/samba/Manifest
index ddee2a9007f9..bda7528f58de 100644
--- a/net-fs/samba/Manifest
+++ b/net-fs/samba/Manifest
@@ -1,8 +1,8 @@
MD5 b4f7c9e6b05c610bf52033ed430de265 samba-2.2.8.ebuild 10688
MD5 ffaa2e0509dbf5a45ca4e11c784e797a samba-2.2.8a.ebuild 10687
-MD5 52229aa2203b2d88075c9f40d4a1c5c1 samba-3.0_alpha24-r1.ebuild 9823
+MD5 6f15d0e1faa1312b73f954ccae2867e6 samba-3.0_alpha24-r1.ebuild 9928
MD5 46aef10a567ec3e66120a6e1c8bdc362 samba-3.0_alpha23.ebuild 9178
-MD5 b8d5ff900339cb96fc619cfae4ce51c2 ChangeLog 8355
+MD5 2ab0faba442e90d708515fc02c81cb5b ChangeLog 8355
MD5 033f952b5f3e9b41f652cc8c54b71740 samba-3.0_alpha22.ebuild 8922
MD5 23bf9d13bd13e51abb07688b00cab9b6 files/winbind-init 896
MD5 9780745de080ee53a34c1b2f9fb1f228 files/digest-samba-2.2.8a 135
diff --git a/net-fs/samba/files/digest-samba-3.0_alpha24-r1 b/net-fs/samba/files/digest-samba-3.0_alpha24-r1
new file mode 100644
index 000000000000..55b3d49af87c
--- /dev/null
+++ b/net-fs/samba/files/digest-samba-3.0_alpha24-r1
@@ -0,0 +1,2 @@
+MD5 9a9b4c191452d2e4656c1ca98581830f samba_3_0_20030528.tar.bz2 4807871
+MD5 cacc32f21812494993e32be558b91bdd samba-vscan-0.3.2b.tar.bz2 69479
diff --git a/net-fs/samba/files/samba-pdb_ldap-exop.patch b/net-fs/samba/files/samba-pdb_ldap-exop.patch
new file mode 100644
index 000000000000..7d866782d587
--- /dev/null
+++ b/net-fs/samba/files/samba-pdb_ldap-exop.patch
@@ -0,0 +1,116 @@
+Index: passdb/pdb_ldap.c
+===================================================================
+RCS file: /home/cvs/samba/source/passdb/pdb_ldap.c,v
+retrieving revision 1.28.2.61
+diff -u -r1.28.2.61 pdb_ldap.c
+--- passdb/pdb_ldap.c 16 May 2003 14:15:09 -0000 1.28.2.61
++++ passdb/pdb_ldap.c 27 May 2003 13:27:16 -0000
+@@ -55,6 +55,24 @@
+ #define LDAP_OPT_SUCCESS 0
+ #endif
+
++#if defined(LDAP_EXOP_X_MODIFY_PASSWD) && !defined(LDAP_EXOP_MODIFY_PASSWD)
++#define LDAP_EXOP_MODIFY_PASSWD LDAP_EXOP_X_MODIFY_PASSWD
++#elif !defined(LDAP_EXOP_MODIFY_PASSWD)
++#define "1.3.6.1.4.1.4203.1.11.1"
++#endif
++
++#if defined(LDAP_EXOP_X_MODIFY_PASSWD_ID) && !defined(LDAP_EXOP_MODIFY_PASSWD_ID)
++#define LDAP_TAG_EXOP_MODIFY_PASSWD_ID LDAP_EXOP_X_MODIFY_PASSWD_ID
++#elif !defined(LDAP_EXOP_MODIFY_PASSWD_ID)
++#define LDAP_TAG_EXOP_MODIFY_PASSWD_ID ((ber_tag_t) 0x80U)
++#endif
++
++#if defined(LDAP_EXOP_X_MODIFY_PASSWD_NEW) && !defined(LDAP_EXOP_MODIFY_PASSWD_NEW)
++#define LDAP_TAG_EXOP_MODIFY_PASSWD_NEW LDAP_EXOP_X_MODIFY_PASSWD_NEW
++#elif !defined(LDAP_EXOP_MODIFY_PASSWD_NEW)
++#define LDAP_TAG_EXOP_MODIFY_PASSWD_NEW ((ber_tag_t) 0x82U)
++#endif
++
+ #ifndef SAM_ACCOUNT
+ #define SAM_ACCOUNT struct sam_passwd
+ #endif
+@@ -910,7 +928,6 @@
+ return rc;
+ }
+
+-#ifdef LDAP_EXOP_X_MODIFY_PASSWD
+ static int ldapsam_extended_operation(struct ldapsam_privates *ldap_state, LDAP_CONST char *reqoid, struct berval *reqdata, LDAPControl **serverctrls, LDAPControl **clientctrls, char **retoidp, struct berval **retdatap)
+ {
+ int rc = LDAP_SERVER_DOWN;
+@@ -934,7 +951,6 @@
+
+ return rc;
+ }
+-#endif
+
+ /*******************************************************************
+ run the search by name.
+@@ -2713,7 +2729,6 @@
+ }
+ }
+
+-#ifdef LDAP_EXOP_X_MODIFY_PASSWD
+ if (!(pdb_get_acct_ctrl(newpwd)&(ACB_WSTRUST|ACB_SVRTRUST|ACB_DOMTRUST)) &&
+ (lp_ldap_passwd_sync() != LDAP_PASSWD_SYNC_OFF) &&
+ need_update(newpwd, PDB_PLAINTEXT_PW) &&
+@@ -2740,8 +2755,8 @@
+ }
+
+ ber_printf (ber, "{");
+- ber_printf (ber, "ts", LDAP_TAG_EXOP_X_MODIFY_PASSWD_ID, utf8_dn);
+- ber_printf (ber, "ts", LDAP_TAG_EXOP_X_MODIFY_PASSWD_NEW, utf8_password);
++ ber_printf (ber, "ts", LDAP_TAG_EXOP_MODIFY_PASSWD_ID, utf8_dn);
++ ber_printf (ber, "ts", LDAP_TAG_EXOP_MODIFY_PASSWD_NEW, utf8_password);
+ ber_printf (ber, "N}");
+
+ if ((rc = ber_flatten (ber, &bv))<0) {
+@@ -2756,7 +2771,7 @@
+ SAFE_FREE(utf8_password);
+ ber_free(ber, 1);
+
+- if ((rc = ldapsam_extended_operation(ldap_state, LDAP_EXOP_X_MODIFY_PASSWD,
++ if ((rc = ldapsam_extended_operation(ldap_state, LDAP_EXOP_MODIFY_PASSWD,
+ bv, NULL, NULL, &retoid, &retdata))!=LDAP_SUCCESS) {
+ DEBUG(0,("LDAP Password could not be changed for user %s: %s\n",
+ pdb_get_username(newpwd),ldap_err2string(rc)));
+@@ -2770,9 +2785,6 @@
+ }
+ ber_bvfree(bv);
+ }
+-#else
+- DEBUG(10,("LDAP PASSWORD SYNC is not supported!\n"));
+-#endif /* LDAP_EXOP_X_MODIFY_PASSWD */
+ return NT_STATUS_OK;
+ }
+
+Index: param/loadparm.c
+===================================================================
+RCS file: /home/cvs/samba/source/param/loadparm.c,v
+retrieving revision 1.397.2.56
+diff -u -r1.397.2.56 loadparm.c
+--- param/loadparm.c 14 May 2003 03:32:19 -0000 1.397.2.56
++++ param/loadparm.c 27 May 2003 13:27:19 -0000
+@@ -625,18 +625,16 @@
+ };
+
+ static const struct enum_list enum_ldap_passwd_sync[] = {
+- {LDAP_PASSWD_SYNC_ON, "Yes"},
+- {LDAP_PASSWD_SYNC_ON, "yes"},
+- {LDAP_PASSWD_SYNC_ON, "on"},
+- {LDAP_PASSWD_SYNC_ON, "On"},
+ {LDAP_PASSWD_SYNC_OFF, "no"},
+ {LDAP_PASSWD_SYNC_OFF, "No"},
+ {LDAP_PASSWD_SYNC_OFF, "off"},
+ {LDAP_PASSWD_SYNC_OFF, "Off"},
+-#ifdef LDAP_EXOP_X_MODIFY_PASSWD
++ {LDAP_PASSWD_SYNC_ON, "Yes"},
++ {LDAP_PASSWD_SYNC_ON, "yes"},
++ {LDAP_PASSWD_SYNC_ON, "on"},
++ {LDAP_PASSWD_SYNC_ON, "On"},
+ {LDAP_PASSWD_SYNC_ONLY, "Only"},
+ {LDAP_PASSWD_SYNC_ONLY, "only"},
+-#endif /* LDAP_EXOP_X_MODIFY_PASSWD */
+ {-1, NULL}
+ };
+
diff --git a/net-fs/samba/samba-3.0_alpha24-r1.ebuild b/net-fs/samba/samba-3.0_alpha24-r1.ebuild
new file mode 100644
index 000000000000..9575aaf8cba8
--- /dev/null
+++ b/net-fs/samba/samba-3.0_alpha24-r1.ebuild
@@ -0,0 +1,368 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0_alpha24-r1.ebuild,v 1.1 2003/05/29 03:28:36 woodchip Exp $
+
+inherit eutils
+
+IUSE="kerberos mysql xml acl cups ldap pam readline python"
+IUSE="${IUSE} oav"
+
+DESCRIPTION="SAMBA is a suite of SMB and CIFS client/server programs for UNIX"
+HOMEPAGE="http://www.samba.org"
+
+VSCAN_VER=0.3.2b
+VSCAN_MODS=${VSCAN_MODS:=fprot mks openantivirus sophos trend icap} #kapersky
+# To build the "kapersky" plugin, the kapersky lib must be installed.
+
+_CVS=_3_0_20030528
+S=${WORKDIR}/${PN}${_CVS}
+
+SRC_URI="mirror://gentoo/${PN}${_CVS}.tar.bz2
+ oav? mirror://sourceforge/openantivirus/${PN}-vscan-${VSCAN_VER}.tar.bz2"
+
+DEPEND="sys-devel/autoconf dev-libs/popt
+ readline? sys-libs/readline
+ kerberos? app-crypt/mit-krb5
+ mysql? ( dev-db/mysql sys-libs/zlib )
+ xml? ( dev-libs/libxml2 sys-libs/zlib )
+ acl? sys-apps/acl
+ cups? net-print/cups
+ ldap? net-nds/openldap
+ pam? sys-libs/pam
+ python? dev-lang/python"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ local i
+ unpack ${A} || die
+ cd ${S} || die
+
+ # Clean up CVS and add patch(es)
+ find . -name .cvsignore | xargs rm -f
+ find . -name CVS | xargs rm -rf
+ cd source; epatch ${FILESDIR}/samba-pdb_ldap-exop.patch; cd ..
+
+
+ # For clean docs packaging sake.
+ rm -rf ${S}/examples.bin ; cp -a ${S}/examples ${S}/examples.bin
+
+ # Prep samba-vscan source.
+ if use oav; then
+ cp -a ${WORKDIR}/${PN}-vscan-${VSCAN_VER} ${S}/examples.bin/VFS
+ cd ${S}/examples.bin/VFS/${PN}-vscan-${VSCAN_VER}/include
+ sed -e "s%^\(# define SAMBA_VERSION_MAJOR\).*%\1 3%" \
+ vscan-global.h >vscan-global.h.3
+ mv -f vscan-global.h.3 vscan-global.h
+ fi
+
+ cd ${S}/source
+ ./autogen.sh || die
+}
+
+src_compile() {
+ local i
+ local myconf
+ local mymods #="nisplussam"
+
+ use xml && mymods="xml,${mymods}"
+ use mysql && mymods="mysql,${mymods}"
+ myconf="${myconf} --with-expsam=${mymods}"
+
+ use acl \
+ && myconf="${myconf} --with-acl-support" \
+ || myconf="${myconf} --without-acl-support"
+
+ use pam \
+ && myconf="${myconf} --with-pam --with-pam_smbpass" \
+ || myconf="${myconf} --without-pam --without-pam_smbpass"
+
+ use cups \
+ && myconf="${myconf} --enable-cups" \
+ || myconf="${myconf} --disable-cups"
+
+ use ldap \
+ && myconf="${myconf} --with-ldap" \
+ || myconf="${myconf} --without-ldap"
+ #this is for old samba 2.x compat
+ #myconf="${myconf} --with-ldapsam"
+ myconf="${myconf} --without-ldapsam"
+
+ use kerberos \
+ && myconf="${myconf} --with-ads" \
+ || myconf="${myconf} --without-ads"
+
+ use python \
+ && myconf="${myconf} --with-python=yes" \
+ || myconf="${myconf} --with-python=no"
+
+ use readline \
+ && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ einfo "\$myconf is: $myconf"
+
+ #grep default_{static,shared}_modules source/configure
+ #/usr/lib/samba/auth/............. AUTH_MODULES
+ #/usr/lib/samba/charset/ CHARSET_MODULES
+ #/usr/lib/samba/pdb/.............. PDB_MODULES
+ #/usr/lib/samba/rpc/ RPC_MODULES
+ #/usr/lib/samba/vfs/.............. grep VFS_MODULES source/Makefile
+ #/usr/lib/samba/lowcase.dat
+ #/usr/lib/samba/upcase.dat
+ #/usr/lib/samba/valid.dat
+
+ cd source
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ --libdir=/usr/lib/samba \
+ --with-privatedir=/etc/samba/private \
+ --with-lockdir=/var/cache/samba \
+ --with-piddir=/var/run/samba \
+ --with-swatdir=/usr/share/swat \
+ --with-configdir=/etc/samba \
+ --with-logfilebase=/var/log/samba \
+ \
+ --enable-shared \
+ --with-manpages-langs=en \
+ --with-sendfile-support \
+ --without-spinlocks \
+ --with-libsmbclient \
+ --with-automount \
+ --with-smbmount \
+ --with-winbind \
+ --with-quotas \
+ --with-tdbsam \
+ --with-syslog \
+ --with-idmap \
+ --with-utmp \
+ --host=${CHOST} ${myconf} || die
+
+ # Compile main SAMBA pieces.
+ make everything wins || die "SAMBA pieces"
+ #make rpctorture
+
+ # Build selected samba-vscan plugins.
+ use oav && \
+ for i in ${VSCAN_MODS}
+ do
+ cd ${S}/examples.bin/VFS/${PN}-vscan-${VSCAN_VER}/$i
+ make USE_INCLMKSDLIB=1 #needed for the mks build
+ assert "problem building $i vscan module"
+ done
+}
+
+src_install() {
+# For tesing the latest brokeness with the Make/Install system :-)
+# cd source
+# make DESTDIR=${D} install installmodules install_python
+# assert "yawn, still horribly broken ... sigh."
+
+ # Install standard binary files.
+ for i in smbclient net smbspool testparm testprns smbstatus \
+ smbcontrol smbtree tdbbackup nmblookup pdbedit editreg \
+ smbpasswd rpcclient smbcacls profiles ntlm_auth \
+ smbcquotas smbmount smbmnt smbumount wbinfo \
+ debug2html smbfilter talloctort # smbsh
+ do
+ exeinto /usr/bin
+ doexe source/bin/${i}
+ done
+ doexe source/script/{smbtar,findsmb}
+
+ # TORTURE_PROGS / Testing stuff, if they built they will come.
+ for i in smbtorture msgtest masktest locktest locktest2 \
+ nsstest vfstest rpctorture
+ do
+ if [ -x source/bin/${i} ]
+ then
+ exeinto /usr/bin
+ doexe source/bin/${i}
+ fi
+ done
+
+ # Installing these two setuid-root allows users to (un)mount smbfs.
+ fperms 4755 /usr/bin/smbumount
+ fperms 4755 /usr/bin/smbmnt
+
+ # Install server binaries.
+ for i in smbd nmbd swat winbindd # wrepld
+ do
+ exeinto /usr/sbin
+ doexe source/bin/${i}
+ done
+
+ # Libraries.
+ exeinto /usr/lib
+ #broken for a while now with some wacky glibc issue
+ #doexe source/bin/smbwrapper.so
+ doexe source/bin/libsmbclient.so
+ insinto /usr/lib
+ doins source/bin/libsmbclient.a
+ insinto /usr/include
+ doins source/include/libsmbclient.h
+ exeinto /lib/security
+ doexe source/nsswitch/pam_winbind.so
+ use pam && doexe source/bin/pam_smbpass.so
+
+ # Nsswitch extensions.
+ for i in wins winbind
+ do
+ exeinto /lib
+ doexe source/nsswitch/libnss_${i}.so
+ done
+ # make link for wins and winbind resolvers..
+ ( cd ${D}/lib ; ln -s libnss_wins.so libnss_wins.so.2 )
+ ( cd ${D}/lib ; ln -s libnss_winbind.so libnss_winbind.so.2 )
+
+ # Python extensions.
+ if use python; then
+ cd source
+ python python/setup.py install --root=${D} || die
+ cd ..
+ fi
+
+ # VFS plugin modules.
+ exeinto /usr/lib/samba/vfs
+ use oav && doexe examples.bin/VFS/${PN}-vscan-${VSCAN_VER}/*/vscan-*.so
+ for i in audit extd_audit fake_perms netatalk recycle
+ do
+ if [ -x source/bin/${i}.so ]
+ then
+ doexe source/bin/${i}.so
+ fi
+ done
+
+ # Passdb modules.
+ exeinto /usr/lib/samba/pdb
+ use mysql && doexe source/bin/mysql.so
+ use xml && doexe source/bin/xml.so
+
+ # Install codepage data files.
+ insinto /usr/lib/samba
+ doins source/codepages/*.dat
+
+ # Install SWAT helper files.
+ for i in swat/help/*.html docs/htmldocs/*.html
+ do
+ insinto /usr/share/swat/help
+ doins ${i}
+ done
+ for i in swat/images/*.gif
+ do
+ insinto /usr/share/swat/images
+ doins ${i}
+ done
+ for i in swat/include/*.html
+ do
+ insinto /usr/share/swat/include
+ doins ${i}
+ done
+
+ # Install the O'Reilly "Using Samba" book.
+ for i in docs/htmldocs/using_samba/*.html
+ do
+ insinto /usr/share/swat/using_samba
+ doins ${i}
+ done
+ for i in docs/htmldocs/using_samba/gifs/*.gif
+ do
+ insinto /usr/share/swat/using_samba/gifs
+ doins ${i}
+ done
+ for i in docs/htmldocs/using_samba/figs/*.gif
+ do
+ insinto /usr/share/swat/using_samba/figs
+ doins ${i}
+ done
+
+ # Install man pages.
+ doman docs/manpages/*
+
+ # SAMBA has a lot of docs, so this just basically
+ # installs them all! We don't want two copies of
+ # the book or manpages though, so:
+ rm -rf docs/htmldocs/using_samba docs/manpages
+
+ dodoc COPYING Manifest README Roadmap WHATSNEW.txt
+ docinto full_docs
+ cp -a docs/* ${D}/usr/share/doc/${PF}/full_docs
+ docinto examples
+ cp -a examples/* ${D}/usr/share/doc/${PF}/examples
+ prepalldocs
+ # keep this next line *after* prepalldocs!
+ dosym /usr/share/swat/using_samba /usr/share/doc/${PF}/using_samba
+ # and we should unzip the html docs..
+ gunzip ${D}/usr/share/doc/${PF}/full_docs/faq/*
+ gunzip ${D}/usr/share/doc/${PF}/full_docs/htmldocs/*
+ if use oav; then
+ docinto ${PN}-vscan-${VSCAN_VER}
+ cd ${WORKDIR}/${PN}-vscan-${VSCAN_VER}
+ dodoc AUTHORS COPYING ChangeLog FAQ INSTALL NEWS README TODO
+ dodoc */*.conf
+ cd ${S}
+ fi
+ chown -R root.root ${D}/usr/share/doc/${PF}
+
+ # link /usr/bin/smbmount to /sbin/mount.smbfs which allows it
+ # to work transparently with the standard 'mount' command..
+ dodir /sbin
+ dosym /usr/bin/smbmount /sbin/mount.smbfs
+
+ # make the smb backend symlink for cups printing support..
+ if use cups; then
+ dodir /usr/lib/cups/backend
+ dosym /usr/bin/smbspool /usr/lib/cups/backend/smb
+ fi
+
+ # Now the config files.
+ if use ldap; then
+ insinto /etc/openldap/schema
+ doins examples/LDAP/samba.schema
+ fi
+
+ insinto /etc
+ dodoc ${FILESDIR}/nsswitch.conf-winbind
+ doins ${FILESDIR}/nsswitch.conf-wins
+
+ insinto /etc/samba
+ doins ${FILESDIR}/smbusers
+# need to update this one! :)
+ doins ${FILESDIR}/smb.conf.example
+ doins ${FILESDIR}/lmhosts
+ doins ${FILESDIR}/recycle.conf
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/samba.pam samba
+ doins ${FILESDIR}/system-auth-winbind
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/samba-init samba
+# this one looks funny
+ newexe ${FILESDIR}/winbind-init winbind
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/swat.xinetd swat
+}
+
+pkg_postinst() {
+ # touch /etc/samba/smb.conf so that people installing samba just
+ # to mount smb shares don't get annoying warnings all the time..
+ if [ ! -e ${ROOT}/etc/samba/smb.conf ] ; then
+ touch ${ROOT}/etc/samba/smb.conf
+ fi
+
+ # empty dirs..
+ install -m0700 -o root -g root -d ${ROOT}/etc/samba/private
+ install -m1777 -o root -g root -d ${ROOT}/var/spool/samba
+ install -m0755 -o root -g root -d ${ROOT}/var/log/samba
+ install -m0755 -o root -g root -d ${ROOT}/var/run/samba
+ install -m0755 -o root -g root -d ${ROOT}/var/cache/samba
+ install -m0755 -o root -g root -d ${ROOT}/var/lib/samba/{netlogon,profiles}
+ install -m0755 -o root -g root -d \
+ ${ROOT}/var/lib/samba/printers/{W32X86,WIN40,W32ALPHA,W32MIPS,W32PPC}
+}