summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorStefaan De Roeck <stefaan@gentoo.org>2009-06-11 19:49:39 +0000
committerStefaan De Roeck <stefaan@gentoo.org>2009-06-11 19:49:39 +0000
commit1018b32112bacc8f9ec26ca57d3a031d5b499855 (patch)
treee7775b5c072d4a1b89e4e729223b22022693a320 /net-fs
parentRemove old. (diff)
downloadhistorical-1018b32112bacc8f9ec26ca57d3a031d5b499855.tar.gz
historical-1018b32112bacc8f9ec26ca57d3a031d5b499855.tar.bz2
historical-1018b32112bacc8f9ec26ca57d3a031d5b499855.zip
version bump to 1.4.10
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/openafs-kernel/ChangeLog8
-rw-r--r--net-fs/openafs-kernel/openafs-kernel-1.4.10.ebuild58
-rw-r--r--net-fs/openafs/ChangeLog10
-rw-r--r--net-fs/openafs/files/openafs-dprintf.patch132
-rw-r--r--net-fs/openafs/openafs-1.4.10.ebuild151
5 files changed, 356 insertions, 3 deletions
diff --git a/net-fs/openafs-kernel/ChangeLog b/net-fs/openafs-kernel/ChangeLog
index 675913c3eda1..3b512a5622b6 100644
--- a/net-fs/openafs-kernel/ChangeLog
+++ b/net-fs/openafs-kernel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/openafs-kernel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/ChangeLog,v 1.118 2009/04/18 12:00:23 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/ChangeLog,v 1.119 2009/06/11 19:49:02 stefaan Exp $
+
+*openafs-kernel-1.4.10 (11 Jun 2009)
+
+ 11 Jun 2009; Stefaan De Roeck <stefaan@gentoo.org>
+ +openafs-kernel-1.4.10.ebuild:
+ version bump to 1.4.10
18 Apr 2009; Markus Meier <maekke@gentoo.org> openafs-kernel-1.4.9.ebuild:
amd64/x86 stable, bug #265538
diff --git a/net-fs/openafs-kernel/openafs-kernel-1.4.10.ebuild b/net-fs/openafs-kernel/openafs-kernel-1.4.10.ebuild
new file mode 100644
index 000000000000..407676f0dc3b
--- /dev/null
+++ b/net-fs/openafs-kernel/openafs-kernel-1.4.10.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/openafs-kernel-1.4.10.ebuild,v 1.1 2009/06/11 19:49:02 stefaan Exp $
+
+inherit eutils linux-mod versionator toolchain-funcs
+
+PATCHVER=0.16
+MY_PN=${PN/-kernel}
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="The OpenAFS distributed file system kernel module"
+HOMEPAGE="http://www.openafs.org/"
+SRC_URI="http://openafs.org/dl/${PV}/${MY_P}-src.tar.bz2
+ mirror://gentoo/${MY_PN}-gentoo-${PATCHVER}.tar.bz2"
+
+LICENSE="IBM openafs-krb5 openafs-krb5-a APSL-2 sun-rpc"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+PATCHDIR=${WORKDIR}/gentoo/patches/$(get_version_component_range 1-2)
+
+CONFIG_CHECK="!DEBUG_RODATA ~!AFS_FS"
+ERROR_DEBUG_RODATA="OpenAFS is incompatible with linux' CONFIG_DEBUG_RODATA option"
+ERROR_AFS_FS="OpenAFS conflicts with the in-kernel AFS-support. Make sure not to load both at the same time!"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${MY_P}-src.tar.bz2
+ unpack ${MY_PN}-gentoo-${PATCHVER}.tar.bz2
+ cd "${S}"
+
+ EPATCH_SUFFIX="patch" \
+ EPATCH_EXCLUDE="012_all_kbuild.patch 013_all_linux-2.6.29.patch" \
+ epatch ${PATCHDIR}
+
+ ./regen.sh || die "Failed: regenerating configure script"
+}
+
+src_compile() {
+ ARCH="$(tc-arch-kernel)" econf --with-linux-kernel-headers=${KV_DIR} \
+ --with-linux-kernel-build=${KV_OUT_DIR} || die "Failed: econf"
+
+ ARCH="$(tc-arch-kernel)" emake -j1 only_libafs || die "Failed: emake"
+}
+
+src_install() {
+ MOD_SRCDIR=$(expr ${S}/src/libafs/MODLOAD-*)
+ [ -f ${MOD_SRCDIR}/libafs.${KV_OBJ} ] \
+ || die "Couldn't find compiled kernel module"
+
+ MODULE_NAMES='libafs(fs/openafs:$MOD_SRCDIR)'
+
+ linux-mod_src_install
+}
diff --git a/net-fs/openafs/ChangeLog b/net-fs/openafs/ChangeLog
index ee6d343b1895..b83185145a9e 100644
--- a/net-fs/openafs/ChangeLog
+++ b/net-fs/openafs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/openafs
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.159 2009/04/18 12:01:15 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.160 2009/06/11 19:49:39 stefaan Exp $
+
+*openafs-1.4.10 (11 Jun 2009)
+
+ 11 Jun 2009; Stefaan De Roeck <stefaan@gentoo.org> +openafs-1.4.10.ebuild,
+ +files/openafs-dprintf.patch:
+ version bump to 1.4.10
18 Apr 2009; Markus Meier <maekke@gentoo.org> openafs-1.4.9:
amd64/x86 stable, bug #265538
diff --git a/net-fs/openafs/files/openafs-dprintf.patch b/net-fs/openafs/files/openafs-dprintf.patch
new file mode 100644
index 000000000000..eed241cb5119
--- /dev/null
+++ b/net-fs/openafs/files/openafs-dprintf.patch
@@ -0,0 +1,132 @@
+pple-Mail-1--66779474
+Content-Transfer-Encoding: 7bit
+Content-Type: text/plain;
+ charset=US-ASCII;
+ delsp=yes;
+ format=flowed
+
+
+On 20 Apr 2009, at 12:12, Axel Thimm wrote:
+
+> Hi,
+>
+> current Fedora rawhide (to become F11) has the following components:
+>
+> glibc-2.9.90-19
+> gcc-4.4.0-0.34
+> kernel-2.6.29.1-100.fc11
+>
+> The build (1.4.10 and 1.4.8) fails with
+>
+> gcc -pipe -O2 -I/builddir/openafs-1.4.10/src/config -I. -I. -I/
+> builddir/openafs-1.4.10/include -I/builddir/openafs-1.4.10/include/
+> afs -I/builddir/openafs-1.4.10/include/rx -I/builddir/
+> openafs-1.4.10 -I/builddir/openafs-1.4.10/src -I/builddir/
+> openafs-1.4.10/src -g -O2 -D_LARGEFILE64_SOURCE -c admin_tools.c
+> In file included from admin_tools.c:30:
+> /usr/include/stdio.h:399:66: error: macro "dprintf" passed 3
+> arguments, but takes just 2
+> admin_tools.c: In function 'MyBeforeProc':
+> admin_tools.c:1470: warning: passing argument 2 of 'ktc_GetToken'
+> from incompatible pointer type
+> /builddir/openafs-1.4.10/include/afs/auth.h:36: note: expected
+> 'struct ktc_token *' but argument is of type 'struct ktc_principal *'
+
+Could you try the attached (untested) patch...
+
+In future, Bcc-ing openafs-bugs (I've just done so) with these kinds
+of reports helps us track them, and their patches, better.
+
+Thanks,
+
+Simon.
+
+--Apple-Mail-1--66779474
+Content-Transfer-Encoding: 7bit
+Content-Type: application/octet-stream;
+ x-unix-mode=0644;
+ name=afs_dprintf
+Content-Disposition: attachment;
+ filename=afs_dprintf
+
+Index: stable/openafs/src/bucoord/bc.p.h
+===================================================================
+--- stable.orig/openafs/src/bucoord/bc.p.h 2009-03-23 12:39:24.000000000 +0000
++++ stable/openafs/src/bucoord/bc.p.h 2009-04-20 13:55:19.000000000 +0100
+@@ -144,4 +144,4 @@
+ #define BC_MAXSIMDUMPS 64
+ #define BC_MAXPORTS 128 /* max number of port offsets for volrestore */
+ /* debugging support */
+-#define dprintf(x)
++#define afs_dprintf(x)
+Index: stable/openafs/src/bucoord/ubik_db_if.c
+===================================================================
+--- stable.orig/openafs/src/bucoord/ubik_db_if.c 2009-03-23 12:49:14.000000000 +0000
++++ stable/openafs/src/bucoord/ubik_db_if.c 2009-04-20 13:55:43.000000000 +0100
+@@ -601,7 +601,7 @@
+
+ fileSize = (afs_int32) filesize(ctPtr->textStream);
+
+- dprintf(("filesize is %d\n", fileSize));
++ afs_dprintf(("filesize is %d\n", fileSize));
+
+ rewind(ctPtr->textStream);
+
+@@ -1390,7 +1390,7 @@
+ ERROR(errno);
+ #endif
+
+- dprintf(("file is %s\n", tmpFileName));
++ afs_dprintf(("file is %s\n", tmpFileName));
+
+ normal_exit:
+ return code;
+Index: stable/openafs/src/config/debug.h
+===================================================================
+--- stable.orig/openafs/src/config/debug.h 2003-07-16 00:14:55.000000000 +0100
++++ stable/openafs/src/config/debug.h 2009-04-20 13:56:31.000000000 +0100
+@@ -112,21 +112,21 @@
+
+ #if defined(AFS_DEBUG)
+ #if defined(lint)
+-#define dprintf(flag, str) printf str
++#define afs_dprintf(flag, str) printf str
+ #define dlprintf(flag, level, str) printf str
+ #define dmprintf(flag, bit, str) printf str
+ #else /* lint */
+-#define dprintf(flag, str) \
++#define afs_dprintf(flag, str) \
+ (void)((flag) ? \
+ ( osi_dp str, osi_dp("\t%s, %d\n", __FILE__, __LINE__)):0)
+-#define dlprintf(flag, level, str) dprintf(((flag) >= (level)), str)
+-#define dmprintf(flag, bit, str) dprintf(((flag)&(1<<((bit)-1))), str)
++#define dlprintf(flag, level, str) afs_dprintf(((flag) >= (level)), str)
++#define dmprintf(flag, bit, str) afs_dprintf(((flag)&(1<<((bit)-1))), str)
+
+ #endif /* lint */
+
+ #else /* AFS_DEBUG */
+
+-#define dprintf(flag, str)
++#define afs_dprintf(flag, str)
+ #define dlprintf(flag, level,str)
+ #define dmprintf(flag, bit, str)
+
+Index: stable/openafs/src/sgistuff/rcmd.c
+===================================================================
+--- stable.orig/openafs/src/sgistuff/rcmd.c 2005-08-16 19:00:44.000000000 +0100
++++ stable/openafs/src/sgistuff/rcmd.c 2009-04-20 13:57:54.000000000 +0100
+@@ -55,8 +55,8 @@
+ #endif /* defined(AFS_HPUX_ENV) */
+ #ifdef TCP_DEBUG
+ #include <sys/syslog.h>
+-# define DPRINTF(args) dprintf args
+-dprintf(args)
++# define DPRINTF(args) afs_dprintf args
++afs_dprintf(args)
+ char *args;
+ {
+ char **argv;
+
+--Apple-Mail-1--66779474--
+
diff --git a/net-fs/openafs/openafs-1.4.10.ebuild b/net-fs/openafs/openafs-1.4.10.ebuild
new file mode 100644
index 000000000000..9d304eacb852
--- /dev/null
+++ b/net-fs/openafs/openafs-1.4.10.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.4.10.ebuild,v 1.1 2009/06/11 19:49:39 stefaan Exp $
+
+inherit flag-o-matic eutils toolchain-funcs versionator pam
+
+PATCHVER=0.15
+DESCRIPTION="The OpenAFS distributed file system"
+HOMEPAGE="http://www.openafs.org/"
+SRC_URI="http://openafs.org/dl/${PV}/${P}-src.tar.bz2
+ doc? ( http://openafs.org/dl/${PV}/${P}-doc.tar.bz2 )
+ mirror://gentoo/${PN}-gentoo-${PATCHVER}.tar.bz2"
+
+LICENSE="IBM openafs-krb5 openafs-krb5-a APSL-2 sun-rpc"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug kerberos pam doc"
+
+RDEPEND="~net-fs/openafs-kernel-${PV}
+ pam? ( sys-libs/pam )
+ kerberos? ( virtual/krb5 )"
+
+PATCHDIR=${WORKDIR}/gentoo/patches/$(get_version_component_range 1-2)
+CONFDIR=${WORKDIR}/gentoo/configs
+SCRIPTDIR=${WORKDIR}/gentoo/scripts
+
+src_unpack() {
+ unpack ${A}; cd "${S}"
+
+ # Apply patches to apply chosen compiler settings, fix the hardcoded paths
+ # to be more FHS friendly, and the fix the incorrect typecasts for va_arg
+ EPATCH_SUFFIX="patch" \
+ EPATCH_EXCLUDE="012_all_kbuild.patch" \
+ epatch ${PATCHDIR}
+
+ epatch "${FILESDIR}"/openafs-dprintf.patch
+
+ # disable XCFLAGS override
+ sed -i 's/^[ \t]*XCFLAGS.*/:/' src/cf/osconf.m4
+ # disable compiler choice override
+ sed -i 's/^[ \t]\+\(CC\|CCOBJ\|MT_CC\)="[^ ]*\(.*\)"/\1="${CC}\2"/' src/cf/osconf.m4
+
+ # fix autoconf cludge (bug #218234)
+ sed -i 's/^AC_\(AIX\|MINIX\)$//' acinclude.m4
+
+ ./regen.sh || die "Failed: regenerating configure script"
+}
+
+src_compile() {
+ # cannot use "use_with" macro, as --without-krb5-config crashes the econf
+ local myconf=""
+ if use kerberos; then
+ myconf="--with-krb5-conf=$(type -p krb5-config)"
+ fi
+
+ # AFS_SYSKVERS: fix linux version at 2.6
+ AFS_SYSKVERS=26 \
+ XCFLAGS="${CFLAGS}" \
+ econf \
+ $(use_enable pam) \
+ $(use_enable debug) \
+ --enable-largefile-fileserver \
+ --enable-supergroups \
+ --disable-kernel-module \
+ --disable-strip-binaries \
+ ${myconf} || die econf
+
+ emake -j1 all_nolibafs || die "Build failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install_nolibafs || die "Installing failed"
+
+ # pam_afs and pam_afs.krb have been installed in irregular locations, fix
+ if use pam; then
+ dopammod "${D}"/usr/$(get_libdir)/pam_afs*
+ rm -f "${D}"/usr/$(get_libdir)/pam_afs*
+ fi
+
+ # compile_et collides with com_err. Remove it from this package.
+ rm "${D}"/usr/bin/compile_et
+
+ # avoid collision with mit_krb5's version of kpasswd
+ (cd "${D}"/usr/bin; mv kpasswd kpasswd_afs)
+ use doc && (cd "${D}"/usr/share/man/man1; mv kpasswd.1 kpasswd_afs.1)
+
+ # minimal documentation
+ dodoc ${CONFDIR}/README ${CONFDIR}/CellServDB
+
+ # documentation package
+ if use doc; then
+ use pam && doman src/pam/pam_afs.5
+
+ cp -pPR doc/* "${D}"/usr/share/doc/${PF}
+ fi
+
+ # Gentoo related scripts
+ newconfd ${CONFDIR}/openafs-client openafs-client
+ newconfd ${CONFDIR}/openafs-server openafs-server
+ newinitd ${SCRIPTDIR}/openafs-client openafs-client
+ newinitd ${SCRIPTDIR}/openafs-server openafs-server
+
+ # used directories: client
+ keepdir /etc/openafs
+ keepdir /var/cache/openafs
+
+ # used directories: server
+ keepdir /etc/openafs/server
+ diropts -m0700
+ keepdir /var/lib/openafs
+ keepdir /var/lib/openafs/db
+ diropts -m0755
+ keepdir /var/lib/openafs/logs
+
+ # link logfiles to /var/log
+ dosym ../lib/openafs/logs /var/log/openafs
+}
+
+pkg_preinst() {
+ ## Somewhat intelligently install default configuration files
+ ## (when they are not present)
+ # CellServDB
+ if [ ! -e "${ROOT}"etc/openafs/CellServDB ] \
+ || grep "GCO Public CellServDB" "${ROOT}"etc/openafs/CellServDB &> /dev/null
+ then
+ cp ${CONFDIR}/CellServDB "${D}"etc/openafs
+ fi
+ # cacheinfo: use a default location cache, 200 megabyte in size
+ # (should be safe for about any root partition, the user can increase
+ # the size as required)
+ if [ ! -e "${ROOT}"etc/openafs/cacheinfo ]; then
+ echo "/afs:/var/cache/openafs:200000" > "${D}"etc/openafs/cacheinfo
+ fi
+ # ThisCell: default to "openafs.org"
+ if [ ! -e "${ROOT}"etc/openafs/ThisCell ]; then
+ echo "openafs.org" > "${D}"etc/openafs/ThisCell
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "This installation should work out of the box (at least the"
+ elog "client part doing global afs-cell browsing, unless you had"
+ elog "a previous and different configuration). If you want to"
+ elog "set up your own cell or modify the standard config,"
+ elog "please have a look at the Gentoo OpenAFS documentation"
+ elog "(warning: it is not yet up to date wrt the new file locations)"
+ elog
+ elog "The documentation can be found at:"
+ elog " http://www.gentoo.org/doc/en/openafs.xml"
+}