summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2004-10-05 20:00:07 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2004-10-05 20:00:07 +0000
commitf920161c976fdd6826f94ad95c894221f75fa8f5 (patch)
tree2614f1f2aa2e475e1b5cf2f06dbff903146e9bbb /net-fs/coda
parentremoved zlib check. (diff)
downloadhistorical-f920161c976fdd6826f94ad95c894221f75fa8f5.tar.gz
historical-f920161c976fdd6826f94ad95c894221f75fa8f5.tar.bz2
historical-f920161c976fdd6826f94ad95c894221f75fa8f5.zip
Fixed mistake in pkg_config of coda. First ask where, then check for problems.
Diffstat (limited to 'net-fs/coda')
-rw-r--r--net-fs/coda/ChangeLog7
-rw-r--r--net-fs/coda/Manifest10
-rw-r--r--net-fs/coda/coda-6.0.6.ebuild27
3 files changed, 25 insertions, 19 deletions
diff --git a/net-fs/coda/ChangeLog b/net-fs/coda/ChangeLog
index 11751bb14b04..ddbfe052bec4 100644
--- a/net-fs/coda/ChangeLog
+++ b/net-fs/coda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/coda
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/ChangeLog,v 1.10 2004/10/03 19:37:12 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/ChangeLog,v 1.11 2004/10/05 20:00:07 griffon26 Exp $
+
+ 05 Oct 2004; Maurice van der Pot <griffon26@gentoo.org> coda-6.0.6.ebuild:
+ During setup of the initial configuration, first ask the user where to
+ store file data, so the location can be checked for an existing vice
+ partition that needs to be removed.
03 Oct 2004; Maurice van der Pot <griffon26@gentoo.org> coda-6.0.6.ebuild:
Ebuild now allows user to set up initial configuration after installation.
diff --git a/net-fs/coda/Manifest b/net-fs/coda/Manifest
index a4d153322dec..dc725cacafc4 100644
--- a/net-fs/coda/Manifest
+++ b/net-fs/coda/Manifest
@@ -3,8 +3,8 @@ Hash: SHA1
MD5 f905a614fde3a85e0adefb203ece18fc metadata.xml 321
MD5 14e8df1cfd403bd955f4de826e758920 coda-6.0.3.ebuild 2974
-MD5 8068c59c5224f3683e5bf869912012b1 coda-6.0.6.ebuild 7535
-MD5 88983cc792ef92f57721c32226f51dc5 ChangeLog 2256
+MD5 92f63e6bcc1ec4e289b435f1863319ed coda-6.0.6.ebuild 7604
+MD5 16aa6f61858308da592649d2d378ca91 ChangeLog 2518
MD5 d21e4e5142a0266459b5ad8b39e3e707 files/coda-6.0.3-iowr.patch 607
MD5 464a8cd91e3af12266c0570034388221 files/coda-6.0.6-gcc3.4.patch 1984
MD5 d08316a08429d573d30dbc9924707206 files/digest-coda-6.0.3 63
@@ -16,7 +16,7 @@ MD5 494ef5b4a48b5a4aa77251d2b5942a91 files/venus 697
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBYFUBMGnpIbeahxwRArT/AKCwPQJjQqJD/5R6m1+ojayb3oeDjgCgwFr4
-fN+kb0pbaI82QffzKNlA19Q=
-=gOPH
+iD8DBQFBYv1TMGnpIbeahxwRAtfMAKDBXANLgRfWTQyeGJClutmanfcaiACgoV4T
+2Gjs9w/bGTX52svJBqMrON4=
+=NMgM
-----END PGP SIGNATURE-----
diff --git a/net-fs/coda/coda-6.0.6.ebuild b/net-fs/coda/coda-6.0.6.ebuild
index d0aea3be48d4..d6e768170242 100644
--- a/net-fs/coda/coda-6.0.6.ebuild
+++ b/net-fs/coda/coda-6.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/coda-6.0.6.ebuild,v 1.6 2004/10/03 19:37:12 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/coda-6.0.6.ebuild,v 1.7 2004/10/05 20:00:07 griffon26 Exp $
inherit eutils
@@ -157,6 +157,18 @@ pkg_config () {
exit 1
fi
+ # Ask for the location of (amongst other things) the vice partition
+ ewarn "This default configuration of coda will require 350MB of free space"
+ ewarn "for Recoverable Virtual Memory. Additional space is required for"
+ ewarn "the files that you store on your coda volume."
+ echo
+ einfon "Please specify where coda should store this data [${CODA_STORAGE_DIR}]: "
+ read new_storage_dir
+ if [ "x${new_storage_dir}" != "x" ]; then
+ CODA_STORAGE_DIR=${new_storage_dir}
+ fi
+ echo
+
# Check if an existing server.conf is in the way
conf=$(codaconfedit server.conf)
intheway=
@@ -164,7 +176,7 @@ pkg_config () {
intheway="${intheway} ${conf}"
fi
- # Check if an existing /var/lib/vice is in the way
+ # Check if an existing vice root dir is in the way
if [ -e ${CODA_ROOT_DIR} ]; then
intheway="${intheway} ${CODA_ROOT_DIR}"
fi
@@ -183,17 +195,6 @@ pkg_config () {
exit 1
fi
- ewarn "This default configuration of coda will require 350MB of free space"
- ewarn "for Recoverable Virtual Memory. Additional space is required for"
- ewarn "the files that you store on your coda volume."
- echo
- einfon "Please specify where coda should store this data [${CODA_STORAGE_DIR}]: "
- read new_storage_dir
- if [ "x${new_storage_dir}" != "x" ]; then
- CODA_STORAGE_DIR=${new_storage_dir}
- fi
-
- echo
einfo "A default coda server and client configuration will be set up that consists of:"
einfo "- a coda SCM (System Control Machine)"
einfo "- a coda administrator '${CODA_ADMIN_NAME}' with coda uid ${CODA_ADMIN_UID} and password 'changeme'"