summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-06-07 13:31:11 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-06-07 13:31:11 +0000
commit95960d5b2b2128f5e8f9e36efab3294fdba9dbda (patch)
tree6a11968db61dabb13d10ccb2f6f0cd71d577494a /net-firewall
parentClosing #51418. (diff)
downloadhistorical-95960d5b2b2128f5e8f9e36efab3294fdba9dbda.tar.gz
historical-95960d5b2b2128f5e8f9e36efab3294fdba9dbda.tar.bz2
historical-95960d5b2b2128f5e8f9e36efab3294fdba9dbda.zip
Possble fix for #46817.
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog8
-rw-r--r--net-firewall/iptables/Manifest4
-rw-r--r--net-firewall/iptables/iptables-1.2.9-r1.ebuild7
3 files changed, 12 insertions, 7 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 1d15da1d7f66..5b4f712fad2d 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,9 +1,11 @@
# ChangeLog for net-firewall/iptables
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.26 2004/06/07 13:24:36 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.27 2004/06/07 13:31:11 aliz Exp $
- 07 Jun 2004; Daniel Ahlberg <aliz@gentoo.org> iptables-1.2.9.ebuild:
- Handle extensionpatches that was added for 1.2.9-r1. Closing #51418.
+ 07 Jun 2004; Daniel Ahlberg <aliz@gentoo.org> iptables-1.2.9-r1.ebuild:
+ + Only run check_KV if /usr/src/liunx is a symlink or a directory, possible fix
+ for #46817.
+ + Handle extensionpatches that was added for 1.2.9-r1. Closing #51418.
10 May 2004; Daniel Ahlberg <aliz@gentoo.org> iptables-1.2.9-r1.ebuild:
CFLAGS must have -O flag, closing #44204
diff --git a/net-firewall/iptables/Manifest b/net-firewall/iptables/Manifest
index c1665465c9a0..dbc7e4bc9cc0 100644
--- a/net-firewall/iptables/Manifest
+++ b/net-firewall/iptables/Manifest
@@ -1,7 +1,7 @@
MD5 54906c7ffcd304a8202c5058287041ac iptables-1.2.7a-r3.ebuild 1968
MD5 25a33c9c34aa8cb3b67c61932d7e2994 iptables-1.2.9.ebuild 2792
-MD5 e7909016b20da914182958eb0a77a6f9 iptables-1.2.9-r1.ebuild 3399
-MD5 54c2fc765e3f3f67ed32ba32c347fdef ChangeLog 10285
+MD5 39eaaeb61906389765432c838709a237 iptables-1.2.9-r1.ebuild 3513
+MD5 49968ed6b7f322af616f96df22a503b4 ChangeLog 10388
MD5 37236013e0d26d43c6bff35a8a48e8ec metadata.xml 220
MD5 f876be872ec78bc824f2503059338d8d files/iptables.confd 382
MD5 04a4f2f4455c1c5df002cde52d354dee files/ip6tables.init 2108
diff --git a/net-firewall/iptables/iptables-1.2.9-r1.ebuild b/net-firewall/iptables/iptables-1.2.9-r1.ebuild
index 2ea8956d9d4e..66cf9ffaf943 100644
--- a/net-firewall/iptables/iptables-1.2.9-r1.ebuild
+++ b/net-firewall/iptables/iptables-1.2.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9-r1.ebuild,v 1.3 2004/05/10 14:07:04 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9-r1.ebuild,v 1.4 2004/06/07 13:31:11 aliz Exp $
inherit eutils flag-o-matic
@@ -39,7 +39,10 @@ src_unpack() {
}
src_compile() {
- check_KV
+ # Only check_KV if /usr/src/linux exists
+ if [ -L ${ROOT}/usr/src/linux -o -d ${ROOT}/usr/src/linux ]; then
+ check_KV
+ fi
# prevent it from causing ICMP errors.
# http://bugs.gentoo.org/show_bug.cgi?id=23645