summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2002-10-18 07:54:16 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2002-10-18 07:54:16 +0000
commit3bd5ae56da7e5eb028b9d74d38ab168dd4e1ca77 (patch)
treec9e4e7212e23c2a30a554052cb49580190789d86 /net-dns
parentAdded mask pending an unfreeze for >=net-dns/djbdns-1.05-r4 (diff)
downloadhistorical-3bd5ae56da7e5eb028b9d74d38ab168dd4e1ca77.tar.gz
historical-3bd5ae56da7e5eb028b9d74d38ab168dd4e1ca77.tar.bz2
historical-3bd5ae56da7e5eb028b9d74d38ab168dd4e1ca77.zip
Added support for a patch that enables djbdns to forward queries to dnscache
depending on the query zone
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/djbdns/ChangeLog9
-rw-r--r--net-dns/djbdns/djbdns-1.05-r4.ebuild64
-rw-r--r--net-dns/djbdns/files/digest-djbdns-1.05-r42
3 files changed, 74 insertions, 1 deletions
diff --git a/net-dns/djbdns/ChangeLog b/net-dns/djbdns/ChangeLog
index 641f69ee0491..1690ad442ab7 100644
--- a/net-dns/djbdns/ChangeLog
+++ b/net-dns/djbdns/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for net-dns/djbdns
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/ChangeLog,v 1.3 2002/09/10 14:44:49 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/ChangeLog,v 1.4 2002/10/18 07:54:16 jhhudso Exp $
+*djbdns-1.05-r4 (18 Oct 2002)
+
+ 18 Oct 2002; Jared Hudson <jhhudso@gentoo.org> .ebuild: Added a patch to
+ enable using dnscache to perform resolution or forwarding according to the
+ query zone. This was in response to bug #9154. Credit goes to Stefano
+ Scipioni.
+
10 Sep 2002; Daniel Robbins <drobbins@gentoo.org>: djbdns-1.05-r3: fixed unpack()
and made the ipv6 patch dependent upon the setting of the ipv6 USE variable. No
rev bump. This closes bug #7236.
diff --git a/net-dns/djbdns/djbdns-1.05-r4.ebuild b/net-dns/djbdns/djbdns-1.05-r4.ebuild
new file mode 100644
index 000000000000..fa29f1ffc5d3
--- /dev/null
+++ b/net-dns/djbdns/djbdns-1.05-r4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r4.ebuild,v 1.1 2002/10/18 07:54:16 jhhudso Exp $
+
+IUSE="ipv6"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Excellent high-performance DNS services"
+SRC_URI="http://cr.yp.to/djbdns/${P}.tar.gz ipv6? http://www.fefe.de/dns/djbdns-1.05-test17.diff.bz2 http://www.skarnet.org/software/djbdns-fwdzone/djbdns-1.04-fwdzone.patch"
+HOMEPAGE="http://cr.yp.to/djbdns.html"
+
+LICENSE="as-is"
+KEYWORDS="x86 sparc sparc64"
+SLOT="0"
+
+DEPEND="virtual/glibc"
+RDEPEND=">=sys-apps/daemontools-0.70
+ sys-apps/ucspi-tcp"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ use ipv6 && { bzcat ${DISTDIR}/djbdns-1.05-test17.diff.bz2 | patch -d ${S} -p1 || die "Failed to apply the ipv6 patch"; }
+ patch -d ${S} -p1 < ${DISTDIR}/djbdns-1.04-fwdzone.patch
+}
+
+src_compile() {
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+ echo "/usr" > conf-home
+ emake || die "emake failed"
+}
+
+src_install() {
+ insinto /etc
+ doins dnsroots.global
+ into /usr
+ for i in *-conf dnscache tinydns walldns rbldns pickdns axfrdns *-get *-data *-edit dnsip dnsipq dnsname dnstxt dnsmx dnsfilter random-ip dnsqr dnsq dnstrace dnstracesort
+ do
+ dobin $i
+ done
+ dodoc CHANGES FILES README SYSDEPS TARGETS TODO VERSION
+
+ dobin ${FILESDIR}/dnscache-setup
+ dobin ${FILESDIR}/tinydns-setup
+
+}
+
+pkg_postinst() {
+ groupadd nofiles
+ id dnscache || useradd -g nofiles -d /nonexistent -s /bin/false dnscache
+ id dnslog || useradd -g nofiles -d /nonexistent -s /bin/false dnslog
+ id tinydns || useradd -g nofiles -d /nonexistent -s /bin/false tinydns
+
+ echo
+ einfo "Use dnscache-setup and tinydns-setup to help you configure your nameservers!"
+ echo
+}
+
+pkg_postrm() {
+ userdel dnscache
+ userdel dnslog
+ userdel tinydns
+}
+
diff --git a/net-dns/djbdns/files/digest-djbdns-1.05-r4 b/net-dns/djbdns/files/digest-djbdns-1.05-r4
new file mode 100644
index 000000000000..0bd36a7b35c2
--- /dev/null
+++ b/net-dns/djbdns/files/digest-djbdns-1.05-r4
@@ -0,0 +1,2 @@
+MD5 3147c5cd56832aa3b41955c7a51cbeb2 djbdns-1.05.tar.gz 85648
+MD5 ac799440bacc9d283e1c228f84cf99d4 djbdns-1.04-fwdzone.patch 6479