summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-07-31 09:12:36 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-07-31 09:12:36 +0000
commitdf0238cf71e8a933b4d7cbef0e35fc39906661cc (patch)
treee22fe8954ab10439677cbc924ff1976aec71ec0d /net-dns/ndu/ndu-0.4-r4.ebuild
parentMissing header. (diff)
downloadhistorical-df0238cf71e8a933b4d7cbef0e35fc39906661cc.tar.gz
historical-df0238cf71e8a933b4d7cbef0e35fc39906661cc.tar.bz2
historical-df0238cf71e8a933b4d7cbef0e35fc39906661cc.zip
Bug #271292: Add a warning that you might want BIND installed for some of the functionality, not it is NOT an actual requirement (the dnstouch tool is very useful in other setups). Also make repoman happy and clean up old ebuilds.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'net-dns/ndu/ndu-0.4-r4.ebuild')
-rw-r--r--net-dns/ndu/ndu-0.4-r4.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/net-dns/ndu/ndu-0.4-r4.ebuild b/net-dns/ndu/ndu-0.4-r4.ebuild
index a3aa41010298..79b408dba457 100644
--- a/net-dns/ndu/ndu-0.4-r4.ebuild
+++ b/net-dns/ndu/ndu-0.4-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ndu/ndu-0.4-r4.ebuild,v 1.4 2007/04/22 13:56:11 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ndu/ndu-0.4-r4.ebuild,v 1.5 2009/07/31 09:12:36 robbat2 Exp $
inherit eutils toolchain-funcs
@@ -19,9 +19,9 @@ RDEPEND="virtual/libc
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${P}-binary-locations.patch
+ epatch "${FILESDIR}"/${P}-binary-locations.patch
- cd ${S}/src
+ cd "${S}"/src
# use the correct compiler
sed -e 's|gcc|$(CXX)|g' -i Makefile
# set correct config pathes
@@ -32,7 +32,7 @@ src_unpack() {
# use the correct editor
sed -e 's|VISUAL|EDITOR|g' -i dnsedit
- cd ${S}
+ cd "${S}"
# match our bind config
sed -e 's|0.0.127.in-addr.arpa|127.in-addr.arpa|g' -i ndu.conf
# document the support for the chrooted BIND setup
@@ -42,7 +42,7 @@ src_unpack() {
}
src_compile() {
- cd ${S}/src
+ cd "${S}"/src
emake CFLAGS="${CFLAGS}" CXX="$(tc-getCXX)"
}
@@ -54,3 +54,9 @@ src_install () {
doins ndu.conf
dodoc README INSTALL
}
+
+pkg_postinst() {
+ elog "The ndu binary expects to read your configuration"
+ elog "from /etc/bind/named.conf, however the other binaries"
+ elog "are useful with BIND locally installed."
+}