summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-02-27 06:18:58 +0000
committerMike Frysinger <vapier@gentoo.org>2003-02-27 06:18:58 +0000
commite3e8ab33db6c3997ad71625efed4286ad66ec7aa (patch)
tree2b1edf76c65703f8876c91e79aa97f39f9109a24 /net-dns/djbdns
parentSo how this digest slipped in, while trying to commit (diff)
downloadhistorical-e3e8ab33db6c3997ad71625efed4286ad66ec7aa.tar.gz
historical-e3e8ab33db6c3997ad71625efed4286ad66ec7aa.tar.bz2
historical-e3e8ab33db6c3997ad71625efed4286ad66ec7aa.zip
errno patch for #16396 (#16267)
Diffstat (limited to 'net-dns/djbdns')
-rw-r--r--net-dns/djbdns/djbdns-1.05-r4.ebuild62
-rw-r--r--net-dns/djbdns/files/1.05-errno.patch11
2 files changed, 11 insertions, 62 deletions
diff --git a/net-dns/djbdns/djbdns-1.05-r4.ebuild b/net-dns/djbdns/djbdns-1.05-r4.ebuild
deleted file mode 100644
index fefd14bd0612..000000000000
--- a/net-dns/djbdns/djbdns-1.05-r4.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r4.ebuild,v 1.5 2003/02/13 13:57:03 vapier Exp $
-
-DESCRIPTION="Excellent high-performance DNS services"
-SRC_URI="http://cr.yp.to/djbdns/${P}.tar.gz
- ipv6? http://www.fefe.de/dns/djbdns-1.05-test17.diff.bz2
- http://www.skarnet.org/software/djbdns-fwdzone/djbdns-1.04-fwdzone.patch"
-HOMEPAGE="http://cr.yp.to/djbdns.html"
-LICENSE="as-is"
-KEYWORDS="~x86 ~sparc "
-SLOT="0"
-IUSE="ipv6"
-
-DEPEND="virtual/glibc"
-RDEPEND="${DEPEND}
- >=sys-apps/daemontools-0.70
- sys-apps/ucspi-tcp"
-
-S="${WORKDIR}/${P}"
-
-src_unpack() {
- unpack ${P}.tar.gz
- if [ `use ipv6` ] ; then
- bzcat ${DISTDIR}/djbdns-1.05-test17.diff.bz2 | \
- patch -d ${S} -p1 || die "Failed to apply the ipv6 patch"
- fi
- patch -d ${S} -p1 < ${DISTDIR}/djbdns-1.04-fwdzone.patch
-}
-
-src_compile() {
- echo "gcc ${CFLAGS}" > conf-cc
- echo "gcc" > conf-ld
- echo "/usr" > conf-home
- emake || die "emake failed"
-}
-
-src_install() {
- insinto /etc
- doins dnsroots.global
- into /usr
- for i in *-conf dnscache tinydns walldns rbldns pickdns axfrdns *-get *-data *-edit dnsip dnsipq dnsname dnstxt dnsmx dnsfilter random-ip dnsqr dnsq dnstrace dnstracesort
- do
- dobin $i
- done
- dodoc CHANGES FILES README SYSDEPS TARGETS TODO VERSION
-
- dobin ${FILESDIR}/dnscache-setup
- dobin ${FILESDIR}/tinydns-setup
-}
-
-pkg_postinst() {
- groupadd &>/dev/null nofiles
- id &>/dev/null dnscache || \
- useradd -g nofiles -d /nonexistent -s /bin/false dnscache
- id &>/dev/null dnslog || \
- useradd -g nofiles -d /nonexistent -s /bin/false dnslog
- id &>/dev/null tinydns || \
- useradd -g nofiles -d /nonexistent -s /bin/false tinydns
-
- einfo "Use dnscache-setup and tinydns-setup to help you configure your nameservers!"
-}
diff --git a/net-dns/djbdns/files/1.05-errno.patch b/net-dns/djbdns/files/1.05-errno.patch
new file mode 100644
index 000000000000..41f9e8ed9021
--- /dev/null
+++ b/net-dns/djbdns/files/1.05-errno.patch
@@ -0,0 +1,11 @@
+--- error.h 2001-02-11 15:11:45.000000000 -0600
++++ error.h 2003-02-26 02:10:21.000000000 -0600
+@@ -1,7 +1,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>;
+
+ extern int error_intr;
+ extern int error_nomem;