summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-12-27 14:47:49 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-12-27 14:47:49 +0000
commitbff1bcc1d9bb7c79a63a91e996fab3389331ca95 (patch)
tree6d9fbe2ed2687db0ef945607f6b32b5222d2889f /net-dialup
parentfixed sed expression to only replace pppoe.so but not rp-pppoe.so (diff)
downloadhistorical-bff1bcc1d9bb7c79a63a91e996fab3389331ca95.tar.gz
historical-bff1bcc1d9bb7c79a63a91e996fab3389331ca95.tar.bz2
historical-bff1bcc1d9bb7c79a63a91e996fab3389331ca95.zip
fixed sleep command to work on all locales (bug #36571)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/ppp/ChangeLog5
-rw-r--r--net-dialup/ppp/Manifest4
-rw-r--r--net-dialup/ppp/files/2.4.2b3/net.ppp06
3 files changed, 9 insertions, 6 deletions
diff --git a/net-dialup/ppp/ChangeLog b/net-dialup/ppp/ChangeLog
index 532a9100fa1a..f8fb1cec94d3 100644
--- a/net-dialup/ppp/ChangeLog
+++ b/net-dialup/ppp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-dialup/ppp
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ChangeLog,v 1.41 2003/12/27 14:37:21 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ChangeLog,v 1.42 2003/12/27 14:47:27 lanius Exp $
+
+ 27 Dec 2003; Heinrich Wendel <lanius@gentoo.org> files/2.4.2b3/net.ppp0:
+ fixed sleep command to work on all locales (bug #36571)
27 Dec 2003; Heinrich Wendel <lanius@gentoo.org> ppp-2.4.2_beta3-r1.ebuild:
fixed sed expression to only replace pppoe.so but not rp-pppoe.so
diff --git a/net-dialup/ppp/Manifest b/net-dialup/ppp/Manifest
index e25bcae41270..e64cd8047ac1 100644
--- a/net-dialup/ppp/Manifest
+++ b/net-dialup/ppp/Manifest
@@ -1,6 +1,6 @@
MD5 189de8d4703c6e1e072e147077c7d720 ppp-2.4.2_beta3-r1.ebuild 3575
MD5 82e881305bcfc09888896071fb0219fa ppp-2.4.1-r14.ebuild 4613
-MD5 768f5d55fe9793935fd9dd4f41e40b05 ChangeLog 7641
+MD5 0ffd97db7033cfa868f83749f30d89b6 ChangeLog 7775
MD5 ec2f84816306825d125d0c01bd86758d metadata.xml 163
MD5 4e62cdeb360ca0a22becbd2deb6f2dac files/pon 957
MD5 86cdaf133f7a79fb464f02d83afc7734 files/plog 146
@@ -28,7 +28,7 @@ MD5 1c6a75aa9390438f483e2885ea40ca72 files/2.4.2b3/killaddr-smarter.patch 6225
MD5 12500a756925e9d8f4b2b655e95a2541 files/2.4.2b3/confd.ppp0 2784
MD5 fa2a5b8df496922fa2fb592115953b6b files/2.4.2b3/options-pppoe 53
MD5 bf0ee7e6765e3b18dbe3964be6cd4500 files/2.4.2b3/mpls.patch 10506
-MD5 639e33b901bd31c59ef1b3e0b40f2b08 files/2.4.2b3/net.ppp0 4347
+MD5 acb0f867e42e9a380eaf8e1c312ad63b files/2.4.2b3/net.ppp0 4343
MD5 1fd88dda7f4996799c69a9501d42cc23 files/2.4.2b3/README.mpls 530
MD5 5d83af7b897082a0b1ecd70a2cc2a0c7 files/2.4.2b3/modules.ppp 268
MD5 c4e991f87477e4fe5a402ef3f8dc9a08 files/2.4.2b3/ip-down 642
diff --git a/net-dialup/ppp/files/2.4.2b3/net.ppp0 b/net-dialup/ppp/files/2.4.2b3/net.ppp0
index ab39cc0a4696..b640800ab7c6 100644
--- a/net-dialup/ppp/files/2.4.2b3/net.ppp0
+++ b/net-dialup/ppp/files/2.4.2b3/net.ppp0
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/files/2.4.2b3/net.ppp0,v 1.3 2003/12/22 15:20:43 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/files/2.4.2b3/net.ppp0,v 1.4 2003/12/27 14:47:27 lanius Exp $
# Misc internal variables
CMD_LINE=""
@@ -76,7 +76,7 @@ stop() {
if [ -n "${PID}" ]
then
kill ${PID}
- sleep 0.5
+ sleep 1
# Try to kill pppd repeatedly (sometimes, (e.g. if connection
# is not established) pppd ignores SIGTERM for a while)
@@ -86,7 +86,7 @@ stop() {
while [ -n "${PID_TMP}" ] && [ ${COUNT} -lt 10 ]
do
kill ${PID}
- sleep 0.5
+ sleep 1
PID_TMP=`pstree -p ${PID}`
PID_TMP=`echo ${PID_TMP} | sed -e 's:^.*pppd(\|).*::g'`
let COUNT++