summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2001-10-12 19:15:17 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2001-10-12 19:15:17 +0000
commit04c884e3f37ed0ee430224850651f8b173c1db13 (patch)
tree5135e52e5dfed8a6329e88c6f08d92144d51800b /net-dialup/mgetty
parenta package for freeamp, a really cool mp3/vorbis/cd player that supports ALSA,... (diff)
downloadhistorical-04c884e3f37ed0ee430224850651f8b173c1db13.tar.gz
historical-04c884e3f37ed0ee430224850651f8b173c1db13.tar.bz2
historical-04c884e3f37ed0ee430224850651f8b173c1db13.zip
Long overdue ebuild; needs testing; vgetty included by default right now.
Diffstat (limited to 'net-dialup/mgetty')
-rw-r--r--net-dialup/mgetty/files/digest-mgetty-1.1.261
-rw-r--r--net-dialup/mgetty/mgetty-1.1.26.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-dialup/mgetty/files/digest-mgetty-1.1.26 b/net-dialup/mgetty/files/digest-mgetty-1.1.26
new file mode 100644
index 000000000000..924ca4ab8d40
--- /dev/null
+++ b/net-dialup/mgetty/files/digest-mgetty-1.1.26
@@ -0,0 +1 @@
+MD5 02d60e05acdd406b1e86222e8a373a7e mgetty1.1.26-Apr16.tar.gz
diff --git a/net-dialup/mgetty/mgetty-1.1.26.ebuild b/net-dialup/mgetty/mgetty-1.1.26.ebuild
new file mode 100644
index 000000000000..19d41237dac7
--- /dev/null
+++ b/net-dialup/mgetty/mgetty-1.1.26.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Grant Goodyear <g2boojum@gentoo.org>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Fax and Voice modem programs."
+
+SRC_URI="ftp://alpha.greenie.net/pub/mgetty/source/1.1/${PN}${PV}-Apr16.tar.gz"
+HOMEPAGE="http://alpha.greenie.net/mgetty"
+
+DEPEND="sys-libs/glibc
+ app-text/tetex
+ sys-apps/gawk
+ sys-devel/perl"
+
+src_compile() {
+ sed -e 's/var\/log\/mgetty/var\/log\/mgetty\/mgetty/' policy.h-dist > policy.h
+ #doesn't compile using default i686 flags
+ #make -e CFLAGS="${CFLAGS}" || die
+ emake || die
+ cd voice
+ emake || die
+ cd ..
+ #emake (previously known as pmake) is a script that calls the standard
+ # GNU make with parallel
+ #building options for speedier builds on SMP systems. Use emake first;
+ # it might not work. If not, then replace the line above with:
+
+ #make || die
+}
+
+src_install () {
+ #you must *personally verify* that this trick doesn't install
+ #anything outside of DESTDIR; do this by reading and understanding
+ #the install part of the Makefiles. Also note that this will often
+ #also work for autoconf stuff (usually much more often than DESTDIR,
+ #which is actually quite rare.
+
+ dodir /var/spool
+ make prefix=${D}/usr spool=${D}/var/spool install || die
+ cd voice
+ make prefix=${D}/usr spool=${D}/var/spool install || die
+
+ #make DESTDIR=${D} install || die
+ #again, verify the Makefiles! We don't want anything falling outside
+ #of ${D}.
+}
+