summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2004-11-17 19:39:52 +0000
committerAlin Năstac <mrness@gentoo.org>2004-11-17 19:39:52 +0000
commit69fd1ac86fc7fbc8d6f4c4c722adf1461cbf13de (patch)
tree90c75c67723f835858bd53020abb3dda6f6cea7e /net-dialup/globespan-adsl/globespan-adsl-0.10.ebuild
parentFixed broken Manifest. (diff)
downloadhistorical-69fd1ac86fc7fbc8d6f4c4c722adf1461cbf13de.tar.gz
historical-69fd1ac86fc7fbc8d6f4c4c722adf1461cbf13de.tar.bz2
historical-69fd1ac86fc7fbc8d6f4c4c722adf1461cbf13de.zip
commit
Diffstat (limited to 'net-dialup/globespan-adsl/globespan-adsl-0.10.ebuild')
-rw-r--r--net-dialup/globespan-adsl/globespan-adsl-0.10.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-dialup/globespan-adsl/globespan-adsl-0.10.ebuild b/net-dialup/globespan-adsl/globespan-adsl-0.10.ebuild
new file mode 100644
index 000000000000..07e8d1eb1cbb
--- /dev/null
+++ b/net-dialup/globespan-adsl/globespan-adsl-0.10.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/globespan-adsl/globespan-adsl-0.10.ebuild,v 1.1 2004/11/17 19:39:52 mrness Exp $
+
+inherit fixheadtails
+
+MY_PN="eciadsl-usermode-${PV}"
+S=${WORKDIR}/${MY_PN}
+DESCRIPTION="Driver for various ADSL modems. Also known as EciAdsl."
+SRC_URI="http://eciadsl.flashtux.org/download/${MY_PN}.tar.gz"
+HOMEPAGE="http://eciadsl.flashtux.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="tcltk"
+
+DEPEND=">=net-dialup/ppp-2.4.1"
+RDEPEND="${DEPEND}
+ tcltk? ( >=dev-lang/tk-8.3.4 )"
+
+src_unpack() {
+ unpack ${A} || die "failed to unpack"
+ cd ${S} || die "source directory not found"
+ ht_fix_all
+
+ einfo "Correct obsolete nice parameters"
+ sed -i -e 's:nice --:nice -n -:' eciadsl-{start,stop,doctor} || \
+ die "failed to replace nice params"
+}
+
+src_compile() {
+ BIN_DIR="/usr/bin"
+ BIN_DIR=${BIN_DIR} ./configure --prefix=/usr --conf-prefix=/etc \
+ --conf-dir=/eciadsl --doc-prefix=/usr/share/doc --doc-dir=/eciads \
+ || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make ROOT=${D} install || die "Install failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Package succesfully installed you should now run "
+ einfo "eciconf.sh (graphical, requires TCL/TK) or eciconftxt.sh"
+ einfo
+ einfo "Paquetage installé avec succés vous devriez maintenant"
+ einfo "executer eciconf.sh (qui requiert TCL/TK) ou eciconftxt.sh"
+ einfo
+ ewarn "Please note that if you're using a 2.6.x kernel you'll"
+ ewarn "probably need to apply a patch to fix a USB bug. See"
+ ewarn "http://eciadsl.flashtux.org/download/beta/"
+ einfo
+}