summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-09-21 21:21:44 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-09-21 21:21:44 +0000
commitffe2eb1d8aeabf7a622454e8989f951bdc710684 (patch)
treeac2dc0d03a90d45cd36f4b01caedf261cb18ba19 /net-analyzer
parentadd xattr flag. (diff)
downloadhistorical-ffe2eb1d8aeabf7a622454e8989f951bdc710684.tar.gz
historical-ffe2eb1d8aeabf7a622454e8989f951bdc710684.tar.bz2
historical-ffe2eb1d8aeabf7a622454e8989f951bdc710684.zip
bug 106772, allow build without X
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ethereal/ChangeLog7
-rw-r--r--net-analyzer/ethereal/Manifest4
-rw-r--r--net-analyzer/ethereal/ethereal-0.10.12.ebuild11
3 files changed, 13 insertions, 9 deletions
diff --git a/net-analyzer/ethereal/ChangeLog b/net-analyzer/ethereal/ChangeLog
index 1982c05bcec9..54b735befedd 100644
--- a/net-analyzer/ethereal/ChangeLog
+++ b/net-analyzer/ethereal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/ethereal
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.136 2005/09/19 19:55:39 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.137 2005/09/21 21:21:44 vanquirius Exp $
+
+ 21 Sep 2005; Marcelo Goes <vanquirius@gentoo.org> ethereal-0.10.12.ebuild:
+ Fix ebuild so that it works without building X. Passing --disable-ethereal
+ _does_ have an influence now. Fixes bug 106772. Thanks to Chris
+ Paulson-Ellis <chris at edesix dot com>.
19 Sep 2005; Marcelo Goes <vanquirius@gentoo.org>
-ethereal-0.10.11.ebuild, -ethereal-0.10.11-r1.ebuild,
diff --git a/net-analyzer/ethereal/Manifest b/net-analyzer/ethereal/Manifest
index 6321f9dd50b2..cfb57cf9c70c 100644
--- a/net-analyzer/ethereal/Manifest
+++ b/net-analyzer/ethereal/Manifest
@@ -1,5 +1,5 @@
-MD5 522d6f7acd4653ce2c99368ace3db6a9 ethereal-0.10.12.ebuild 3505
-MD5 d4d00cfbd05c26084f690ad15d70cdad ChangeLog 10741
+MD5 f8df469837b3a964d556a54c89c4dd7e ethereal-0.10.12.ebuild 3472
+MD5 5bce438ee5ecab27c437a1b0be899305 ChangeLog 11005
MD5 17a9be2cf8cb9f24e7e5b398392483b4 metadata.xml 224
MD5 34bd8a0285aea402be479f40304aa947 files/digest-ethereal-0.10.12 70
MD5 a4d5fb3621ed4e86f311718f1447a870 files/fifo.patch 1138
diff --git a/net-analyzer/ethereal/ethereal-0.10.12.ebuild b/net-analyzer/ethereal/ethereal-0.10.12.ebuild
index c460b2b6b820..6dcc147824b6 100644
--- a/net-analyzer/ethereal/ethereal-0.10.12.ebuild
+++ b/net-analyzer/ethereal/ethereal-0.10.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.10.12.ebuild,v 1.9 2005/09/19 19:55:39 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.10.12.ebuild,v 1.10 2005/09/21 21:21:44 vanquirius Exp $
inherit libtool flag-o-matic eutils
@@ -14,10 +14,6 @@ SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
IUSE="adns gtk ipv6 snmp ssl kerberos"
-# if --disable-gtk2 is not passed to configure it will try to build with glib-2.0.
-# --disable-ethereal do not have an influence.
-
-
RDEPEND=">=sys-libs/zlib-1.1.4
snmp? ( >=net-analyzer/net-snmp-5.1.1 )
>=dev-util/pkgconfig-0.15.0
@@ -54,8 +50,10 @@ src_compile() {
local myconf
if use gtk; then
- myconf="${myconf} $(use_enable gtk gtk2)"
+ einfo "Building with gtk support"
else
+ einfo "Building without gtk support"
+ myconf="${myconf} --disable-ethereal"
# the asn1 plugin needs gtk
sed -i -e '/plugins.asn1/d' Makefile.in || die "sed failed"
sed -i -e '/^SUBDIRS/s/asn1//' plugins/Makefile.in || die "sed failed"
@@ -67,6 +65,7 @@ src_compile() {
$(use_with adns) \
$(use_with kerberos krb5) \
$(use_with snmp net-snmp) \
+ $(use_enable gtk gtk2) \
--without-ucd-snmp \
--enable-dftest \
--enable-randpkt \