summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-10-14 11:31:09 +0000
committerEldad Zack <eldad@gentoo.org>2004-10-14 11:31:09 +0000
commitf83050c4aed164c6004065bc43f0c0e2fc35449b (patch)
treeba515f25b3e492511c4675963cf22b5d1c86d13a /net-analyzer
parenttidy up postinstall-en.txt (diff)
downloadhistorical-f83050c4aed164c6004065bc43f0c0e2fc35449b.tar.gz
historical-f83050c4aed164c6004065bc43f0c0e2fc35449b.tar.bz2
historical-f83050c4aed164c6004065bc43f0c0e2fc35449b.zip
pkg_setup fix
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/acid/ChangeLog5
-rw-r--r--net-analyzer/acid/Manifest10
-rw-r--r--net-analyzer/acid/acid-0.9.6_beta23.ebuild23
3 files changed, 25 insertions, 13 deletions
diff --git a/net-analyzer/acid/ChangeLog b/net-analyzer/acid/ChangeLog
index 2730692162f1..c3b8b1c63e56 100644
--- a/net-analyzer/acid/ChangeLog
+++ b/net-analyzer/acid/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/acid
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/acid/ChangeLog,v 1.4 2004/10/11 23:10:52 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/acid/ChangeLog,v 1.5 2004/10/14 11:31:09 eldad Exp $
+
+ 14 Oct 2004; Eldad Zack <eldad@gentoo.org> acid-0.9.6_beta23.ebuild:
+ Fixed pkg_setup.
12 Oct 2004; Eldad Zack <eldad@gentoo.org> acid-0.9.6_beta23.ebuild:
Added deps media-libs/gd and dev-php/mod_php. Added a check to see if mod_php
diff --git a/net-analyzer/acid/Manifest b/net-analyzer/acid/Manifest
index 27127cf097a1..13ecf0b98735 100644
--- a/net-analyzer/acid/Manifest
+++ b/net-analyzer/acid/Manifest
@@ -1,14 +1,14 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 00843ef9eb0ae8f1b30d6a9b56a9618e acid-0.9.6_beta23.ebuild 1450
-MD5 0dbe0629180e600b08e15a03f64112d0 ChangeLog 1039
+MD5 1c57eecc139660049e269cc20e7798b3 acid-0.9.6_beta23.ebuild 1518
+MD5 be6f8bef09154d089b5a9cc386ed7071 ChangeLog 1130
MD5 d5e9bd932b7a02f7fbaa05865d864854 metadata.xml 248
MD5 26f34d01017d5c8acb2d58fd139cef67 files/digest-acid-0.9.6_beta23 65
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBaxLiT+MN7JbqCpMRAhCMAJ4wmzgopWhUm5CIv/lId27jIIHQKgCfVS24
-0a2zZcLaQnBIBOmAltamN44=
-=PyL6
+iD8DBQFBbmNGT+MN7JbqCpMRAv8rAJ9bOn8rMaHaJp41aLinxqykGhVxmgCaAlao
+F8MoZAydwwEG6nvmjxF4q+k=
+=Yz42
-----END PGP SIGNATURE-----
diff --git a/net-analyzer/acid/acid-0.9.6_beta23.ebuild b/net-analyzer/acid/acid-0.9.6_beta23.ebuild
index 0512dde4808f..52564b02f00c 100644
--- a/net-analyzer/acid/acid-0.9.6_beta23.ebuild
+++ b/net-analyzer/acid/acid-0.9.6_beta23.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/acid/acid-0.9.6_beta23.ebuild,v 1.5 2004/10/11 23:10:52 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/acid/acid-0.9.6_beta23.ebuild,v 1.6 2004/10/14 11:31:09 eldad Exp $
inherit webapp
@@ -24,15 +24,24 @@ DEPEND="apache2? ( >=net-www/apache-2 )
dev-php/mod_php
net-analyzer/snort"
-pkg_setup() {
- # Check if mod_php was emerged with GD
- my_modphp=$(best_version dev-php/mod_php)
+check_useflag() {
+ local my_pkg=$(best_version ${1})
+ local my_flag=${2}
- if [[ ! $(grep -wo gd /var/db/pkg/${my_modphp}/USE) ]];
+ if [[ $(grep -wo ${my_flag} /var/db/pkg/${my_pkg}/USE) ]]
then
- eerror "${my_modphp} was compiled without gd support. Please reemerge it with USE=gd."
- die "pkg_setup failed"
+ return 0
fi
+
+ eerror "${my_pkg} was compiled without ${my_flag}. Please re-emerge it with USE=${my_flag}"
+ die "check_useflag failed"
+
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ check_useflag dev-php/mod_php gd
}
src_compile () {