summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-07-16 09:25:01 +0000
committerEldad Zack <eldad@gentoo.org>2004-07-16 09:25:01 +0000
commitd86e96c09e5512bacd6e3b071b359b514b8e94e7 (patch)
tree4f7912d647c2aebc9976e870b1b2886c7336886a /net-analyzer
parentAdded to ~ppc (diff)
downloadhistorical-d86e96c09e5512bacd6e3b071b359b514b8e94e7.tar.gz
historical-d86e96c09e5512bacd6e3b071b359b514b8e94e7.tar.bz2
historical-d86e96c09e5512bacd6e3b071b359b514b8e94e7.zip
version bump and then some; closes #57173
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/pmacct/ChangeLog8
-rw-r--r--net-analyzer/pmacct/Manifest14
-rw-r--r--net-analyzer/pmacct/files/digest-pmacct-0.7.11
-rw-r--r--net-analyzer/pmacct/pmacct-0.7.1.ebuild45
4 files changed, 66 insertions, 2 deletions
diff --git a/net-analyzer/pmacct/ChangeLog b/net-analyzer/pmacct/ChangeLog
index 37023c12383f..04300d503581 100644
--- a/net-analyzer/pmacct/ChangeLog
+++ b/net-analyzer/pmacct/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/pmacct
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.1 2004/07/09 14:11:02 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.2 2004/07/16 09:25:01 eldad Exp $
+
+*pmacct-0.7.1 (16 Jul 2004)
+
+ 16 Jul 2004; Eldad Zack <eldad@gentoo.org> +pmacct-0.7.1.ebuild:
+ Version bump. Added mmap useflag. dodoc fixes. Thanks to Bjarke Freund-Hansen
+ <gentoo-bugzilla@rocekiller.dk>. Closes #57173
09 Jul 2004; Eldad Zack <eldad@gentoo.org> +files/pmacctd-conf.d,
+files/pmacctd-init.d:
diff --git a/net-analyzer/pmacct/Manifest b/net-analyzer/pmacct/Manifest
index 95ddbba86d07..5aa7fa5aad54 100644
--- a/net-analyzer/pmacct/Manifest
+++ b/net-analyzer/pmacct/Manifest
@@ -1,6 +1,18 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 e2059621c7287e9ad39fb7ebc8bf5c47 pmacct-0.7.1.ebuild 1297
MD5 95491b12c21869e140dc23899f437460 pmacct-0.7.0.ebuild 1242
-MD5 5c0c55b023d6c7aab14a0edb49a77f78 ChangeLog 403
+MD5 8b9ca2401cd4067a7bb6937bae583b93 ChangeLog 629
MD5 808a9a788ae7955af0a3c442cafee866 metadata.xml 243
MD5 50333f1c79a80df31266ce7235cbf36c files/pmacctd-conf.d 313
MD5 2afa8e97312b03f3e119c0befed9e7d3 files/pmacctd-init.d 869
MD5 9c8f7c9b62771e795e0d0477b09d6242 files/digest-pmacct-0.7.0 64
+MD5 44c1834789fa301914395bc47ea184bd files/digest-pmacct-0.7.1 64
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.4 (GNU/Linux)
+
+iD8DBQFA955lT+MN7JbqCpMRAkSAAJ4/194okjhDEoTtRMYq0oB23but0gCghwtL
+xLc0a8loMKR+caxuLJX017o=
+=XC66
+-----END PGP SIGNATURE-----
diff --git a/net-analyzer/pmacct/files/digest-pmacct-0.7.1 b/net-analyzer/pmacct/files/digest-pmacct-0.7.1
new file mode 100644
index 000000000000..8f74cad4bf19
--- /dev/null
+++ b/net-analyzer/pmacct/files/digest-pmacct-0.7.1
@@ -0,0 +1 @@
+MD5 5fa26df1d70f6895453ad72a6d039545 pmacct-0.7.1.tar.gz 159832
diff --git a/net-analyzer/pmacct/pmacct-0.7.1.ebuild b/net-analyzer/pmacct/pmacct-0.7.1.ebuild
new file mode 100644
index 000000000000..da20c496efc7
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-0.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.7.1.ebuild,v 1.1 2004/07/16 09:25:01 eldad Exp $
+
+DESCRIPTION="A network tool to gather ip traffic informations"
+HOMEPAGE="http://www.ba.cnr.it/~paolo/pmacct/"
+SRC_URI="http://www.ba.cnr.it/~paolo/pmacct/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="mysql postgres mmap"
+
+RDEPEND="net-libs/libpcap
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )"
+
+src_compile() {
+ econf `use_enable mysql` \
+ `use_enable postgres pgsql` \
+ `use_enable mmap` \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc README EXAMPLES KNOWN-BUGS CONFIG-KEYS FAQS ChangeLog docs/SIGNALS docs/PLUGINS docs/INTERNALS TODO TOOLS || die "dodoc failed"
+
+ for dirname in examples sql pcap; do
+ docinto ${dirname}
+ dodoc ${dirname}/* || die "dodoc failed"
+ done
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pmacctd-init.d pmacctd || die "newexe failed"
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/pmacctd-conf.d pmacctd || die "newins failed"
+
+ insinto /etc
+ newins ${S}/examples/pmacctd-imt.conf.example pmacctd.conf.example || "newins failed"
+}
+