summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-17 03:44:42 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-17 03:44:42 +0000
commitaa1f053ef853fc3fa9210818e08bc6976be0ae4e (patch)
tree1d52cebfcb2ccbc95af0f9b9862f14f197ec7068 /net-analyzer
parentMarked stable for x86. Changed to epatch. Fixed doc install directory. (diff)
downloadhistorical-aa1f053ef853fc3fa9210818e08bc6976be0ae4e.tar.gz
historical-aa1f053ef853fc3fa9210818e08bc6976be0ae4e.tar.bz2
historical-aa1f053ef853fc3fa9210818e08bc6976be0ae4e.zip
added tcpd and gtk2 variable support. other cleanups. Marked stable
for x86
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nessus-core/ChangeLog8
-rw-r--r--net-analyzer/nessus-core/nessus-core-1.2.7.ebuild42
2 files changed, 29 insertions, 21 deletions
diff --git a/net-analyzer/nessus-core/ChangeLog b/net-analyzer/nessus-core/ChangeLog
index 4cb5eda9325f..ac4e5deb71ba 100644
--- a/net-analyzer/nessus-core/ChangeLog
+++ b/net-analyzer/nessus-core/ChangeLog
@@ -1,9 +1,15 @@
# ChangeLog for net-analyzer/nessus-core
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/ChangeLog,v 1.10 2003/01/04 03:31:12 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/ChangeLog,v 1.11 2003/01/17 03:44:42 raker Exp $
*nessus-core-1.2.7 (04 Jan 2003)
+ 16 Jan 2003; Nick Hadaway <raker@gentoo.org> nessus-core-1.2.7.ebuild :
+ Added support for tcpd and gtk2 use variables. gtk takes precedence
+ over gtk2 has the latter is unstable. Properly disables the gtk
+ portion if neither gtk nor gtk2 is specified in use. Marked stable
+ for x86.
+
04 Jan 2003; Daniel Ahlberg <aliz@gentoo.org> :
Version bump. Found by Raskasi <raskasi@gmx.net>.
diff --git a/net-analyzer/nessus-core/nessus-core-1.2.7.ebuild b/net-analyzer/nessus-core/nessus-core-1.2.7.ebuild
index e68fcfb57169..b300e8a2ac89 100644
--- a/net-analyzer/nessus-core/nessus-core-1.2.7.ebuild
+++ b/net-analyzer/nessus-core/nessus-core-1.2.7.ebuild
@@ -1,54 +1,56 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-1.2.7.ebuild,v 1.1 2003/01/04 03:31:12 aliz Exp $
-
-IUSE="X gtk"
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nessus-core/nessus-core-1.2.7.ebuild,v 1.2 2003/01/17 03:44:42 raker Exp $
+IUSE="tcpd X gtk gtk2"
S=${WORKDIR}/${PN}
-
DESCRIPTION="A remote security scanner for Linux (nessus-core)"
HOMEPAGE="http://www.nessus.org/"
SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/${P}.tar.gz"
-
DEPEND="=net-analyzer/libnasl-${PV}
+ tcpd? ( sys-apps/tcp-wrappers )
X? ( x11-base/xfree )
- gtk? ( =x11-libs/gtk+-1.2* )"
-
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( =x11-libs/gtk+-2* )"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc -sparc ~alpha"
+KEYWORDS="x86 ~ppc -sparc ~alpha"
src_compile() {
-
+ local myconf
use X && myconf="--with-x" || myconf="--without-x"
-
- use gtk && myconf="--enable-gtk" || myconf="--disable-gtk"
-
- econf || die "configure failed"
-
+ if [ `use gtk` ]; then
+ myconf="${myconf} --enable-gtk"
+ elif [ `use gtk2`]; then
+ myconf="${myconf} --enable-gtk"
+ else
+ myconf="${myconf} --disable-gtk"
+ fi
+ use tcpd && myconf="${myconf} --enable-tcpwrappers" \
+ || myconf="${myconf} --disable-tcpwrappers"
+ if [ ! -z $DEBUGBUILD ]; then
+ myconf="${myconf} --enable-debug"
+ else
+ myconf="${myconf} --disable-debug"
+ fi
+ econf ${myconf} || die "configure failed"
emake || die "emake failed"
}
src_install() {
-
make \
prefix=${D}/usr \
sysconfdir=${D}/etc \
localstatedir=${D}/var/lib \
mandir=${D}/usr/share/man \
install || die "Install failed nessus-core"
-
cd ${S}
- docinto nessus-core
dodoc README* UPGRADE_README CHANGES
dodoc doc/*.txt doc/ntp/*
-
insinto /etc/init.d
insopts -m 755
newins ${FILESDIR}/nessusd-r6 nessusd
-
keepdir /var/lib/nessus/logs
keepdir /var/lib/nessus/users
-
}