summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-10-11 23:10:52 +0000
committerEldad Zack <eldad@gentoo.org>2004-10-11 23:10:52 +0000
commita7fb2ed7b8b76b449f06412b7c910e75f5f3de2d (patch)
tree611fa706e0e48eac2f45e1b68659b9e55fba9dca /net-analyzer
parentAdded selinux to IUSE and removed old ebuild versions (diff)
downloadhistorical-a7fb2ed7b8b76b449f06412b7c910e75f5f3de2d.tar.gz
historical-a7fb2ed7b8b76b449f06412b7c910e75f5f3de2d.tar.bz2
historical-a7fb2ed7b8b76b449f06412b7c910e75f5f3de2d.zip
deps (#63441), sed typo (#64164).
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/acid/ChangeLog8
-rw-r--r--net-analyzer/acid/Manifest14
-rw-r--r--net-analyzer/acid/acid-0.9.6_beta23.ebuild17
3 files changed, 34 insertions, 5 deletions
diff --git a/net-analyzer/acid/ChangeLog b/net-analyzer/acid/ChangeLog
index 408b254ddaac..2730692162f1 100644
--- a/net-analyzer/acid/ChangeLog
+++ b/net-analyzer/acid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/acid
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/acid/ChangeLog,v 1.3 2004/07/31 08:39:01 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/acid/ChangeLog,v 1.4 2004/10/11 23:10:52 eldad Exp $
+
+ 12 Oct 2004; Eldad Zack <eldad@gentoo.org> acid-0.9.6_beta23.ebuild:
+ Added deps media-libs/gd and dev-php/mod_php. Added a check to see if mod_php
+ was emerged with USE=gd, and bail if not. Closes bug #63441. Thanks to
+ Benjamin Smee (strerror) <ben@disciplina.net>. Fixed typo in sedding. Closes
+ #64164. Thanks to Jakub Moc <jakub.moc@seznam.cz>.
31 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org>
acid-0.9.6_beta23.ebuild:
diff --git a/net-analyzer/acid/Manifest b/net-analyzer/acid/Manifest
index 65e24835b097..27127cf097a1 100644
--- a/net-analyzer/acid/Manifest
+++ b/net-analyzer/acid/Manifest
@@ -1,4 +1,14 @@
-MD5 d5ef92e9d5d177c5329ee0b00ab91cae acid-0.9.6_beta23.ebuild 1139
-MD5 353788c8785d5f1b3adc69b33dd185c4 ChangeLog 686
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 00843ef9eb0ae8f1b30d6a9b56a9618e acid-0.9.6_beta23.ebuild 1450
+MD5 0dbe0629180e600b08e15a03f64112d0 ChangeLog 1039
MD5 d5e9bd932b7a02f7fbaa05865d864854 metadata.xml 248
MD5 26f34d01017d5c8acb2d58fd139cef67 files/digest-acid-0.9.6_beta23 65
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBaxLiT+MN7JbqCpMRAhCMAJ4wmzgopWhUm5CIv/lId27jIIHQKgCfVS24
+0a2zZcLaQnBIBOmAltamN44=
+=PyL6
+-----END PGP SIGNATURE-----
diff --git a/net-analyzer/acid/acid-0.9.6_beta23.ebuild b/net-analyzer/acid/acid-0.9.6_beta23.ebuild
index 361ae32093b2..0512dde4808f 100644
--- a/net-analyzer/acid/acid-0.9.6_beta23.ebuild
+++ b/net-analyzer/acid/acid-0.9.6_beta23.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/acid/acid-0.9.6_beta23.ebuild,v 1.4 2004/09/04 18:55:05 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/acid/acid-0.9.6_beta23.ebuild,v 1.5 2004/10/11 23:10:52 eldad Exp $
inherit webapp
@@ -20,8 +20,21 @@ DEPEND="apache2? ( >=net-www/apache-2 )
!apache2? ( =net-www/apache-1* )
>=dev-php/adodb-4.0.5
>=dev-php/jpgraph-1.12.2
+ media-libs/gd
+ dev-php/mod_php
net-analyzer/snort"
+pkg_setup() {
+ # Check if mod_php was emerged with GD
+ my_modphp=$(best_version dev-php/mod_php)
+
+ if [[ ! $(grep -wo gd /var/db/pkg/${my_modphp}/USE) ]];
+ then
+ eerror "${my_modphp} was compiled without gd support. Please reemerge it with USE=gd."
+ die "pkg_setup failed"
+ fi
+}
+
src_compile () {
einfo "Nothing to compile."
}
@@ -29,7 +42,7 @@ src_compile () {
src_install () {
webapp_src_preinst
- sed -i -e '12s:^$DBlib_path =.*:$DBlib_path = "/usr/lib/php/adodb":' acid_conf.php
+ sed -i -e '12s:^$DBlib_path =.*:$DBlib_path = "/usr/lib/php/adodb";:' acid_conf.php
insinto ${MY_HTDOCSDIR}
doins *