summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-10-14 04:41:29 +0000
committerEldad Zack <eldad@gentoo.org>2004-10-14 04:41:29 +0000
commit530974e9a3e817ee2dfffe5d5c52293d58180c65 (patch)
tree7d296bf137a9e188984f79e4f472707e7581ce7d /net-analyzer
parentStable on sparc and x86. (diff)
downloadhistorical-530974e9a3e817ee2dfffe5d5c52293d58180c65.tar.gz
historical-530974e9a3e817ee2dfffe5d5c52293d58180c65.tar.bz2
historical-530974e9a3e817ee2dfffe5d5c52293d58180c65.zip
bump and fixes (bug #63889)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti/ChangeLog8
-rw-r--r--net-analyzer/cacti/Manifest12
-rw-r--r--net-analyzer/cacti/cacti-0.8.6b.ebuild139
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.6b1
4 files changed, 149 insertions, 11 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 88a0b8e614f9..c0eef924fd80 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.30 2004/08/23 10:02:16 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.31 2004/10/14 04:41:29 eldad Exp $
+
+*cacti-0.8.6b (14 Oct 2004)
+
+ 14 Oct 2004; Eldad Zack <eldad@gentoo.org> +cacti-0.8.6b.ebuild:
+ Version bump. Updated deps (cron, php). Check useflags of php/mod_php. Got rid
+ of version detection, and corrrected a few postinst instructions.
*cacti-0.8.5a-r2 (23 Aug 2004)
diff --git a/net-analyzer/cacti/Manifest b/net-analyzer/cacti/Manifest
index 516de0a4ab98..1bae6c219e76 100644
--- a/net-analyzer/cacti/Manifest
+++ b/net-analyzer/cacti/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 3c5429026810fd126265aac06c4cdd93 cacti-0.8.5a-r1.ebuild 4654
+MD5 87188840d9a0b63e57858afb1a30d245 cacti-0.8.6b.ebuild 4085
MD5 4ed1408b763c30830d5f22ee0bd0b6c3 ChangeLog 3913
MD5 9683bb7323c40d69b48d54ad0eb169ed metadata.xml 221
MD5 7cc300afca6489e25dbf3da4fc8f63c5 cacti-0.8.5a-r2.ebuild 4218
+MD5 5415dc0df13fd1528eb90acce7f44989 files/digest-cacti-0.8.6b 65
MD5 9921205d0e13d5948104d5de2e58d3ee files/cacti-0.8.5a-sql-injection.patch 625
MD5 44637d48edf68b76a472c70817449cd6 files/digest-cacti-0.8.5a-r1 64
MD5 44637d48edf68b76a472c70817449cd6 files/digest-cacti-0.8.5a-r2 64
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.4 (GNU/Linux)
-
-iD8DBQFBKgYuT+MN7JbqCpMRAt77AJ9DUWvfkR/XdG1n7YbToNUtGpPzMwCfciRS
-haoJsDAsF/mSzE9eTPDo8BM=
-=Gaim
------END PGP SIGNATURE-----
diff --git a/net-analyzer/cacti/cacti-0.8.6b.ebuild b/net-analyzer/cacti/cacti-0.8.6b.ebuild
new file mode 100644
index 000000000000..49cfe47ea320
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.6b.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6b.ebuild,v 1.1 2004/10/14 04:41:29 eldad Exp $
+
+inherit eutils webapp
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+IUSE="snmp"
+
+DEPEND=""
+
+# TODO: RDEPEND Not just apache... but there's no virtual/webserver (yet)
+
+RDEPEND="net-www/apache
+ snmp? ( virtual/snmp )
+ net-analyzer/rrdtool
+ dev-db/mysql
+ virtual/cron
+ dev-php/php
+ dev-php/mod_php"
+
+check_useflag() {
+ local my_pkg=$(best_version ${1})
+ local my_flag=${2}
+
+ if [[ $(grep -wo ${my_flag} /var/db/pkg/${my_pkg}/USE) ]]
+ then
+ return 0
+ fi
+
+ eerror "${my_pkg} was compiled without ${my_flag}. Please re-emerge it with USE=${my_flag}"
+ die "check_useflag failed"
+
+}
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ # Check if php, mod_php was emerged with mysql useflag
+
+ check_useflag dev-php/php mysql
+ check_useflag dev-php/mod_php mysql
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc LICENSE
+ rm LICENSE README
+
+ dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
+ rm -rf docs
+ #Don't overwrite old config
+ mv include/config.php include/config-sample.php
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${D}${MY_HTDOCSDIR}
+ cp -r . ${D}${MY_HTDOCSDIR}
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ local webserver_root=${VHOST_ROOT}/${VHOST_HTDOCS_INSECURE}
+
+ einfo "Install Notes: Assuming your webserver is at ${webserver_root},"
+ einfo "and that the webserver group is ${VHOST_DEFAULT_GID}."
+ einfo
+ einfo "New Install"
+ einfo
+ einfo "1. Create the new cacti database"
+ einfo " shell> mysqladmin --user=root create cacti"
+ einfo "2. Import the default cacti database:"
+ einfo " shell> mysql cacti < ${webserver_root}/${PN}/cacti.sql"
+ einfo "3. Optional: Create a MySQL username and password for cacti."
+ einfo " shell> mysql --user=root mysql"
+ einfo " mysql> GRANT ALL ON cacti.* TO cactiuser@localhost IDENTIFIED BY 'somepassword';"
+ einfo " mysql> flush privileges;"
+ einfo "4. Copy ${webserver_root}/${PN}/include/config-sample.php to config.php."
+ einfo " + Modify the MySQL user, password and database for your"
+ einfo " cacti configuration."
+ einfo " \$database_default = \"cacti\";"
+ einfo " \$database_hostname = \"localhost\";"
+ einfo " \$database_username = \"cactiuser\";"
+ einfo " \$database_password = \"cacti\";"
+ einfo "6. Point your web browser to: http://your-server/cacti/"
+ einfo " Make sure to fill in all of the path variables carefully and"
+ einfo " correctly on the following screen."
+ einfo
+ einfo "Upgrading"
+ einfo
+ einfo "Before cacti works you must upgrade the cacti database:"
+ einfo "1. Backup the old cacti database:"
+ einfo " shell> mysqlhotcopy --suffix=_old cacti"
+ einfo "2. Drop the old cacti database:"
+ einfo " shell> mysqladmin -p drop cacti"
+ einfo "3. Create the new cacti database"
+ einfo " shell> mysqladmin --user=root create cacti"
+ einfo "4. Import the default cacti database:"
+ einfo " shell> mysql cacti < ${webserver_root}/${PN}/cacti.sql"
+ einfo "5. Edit ${webserver_root}/${PN}/include/config.php."
+ einfo " + Modify the MySQL user, password and database for your"
+ einfo " cacti configuration."
+ einfo " \$database_default = \"cacti\";"
+ einfo " \$database_hostname = \"localhost\";"
+ einfo " \$database_username = \"cactiuser\";"
+ einfo " \$database_password = \"cacti\";"
+ einfo "6. Point your web browser to: http://your-server/cacti/"
+ einfo " Select \"Upgrade\"."
+ einfo " Make sure to fill in all of the path variables carefully and"
+ einfo " correctly on the following screen."
+ einfo "7. Test your upgraded installation. When all is fine you can"
+ einfo "drop the cacti_old database like so:"
+ einfo " shell> mysqladmin -p drop cacti_old"
+ einfo
+ einfo "Either new or upgrading, make sure you have a cron job -"
+ einfo "Add this line to your /etc/crontab file:"
+ einfo " */5 * * * * ${VHOST_DEFAULT_GID} php ${webserver_root}/${PN}/poller.php > /dev/null 2>&1"
+ einfo
+ einfo "FINALLY, you must have these settings in your php.ini:"
+ einfo " register_globals = On"
+ einfo " register_argc_argv = On"
+ einfo
+ ewarn "Note that you should use poller.php as the cronjob"
+ ewarn "instead of cmd.php (as it was with earlier version)"
+ ewarn "to enable you to switch between cmd.php and cactid."
+
+ webapp_pkg_postinst
+}
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.6b b/net-analyzer/cacti/files/digest-cacti-0.8.6b
new file mode 100644
index 000000000000..0343fd123fdc
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.6b
@@ -0,0 +1 @@
+MD5 6c6304aed42823b70648b4d5a3c329bd cacti-0.8.6b.tar.gz 1021894