summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-10-03 09:55:29 +0000
committerMamoru Komachi <usata@gentoo.org>2004-10-03 09:55:29 +0000
commit2a9a38b8e21291a1783864b302c5ea805804c328 (patch)
tree009910c410bf9644b48cf05e84723edb73590e3a /net-analyzer
parentStable on alpha. (diff)
downloadhistorical-2a9a38b8e21291a1783864b302c5ea805804c328.tar.gz
historical-2a9a38b8e21291a1783864b302c5ea805804c328.tar.bz2
historical-2a9a38b8e21291a1783864b302c5ea805804c328.zip
ppc-macos fix
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/argus/argus-2.0.5.ebuild6
-rw-r--r--net-analyzer/netperf/netperf-2.2.4.ebuild9
2 files changed, 6 insertions, 9 deletions
diff --git a/net-analyzer/argus/argus-2.0.5.ebuild b/net-analyzer/argus/argus-2.0.5.ebuild
index f9483b628012..510a2e99abfc 100644
--- a/net-analyzer/argus/argus-2.0.5.ebuild
+++ b/net-analyzer/argus/argus-2.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-2.0.5.ebuild,v 1.8 2004/07/27 02:18:38 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-2.0.5.ebuild,v 1.9 2004/10/03 09:53:00 usata Exp $
inherit eutils
@@ -10,7 +10,7 @@ HOMEPAGE="http://www.qosient.com/argus/"
SRC_URI="ftp://ftp.qosient.com/pub/argus/src/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~amd64"
+KEYWORDS="x86 ~amd64 ~ppc-macos"
IUSE=""
RDEPEND="virtual/libc
>=net-libs/libpcap-0.6.2"
@@ -37,7 +37,7 @@ src_install () {
dobin bin/ra*
- use macos && newsbin bin/argus_bpf argus || newsbin bin/argus_linux argus
+ use ppc-macos && newsbin bin/argus_bpf argus || newsbin bin/argus_linux argus
insinto /etc/argus
doins support/Config/argus.conf
diff --git a/net-analyzer/netperf/netperf-2.2.4.ebuild b/net-analyzer/netperf/netperf-2.2.4.ebuild
index 4fcfbf9a0579..26d8a5fee71c 100644
--- a/net-analyzer/netperf/netperf-2.2.4.ebuild
+++ b/net-analyzer/netperf/netperf-2.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netperf/netperf-2.2.4.ebuild,v 1.12 2004/09/16 02:10:40 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netperf/netperf-2.2.4.ebuild,v 1.13 2004/10/03 09:55:29 usata Exp $
inherit flag-o-matic
@@ -20,13 +20,10 @@ KEYWORDS="x86 sparc ia64 alpha amd64 ppc64 macos ~ppc ppc-macos"
IUSE="ipv6"
-RDEPEND="virtual/libc >=sys-apps/sed-4"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+DEPEND="virtual/libc >=sys-apps/sed-4"
src_compile() {
- use macos || append-flags -DDO_UNIX
- use ppc-macos || append-flags -DDO_UNIX
+ ( use macos || use ppc-macos ) || append-flags -DDO_UNIX
use ipv6 && append-flags -DDO_IPV6
emake CFLAGS="${CFLAGS}" || die
sed -i 's:^\(NETHOME=\).*:\1/usr/bin:' *_script