summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-02-06 15:02:09 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-02-06 15:02:09 +0000
commit49c382213ce067cfabb34303efce092947d01cfd (patch)
tree96c804f28a134529ff3cd24d8225f4a5a45d10a0 /net-analyzer/ssldump/ssldump-0.9.ebuild
parentx86/ppc/hppa stable (diff)
downloadhistorical-49c382213ce067cfabb34303efce092947d01cfd.tar.gz
historical-49c382213ce067cfabb34303efce092947d01cfd.tar.bz2
historical-49c382213ce067cfabb34303efce092947d01cfd.zip
patch for new libpcap headers.
Diffstat (limited to 'net-analyzer/ssldump/ssldump-0.9.ebuild')
-rw-r--r--net-analyzer/ssldump/ssldump-0.9.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/net-analyzer/ssldump/ssldump-0.9.ebuild b/net-analyzer/ssldump/ssldump-0.9.ebuild
index 06fef405a100..ed8b3e9e8e12 100644
--- a/net-analyzer/ssldump/ssldump-0.9.ebuild
+++ b/net-analyzer/ssldump/ssldump-0.9.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ssldump/ssldump-0.9.ebuild,v 1.3 2003/09/05 23:44:49 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ssldump/ssldump-0.9.ebuild,v 1.4 2004/02/06 15:02:09 aliz Exp $
+
+inherit gnuconfig
IUSE="ssl"
@@ -11,18 +13,22 @@ SRC_URI="http://www.rtfm.com/ssldump/${MY_P}.tar.gz"
HOMEPAGE="http://www.rtfm.com/ssldump/"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="x86 ~amd64"
LICENSE="GPL-2"
DEPEND=">=net-libs/libpcap-0.6.1
ssl? ( >=dev-libs/openssl-0.6.9 )"
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ epatch ${FILESDIR}/${P}-libpcap-header.patch
+}
src_compile() {
- local myconf
+ gnuconfig_update
- use ssl || myconf="--without-crypto"
- econf ${myconf} || die
+ econf `use_with ssl crypto` || die
emake || die
}