summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-05-19 21:36:49 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-05-19 21:36:49 +0000
commit1e5a78b818c3e9a14c7ad30031c0783301790843 (patch)
tree051956326963f0d34a8b3baf73c0e947decbcff1 /net-analyzer/ssldump/ssldump-0.9.ebuild
parentinitial ebuild (diff)
downloadhistorical-1e5a78b818c3e9a14c7ad30031c0783301790843.tar.gz
historical-1e5a78b818c3e9a14c7ad30031c0783301790843.tar.bz2
historical-1e5a78b818c3e9a14c7ad30031c0783301790843.zip
initial ebuild
Diffstat (limited to 'net-analyzer/ssldump/ssldump-0.9.ebuild')
-rw-r--r--net-analyzer/ssldump/ssldump-0.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/ssldump/ssldump-0.9.ebuild b/net-analyzer/ssldump/ssldump-0.9.ebuild
new file mode 100644
index 000000000000..d4c060cc9c39
--- /dev/null
+++ b/net-analyzer/ssldump/ssldump-0.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ssldump/ssldump-0.9.ebuild,v 1.1 2003/05/19 21:36:26 mholzer Exp $
+
+IUSE="ssl"
+
+MY_P=${PN}-0.9b3
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+SRC_URI="http://www.rtfm.com/ssldump/${MY_P}.tar.gz"
+HOMEPAGE="http://www.rtfm.com/ssldump/"
+
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+
+DEPEND=">=net-libs/libpcap-0.6.1
+ ssl? ( >=dev-libs/openssl-0.6.9 )"
+
+
+src_compile() {
+ local myconf
+
+ use ssl || myconf="--without-crypto"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ into /usr
+ dosbin ssldump
+ doman ssldump.1
+ dodoc COPYRIGHT CREDITS README FILES VERSION INSTALL ChangeLog
+}