summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-10 00:00:13 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-10 00:00:13 +0000
commit4617d963e553a09ce6db0983c5354f1b8bd9f98f (patch)
treec54f263d3b4f89738b2a91e2d87f000a8cdc3fb6 /net-analyzer/portsentry/portsentry-1.1-r6.ebuild
parentunmasked supersed (diff)
downloadhistorical-4617d963e553a09ce6db0983c5354f1b8bd9f98f.tar.gz
historical-4617d963e553a09ce6db0983c5354f1b8bd9f98f.tar.bz2
historical-4617d963e553a09ce6db0983c5354f1b8bd9f98f.zip
changed to using supersed instead of regular sed
Diffstat (limited to 'net-analyzer/portsentry/portsentry-1.1-r6.ebuild')
-rw-r--r--net-analyzer/portsentry/portsentry-1.1-r6.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/net-analyzer/portsentry/portsentry-1.1-r6.ebuild b/net-analyzer/portsentry/portsentry-1.1-r6.ebuild
index dce29f0774d6..71a78067cb27 100644
--- a/net-analyzer/portsentry/portsentry-1.1-r6.ebuild
+++ b/net-analyzer/portsentry/portsentry-1.1-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portsentry/portsentry-1.1-r6.ebuild,v 1.5 2002/08/01 11:40:16 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/portsentry/portsentry-1.1-r6.ebuild,v 1.6 2002/08/10 00:00:13 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Automated port scan detector and response tool"
@@ -11,24 +11,24 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
-DEPEND="virtual/glibc"
+DEPEND="sys-apps/supersed"
src_unpack() {
unpack ${A} ; cd ${S}
# Setting the portsentry.conf file location
- sed -e 's:/usr/local/psionic/portsentry/portsentry.conf:/etc/portsentry/portsentry.conf:' \
- portsentry_config.h | cat > portsentry_config.h
+ sed -i 's:/usr/local/psionic/portsentry/portsentry.conf:/etc/portsentry/portsentry.conf:' \
+ portsentry_config.h
# presetting the other file locations in portsentry.conf
- sed -e 's:^IGNORE_FILE.*:IGNORE_FILE="/etc/portsentry/portsentry.ignore":g' \
- -e 's:^HISTORY_FILE.*:HISTORY_FILE="/etc/portsentry/portsentry.history":g' \
- -e 's:^BLOCKED_FILE.*:BLOCKED_FILE="/etc/portsentry/portsentry.blocked":g' \
- portsentry.conf | cat > portsentry.conf
+ sed -i -e 's:\(^IGNORE_FILE\).*:\1="/etc/portsentry/portsentry.ignore":g' \
+ -e 's:^\(HISTORY_FILE\).*:\1="/etc/portsentry/portsentry.history":g' \
+ -e 's:^\(BLOCKED_FILE\).*:\1="/etc/portsentry/portsentry.blocked":g' \
+ portsentry.conf
- sed -e "s:^set SENTRYDIR.*:set SENTRYDIR=/etc/portsentry:g" \
- ignore.csh | cat > ignore.csh
+ sed -i "s:^set SENTRYDIR.*:set SENTRYDIR=/etc/portsentry:g" \
+ ignore.csh
}
src_compile() {