summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2005-09-10 18:24:13 +0000
committerLance Albertson <ramereth@gentoo.org>2005-09-10 18:24:13 +0000
commitafc9d5ea9ad7dbdbcda61d89cb6c2872efe1eabf (patch)
tree62b15b61a51fc8279c4bfef1ca02f3930c221f35 /net-analyzer/nagios-plugins/nagios-plugins-1.4.1.ebuild
parentMarked Stable on AMD64. Removed older versions. (diff)
downloadhistorical-afc9d5ea9ad7dbdbcda61d89cb6c2872efe1eabf.tar.gz
historical-afc9d5ea9ad7dbdbcda61d89cb6c2872efe1eabf.tar.bz2
historical-afc9d5ea9ad7dbdbcda61d89cb6c2872efe1eabf.zip
fix noradius patch to actually patch configure.in (makes it more portable), fixes bug #105459
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-analyzer/nagios-plugins/nagios-plugins-1.4.1.ebuild')
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.4.1.ebuild24
1 files changed, 18 insertions, 6 deletions
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.4.1.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.4.1.ebuild
index 27e423c4d5a0..e35044422398 100644
--- a/net-analyzer/nagios-plugins/nagios-plugins-1.4.1.ebuild
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.1.ebuild,v 1.3 2005/09/10 13:22:54 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.1.ebuild,v 1.4 2005/09/10 18:24:13 ramereth Exp $
inherit eutils
@@ -44,12 +44,24 @@ pkg_setup() {
enewuser nagios -1 /bin/bash /dev/null nagios
}
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ if ! use radius; then
+ EPATCH_OPTS="-p0 -d ${S}" epatch ${FILESDIR}/${P}-noradius.patch
+ fi
if ! use radius; then
- epatch ${FILESDIR}/nagios-plugins-noradius.patch
+ export WANT_AUTOCONF=2.58
+ export WANT_AUTMAKE=1.8
+ cd ${S}
+ aclocal -I m4 || die "Failed to run aclocal"
+ autoconf || die "Failed to run autoconf"
+ automake || die "Failed to run automake"
fi
+}
+
+src_compile() {
- ./configure \
+ econf \
$(use_with mysql) \
$(use_with postgres) \
$(use_with ssl openssl) \
@@ -59,12 +71,12 @@ src_compile() {
--with-nagios-user=nagios \
--sysconfdir=/etc/nagios \
--infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ --mandir=/usr/share/man || die "econf failed"
# fix problem with additional -
sed -i -e 's:/bin/ps -axwo:/bin/ps axwo:g' config.h || die "sed failed"
- make || die "make failed"
+ emake || die "emake failed"
}
src_install() {