summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-09-28 13:05:18 +0000
committerCédric Krier <cedk@gentoo.org>2008-09-28 13:05:18 +0000
commit44a7069e241c6506c1402a2ce53c058710eeb188 (patch)
treec1ec38f4a8039dde838cda9919a448b60fa8f6d2 /net-analyzer/arping/arping-2.08.ebuild
parentRemove old (diff)
downloadhistorical-44a7069e241c6506c1402a2ce53c058710eeb188.tar.gz
historical-44a7069e241c6506c1402a2ce53c058710eeb188.tar.bz2
historical-44a7069e241c6506c1402a2ce53c058710eeb188.zip
Version bump
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'net-analyzer/arping/arping-2.08.ebuild')
-rw-r--r--net-analyzer/arping/arping-2.08.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/arping/arping-2.08.ebuild b/net-analyzer/arping/arping-2.08.ebuild
new file mode 100644
index 000000000000..82f1dc7b72a9
--- /dev/null
+++ b/net-analyzer/arping/arping-2.08.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/arping/arping-2.08.ebuild,v 1.1 2008/09/28 13:05:18 cedk Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A utility to see if a specific IP address is taken and what MAC address owns it"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=arping"
+SRC_URI="ftp://ftp.habets.pp.se/pub/synscan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap
+ >=net-libs/libnet-1.1.0-r3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm -f Makefile
+ # since we install as arping2, use arping2 in the man page
+ sed -i "s/\(${PN}\)/\12/g" ${PN}.8 || die "sed ${PN}.8 failed"
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ LDLIBS="-lpcap -lnet" \
+ arping-2/arping \
+ || die
+}
+
+src_test() {
+ einfo "Selftest only works as root"
+ #make SUDO= HOST=`hostname` MAC=`ifconfig -a | fgrep HWaddr | sed 's/.*HWaddr //g'` test
+}
+
+src_install() {
+ newsbin arping-2/arping arping2 || die
+ newman arping.8 arping2.8
+ dodoc README arping-scan-net.sh
+}