summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2004-01-13 22:17:14 +0000
committerBryan Stine <battousai@gentoo.org>2004-01-13 22:17:14 +0000
commite258731de72bc07cea0c29287811de98a48aa1fa (patch)
tree1534c5752c0dc0da249bd9a362651c8fe97b219a /media-video
parentadding metadata (diff)
downloadhistorical-e258731de72bc07cea0c29287811de98a48aa1fa.tar.gz
historical-e258731de72bc07cea0c29287811de98a48aa1fa.tar.bz2
historical-e258731de72bc07cea0c29287811de98a48aa1fa.zip
Updated version, hard masked
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ati-gatos/ChangeLog9
-rw-r--r--media-video/ati-gatos/Manifest4
-rw-r--r--media-video/ati-gatos/ati-gatos-4.3.0.ebuild63
-rw-r--r--media-video/ati-gatos/files/digest-ati-gatos-4.3.01
4 files changed, 75 insertions, 2 deletions
diff --git a/media-video/ati-gatos/ChangeLog b/media-video/ati-gatos/ChangeLog
index 88373e1b24af..c1c718efda96 100644
--- a/media-video/ati-gatos/ChangeLog
+++ b/media-video/ati-gatos/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/ati-gatos
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ati-gatos/ChangeLog,v 1.5 2003/11/18 17:23:32 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ati-gatos/ChangeLog,v 1.6 2004/01/13 22:17:05 battousai Exp $
+
+*ati-gatos-4.3.0 (13 Jan 2004)
+
+ 13 Jan 2004; <admin@gentoo.org> ati-gatos-4.3.0.ebuild:
+ Updated ebuild. This will build against xfree 4.3.0 with the sdk installed,
+ putting drivers in an alternate location so as not to interfere with the
+ original ati drivers.
18 Nov 2003; Martin Holzer <mholzer@gentoo.org>
ati-gatos-4.2.0.11-r1.ebuild:
diff --git a/media-video/ati-gatos/Manifest b/media-video/ati-gatos/Manifest
index 49b18f20a83b..7bbed7c049e6 100644
--- a/media-video/ati-gatos/Manifest
+++ b/media-video/ati-gatos/Manifest
@@ -1,4 +1,6 @@
-MD5 0ce2f5c453920417b88a7b290f9c32fd ChangeLog 852
+MD5 379166c2ec97b6c7079eed32d612b751 ChangeLog 1122
MD5 ade60b0e23a771694aaf634abcf119cb ati-gatos-4.2.0.11-r1.ebuild 1164
MD5 bca4dd1758b390509e46f966d475006d metadata.xml 221
+MD5 3b4cffe1da69a3227e771cbc08b40e6a ati-gatos-4.3.0.ebuild 2146
MD5 9eb54703092cc2e1847fb7983a0f11a7 files/digest-ati-gatos-4.2.0.11-r1 69
+MD5 9da49bcc2819c7a4ba37aa135a117f73 files/digest-ati-gatos-4.3.0 68
diff --git a/media-video/ati-gatos/ati-gatos-4.3.0.ebuild b/media-video/ati-gatos/ati-gatos-4.3.0.ebuild
new file mode 100644
index 000000000000..b5ea312b44c0
--- /dev/null
+++ b/media-video/ati-gatos/ati-gatos-4.3.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ati-gatos/ati-gatos-4.3.0.ebuild,v 1.1 2004/01/13 22:17:05 battousai Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="ATI Multimedia-capable drivers for XFree86"
+SRC_URI="http://www.kentonet.net/${P}.tar.bz2"
+HOMEPAGE="http://gatos.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="${DEPEND}
+ x11-base/xfree"
+
+pkg_setup() {
+ ewarn "This package requires that xfree was merged with the gatos USE flag enabled."
+ grep gatos /var/db/pkg/x11-base/xfree*/USE || die "Please merge xfree with the gatos and sdk USE flags enabled."
+}
+
+src_compile() {
+ cd ${S}
+
+ # Build makefiles against XFree SDK
+ imake -I/usr/X11R6/lib/Server/config/cf -DUseInstalled -DXF86DriverSDK
+
+ # Makefile fixes
+ fix_makefile
+
+ emake DESTDIR=${D} || die "Problem compiling GATOS drivers."
+}
+
+src_install() {
+ emake DESTDIR=${D} install
+}
+
+pkg_postinst() {
+ einfo "To have XFree86 make use of the new GATOS modules, you should add the following"
+ einfo "line to /etc/X11/XF86Config, in the files section and above any other"
+ einfo "ModulePath directives:"
+ einfo
+ einfo " ModulePath /usr/X11R6/lib/modules-extra/gatos"
+ einfo
+ einfo "Please note that you may need to uncomment or add another ModulePath line with"
+ einfo "the default module path in it. If XFree86 does not start after adding the line"
+ einfo "above, add this one under it:"
+ einfo
+ einfo " ModulePath /usr/X11R6/lib/modules"
+}
+
+fix_makefile() {
+ # Add the XFree86 SDK include directories that gatos will use
+ sed -i "s:INCLUDES = \(.\+\):INCLUDES = \\1 -I/usr/X11R6/lib/Server/include -I/usr/X11R6/lib/Server/include/extensions:" Makefile
+
+ # Clean up the ugly sandbox violations
+ sed -i "s:\(\ \+\)MODULEDIR = .*:\\1MODULEDIR = \\\$(USRLIBDIR)/modules-extra/gatos:" Makefile
+ sed -i "s:\(\ \+\)BUILDLIBDIR = .*:\\1BUILDLIBDIR = \\\$(DESTDIR)\\\$(TOP)/exports/lib:" Makefile
+ sed -i "s:\\(.\+\)\\\$(RM) \\\$(BUILDMODULEDIR)/drivers/ati2_drv\.o:\\1\\\$(RM) \\\$(DESTDIR)\\\$(BUILDMODULEDIR)/drivers/ati2_drv.o:" Makefile
+}
diff --git a/media-video/ati-gatos/files/digest-ati-gatos-4.3.0 b/media-video/ati-gatos/files/digest-ati-gatos-4.3.0
new file mode 100644
index 000000000000..4bf0e443bbc3
--- /dev/null
+++ b/media-video/ati-gatos/files/digest-ati-gatos-4.3.0
@@ -0,0 +1 @@
+MD5 25dcf3da6039d9a40a4dd47355927c6b ati-gatos-4.3.0.tar.bz2 388917