summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-01-23 11:25:17 +0000
committerNick Hadaway <raker@gentoo.org>2003-01-23 11:25:17 +0000
commitbc4c636d102c849acef3dc2252bc17294a2f5e23 (patch)
treed5fcab8406c20cc0647725bd7859e6dc74ce90f6 /media-video
parentNew ebuild to pull the new init.d file. (diff)
downloadhistorical-bc4c636d102c849acef3dc2252bc17294a2f5e23.tar.gz
historical-bc4c636d102c849acef3dc2252bc17294a2f5e23.tar.bz2
historical-bc4c636d102c849acef3dc2252bc17294a2f5e23.zip
Version bump. Lots of ebuild changes.
Diffstat (limited to 'media-video')
-rw-r--r--media-video/avifile/ChangeLog14
-rw-r--r--media-video/avifile/avifile-0.7.26.20030117.ebuild165
-rw-r--r--media-video/avifile/files/digest-avifile-0.7.26.200301171
3 files changed, 178 insertions, 2 deletions
diff --git a/media-video/avifile/ChangeLog b/media-video/avifile/ChangeLog
index d69b3da5ff02..965a382159b2 100644
--- a/media-video/avifile/ChangeLog
+++ b/media-video/avifile/ChangeLog
@@ -1,11 +1,21 @@
# ChangeLog for media-video/avifile
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.29 2003/01/19 14:46:57 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.30 2003/01/23 11:25:17 raker Exp $
+
+*avifile-0.7.26.20030117 (23 Jan 2003)
+
+ 23 Jan 2003; Nick Hadaway <raker@gentoo.org> avifile-0.7.26.20030117.ebuild,
+ files/digest-avifile-0.7.26.20030117 :
+ Version bump. Total ebuild reorganization fully supporting all
+ available configure options. A couple of local variables added for
+ explicit disabling or enabling of certain features. Unset CC and
+ CXX during configure to avoid problems during the mad configuration.
+ Reset for emake.
19 Jan 2003; Martin Schlemmer <azarah@gentoo.org> :
Disable KDE support, as it is broken anyhow. Bug #13608.
-*avifile-0.7.25-20030114 (15 Jan 2003)
+*avifile-0.7.25.20030114 (15 Jan 2003)
15 Jan 2003; Nick Hadaway <raker@gentoo.org> avifile-0.7.25.20030114.ebuild,
files/digest-avifile-0.7.25.20030114 :
diff --git a/media-video/avifile/avifile-0.7.26.20030117.ebuild b/media-video/avifile/avifile-0.7.26.20030117.ebuild
new file mode 100644
index 000000000000..e178b8ebbea8
--- /dev/null
+++ b/media-video/avifile/avifile-0.7.26.20030117.ebuild
@@ -0,0 +1,165 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/avifile-0.7.26.20030117.ebuild,v 1.1 2003/01/23 11:25:17 raker Exp $
+
+IUSE="static freetype xv sdl oss dvd mmx sse 3dnow zlib oggvorbis X qt"
+
+inherit libtool
+
+MY_P="${P/.200/-200}"
+MY_S="${PN}0.7-0.7.26"
+S="${WORKDIR}/${MY_S}"
+
+DESCRIPTION="Library for AVI-Files"
+SRC_URI="http://avifile.sourceforge.net/${MY_P}.tgz"
+HOMEPAGE="http://avifile.sourceforge.net/"
+
+DEPEND=">=media-libs/divx4linux-20020418
+ >=media-libs/jpeg-6b
+ >=media-libs/win32codecs-0.90
+ >=media-video/ffmpeg-0.4
+ >=media-sound/mad-0.14
+ >=media-libs/xvid-0.9.0
+ >=media-sound/lame-3.90
+ >=sys-devel/automake-1.7
+ freetype? ( >=media-libs/freetype-2.1 )
+ xv? ( >=x11-base/xfree-4.2.1 )
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ dvd? ( >=media-libs/a52dec-0.7 )
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ oggvorbis? ( >=media-libs/libvorbis-1.0 )
+ X? ( >=x11-base/xfree-4.2.0 >=x11-libs/xft-2.0.1 )
+ qt? ( >=x11-libs/qt-3.0.3 )"
+
+SLOT="0.7"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile() {
+
+ elibtoolize
+
+ local myconf=""
+ local kdepre=""
+
+ use static \
+ && myconf="${myconf} --enable-static" \
+ || myconf="${myconf} --disable-static"
+
+ use freetype \
+ && myconf="${myconf} --enable-freetype2" \
+ || myconf="${myconf} --disable-freetype2"
+
+ use xv \
+ && myconf="${myconf} --enable-xv" \
+ || myconf="${myconf} --disable-xv"
+
+ if [ "$XINERAMA" = "NO" ]; then
+ myconf="${myconf} --disable-xinerama"
+ fi
+
+ if [ "$DPMS" = "NO" ]; then
+ myconf="${myconf} --disable-dpms"
+ fi
+
+ use sdl \
+ && myconf="${myconf} --enable-sdl" \
+ || myconf="${myconf} --disable-sdl --disable-sdltest"
+
+ if [ "$V4L" = "NO" ]; then
+ myconf="${myconf} --disable-v4l"
+ fi
+
+ use oss \
+ && myconf="${myconf} --enable-oss" \
+ || myconf="${myconf} --disable-oss"
+
+ if [ "$SUN" = "NO" ]; then
+ myconf="${myconf} --disable-sunaudio"
+ fi
+
+ use dvd \
+ && myconf="${myconf} --enable-a52 --enable-ffmpeg-a52" \
+ || myconf="${myconf} --disable-a52 --disable-ffmpeg-a52"
+
+ if [ "$SBLIVE" = "NO" ]; then
+ myconf="${myconf} --disable-ac3passthrough"
+ fi
+
+ if [ "$RUNTIME_LAME" = "YES" ]; then
+ myconf="${myconf} --enable-lame-bin"
+ fi
+
+ if [ ! -z $DEBUGBUILD ]; then
+ myconf="${myconf} --enable-loader-out --enable-timing"
+ else
+ myconf="${myconf} --enable-quiet"
+ fi
+
+ ( use mmx || use sse || use 3dnow ) && myconf="${myconf} --enable-x86opt"
+
+ use zlib \
+ && myconf="${myconf} --enable-libz" \
+ || myconf="${myconf} --disable-libz"
+
+ use oggvorbis \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis --disable-oggtest --disable-vorbistest"
+
+ if [ "$MGA" = "NO" ]; then
+ myconf="${myconf} --disable-mga"
+ fi
+
+ if [ "$DMALLOC" = "YES" ]; then
+ myconf="${myconf} --with-dmallocth"
+ fi
+
+ use X \
+ && myconf="${myconf} --with-x --enable-xft" \
+ || myconf="${myconf} --without-x --disable-xft"
+
+ use qt \
+ && myconf="${myconf} --with-qt-dir=${QTDIR}" \
+ || myconf="${myconf} --without-qt"
+
+ # Rather not use custom ones here .. build should set as high as
+ # safe by itself.
+ unset CFLAGS CXXFLAGS LDFLAGS CC CXX
+
+ # Make sure we include freetype2 headers before freetype1 headers, else Xft2
+ # borks, bug #11941.
+ export C_INCLUDE_PATH="${C_INCLUDE_PATH}:/usr/include/freetype2"
+ export CPLUS_INCLUDE_PATH="${CPLUS_INCLUDE_PATH}:/usr/include/freetype2"
+
+ # Fix qt detection
+ cp configure configure.orig
+ sed -e "s:extern \"C\" void exit(int);:/* extern \"C\" void exit(int); */:" \
+ < configure.orig > configure
+
+ econf \
+ --enable-samples \
+ --disable-vidix \
+ --with-fpic \
+ --with-gnu-ld \
+ ${myconf} || die
+
+ export CC="gcc"
+ export CXX="g++"
+
+ emake || die
+}
+
+src_install () {
+
+ dodir /usr/lib /usr/bin
+ use avi && dodir /usr/lib/win32
+
+ einstall || die
+
+ cd ${S}
+ dodoc COPYING README
+ cd doc
+ dodoc CREDITS EXCEPTIONS FreeBSD LICENSING TODO
+ dodoc VIDEO-PERFORMANCE WARNINGS
+}
+
diff --git a/media-video/avifile/files/digest-avifile-0.7.26.20030117 b/media-video/avifile/files/digest-avifile-0.7.26.20030117
new file mode 100644
index 000000000000..b580e1d64538
--- /dev/null
+++ b/media-video/avifile/files/digest-avifile-0.7.26.20030117
@@ -0,0 +1 @@
+MD5 36f19b6eaa893f46aa59bae8df820a21 avifile-0.7.26-20030117.tgz 2828062