summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2004-06-14 00:37:35 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2004-06-14 00:37:35 +0000
commitba19d77c05e53b128b8cb51474c781a48e27cac5 (patch)
tree944c8c37eb5790aa1b71c318252f2f44cf550616 /media-video/yanc/yanc-0.2.1-r1.ebuild
parentChange x11-base/xfree dependency to virtual/x11 (#47632). (diff)
downloadhistorical-ba19d77c05e53b128b8cb51474c781a48e27cac5.tar.gz
historical-ba19d77c05e53b128b8cb51474c781a48e27cac5.tar.bz2
historical-ba19d77c05e53b128b8cb51474c781a48e27cac5.zip
Look for /etc/X11/xorg.conf (#47632).
Diffstat (limited to 'media-video/yanc/yanc-0.2.1-r1.ebuild')
-rw-r--r--media-video/yanc/yanc-0.2.1-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-video/yanc/yanc-0.2.1-r1.ebuild b/media-video/yanc/yanc-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..333609d75e5f
--- /dev/null
+++ b/media-video/yanc/yanc-0.2.1-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/yanc/yanc-0.2.1-r1.ebuild,v 1.1 2004/06/14 00:37:35 spyderous Exp $
+
+inherit eutils
+
+DESCRIPTION="YanC is a GUI configuration tool for the NVIDIA Accelerated Linux Driver Set."
+HOMEPAGE="http://yanc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/yanc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+# As the downloaded package seems to be pre-compiled,
+# the dependances are not clear.
+# TODO: Emerge the real compilable yanc's code
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="virtual/x11"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-xorg-x11-compat.patch
+}
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ dodir /usr/share/yanc
+ dodir /usr/lib
+ dodir /usr/bin
+
+ cp -r src ${D}/usr/share/yanc
+ cp -r lang ${D}/usr/share/yanc
+ dolib lib/libborqt-6.9.0-qt2.3.so
+ dosym libborqt-6.9.0-qt2.3.so /usr/lib/libborqt-6.9-qt2.3.so
+
+ insinto /usr/share/yanc
+ doins logo.jpg gpl.jpg loeschen.xpm nachunten.xpm nachoben.xpm yanc.xpm
+ doins LICENSE
+
+ exeinto /usr/share/yanc
+ doexe yanc
+
+
+ into /usr
+ dobin script/yanc
+ dosed "s:local:share:" /usr/bin/yanc
+
+ dodoc README*
+ dohtml doc
+}
+
+pkg_postinst() {
+ einfo '-> Please create a copy of your X config before you use YanC for the'
+ einfo 'first time, because it is possible that it will be damaged because of'
+ einfo 'the use of YanC. Then a restart of X would be impossible.'
+}