summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-05-07 20:21:10 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-05-07 20:21:10 +0000
commitade8ba62988ec700f290543ee0bf8409f64207d5 (patch)
tree87731fb362e6dc54964cdfcf882f7c2bd3f7f23f /media-video/linux-uvc/linux-uvc-0.0.1_pre51.ebuild
parentProperly indent init script. (diff)
downloadhistorical-ade8ba62988ec700f290543ee0bf8409f64207d5.tar.gz
historical-ade8ba62988ec700f290543ee0bf8409f64207d5.tar.bz2
historical-ade8ba62988ec700f290543ee0bf8409f64207d5.zip
Version bump, fixes bugs 173889 and 177320 thanks to cedk and Ortwin Glueck <odi@odi.ch>
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'media-video/linux-uvc/linux-uvc-0.0.1_pre51.ebuild')
-rw-r--r--media-video/linux-uvc/linux-uvc-0.0.1_pre51.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/media-video/linux-uvc/linux-uvc-0.0.1_pre51.ebuild b/media-video/linux-uvc/linux-uvc-0.0.1_pre51.ebuild
deleted file mode 100644
index aeea50b3b3eb..000000000000
--- a/media-video/linux-uvc/linux-uvc-0.0.1_pre51.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/linux-uvc/linux-uvc-0.0.1_pre51.ebuild,v 1.4 2006/10/13 12:30:27 blubb Exp $
-
-inherit eutils linux-mod
-
-DESCRIPTION="Linux driver and user-space tools for USB Video Class devices."
-HOMEPAGE="http://linux-uvc.berlios.de/"
-SRC_URI="http://gentooexperimental.org/~genstef/dist/${P}.tar.bz2"
-#ESVN_REPO_URI="http://svn.berlios.de/svnroot/repos/linux-uvc/linux-uvc/trunk/"
-#ESVN_OPTIONS="-r ${PV/*_pre}"
-#svn co http://svn.berlios.de/svnroot/repos/linux-uvc/linux-uvc/trunk linux-uvc-0.0.1_pre
-#rm -r linux-uvc-0.0.1_pre*/.svn
-
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE="isight"
-DEPEND=">=dev-libs/libusb-0.1.12"
-
-MODULE_NAMES="uvcvideo(usb/media)"
-BUILD_TARGETS="uvcvideo"
-CONFIG_CHECK="VIDEO_DEV"
-
-pkg_setup() {
- linux-mod_pkg_setup
-
- BUILD_PARAMS="KERNEL_DIR=${KV_DIR}"
- if use isight; then
- MODULESD_UVCVIDEO_ENABLED="yes"
- MODULESD_UVCVIDEO_ADDITIONS=( "pre-install uvcvideo /sbin/isight-firmware-tool /lib/firmware/AppleUSBVideoSupport; sleep 2" )
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- use isight && epatch ${FILESDIR}/41-001-isight.patch
- kernel_is ge 2 6 18 && epatch ${FILESDIR}/uvc-2.6.18.diff
-}
-
-src_compile() {
- use isight && emake extract
-
- linux-mod_src_compile
-}
-
-src_install() {
- into /
- use isight && newsbin extract isight-firmware-tool
-
- linux-mod_src_install
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
- ewarn "This is SVN checkout build -- against revision: ${PV/*_pre}"
- ewarn "If something is broken, you should get involved, and report"
- ewarn "back to the mailing list linux-uvc-devel@lists.berlios.de"
-
- if use isight; then
- elog "Using iSight cameras, you *must* install the firmware to /lib/firmware, for e.g:"
- elog " mkdir -p /lib/firmware"
- elog " cp /\${OSX_MOUNT}/System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBVideoSupport.kext/Contents/MacOS/AppleUSBVideoSupport /lib/firmware"
- elog "Check /etc/modules.d/uvcvideo for more info."
- fi
-}