summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-01-11 20:25:04 +0000
committerMichael Weber <xmw@gentoo.org>2011-01-11 20:25:04 +0000
commit8b337a1364057debe14ed13722599afd32aabcf0 (patch)
tree9c48dabbb4a40ded3125a3abbb7e9950676dbb27 /media-video/coherence/coherence-0.6.6.2.ebuild
parentNeeds gnome-panel with bonobo support (bug #348185). (diff)
downloadhistorical-8b337a1364057debe14ed13722599afd32aabcf0.tar.gz
historical-8b337a1364057debe14ed13722599afd32aabcf0.tar.bz2
historical-8b337a1364057debe14ed13722599afd32aabcf0.zip
Fix python issues (bug 313987) and version bump (bug 349476).
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'media-video/coherence/coherence-0.6.6.2.ebuild')
-rw-r--r--media-video/coherence/coherence-0.6.6.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-video/coherence/coherence-0.6.6.2.ebuild b/media-video/coherence/coherence-0.6.6.2.ebuild
new file mode 100644
index 000000000000..abee6536a86e
--- /dev/null
+++ b/media-video/coherence/coherence-0.6.6.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/coherence/coherence-0.6.6.2.ebuild,v 1.1 2011/01/11 20:25:04 xmw Exp $
+
+EAPI=2
+PYTHON_DEPEND="*"
+PYTHON_USE_WITH="sqlite"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit distutils python
+
+MY_P="Coherence-${PV}"
+
+DESCRIPTION="A framework written in Python for DLNA/UPnP components"
+HOMEPAGE="https://coherence.beebits.net/"
+SRC_URI="http://coherence.beebits.net/download/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# deps are not exact and need some work
+DEPEND="dev-python/louie
+ dev-python/twisted
+ dev-python/twisted-web
+ dev-python/configobj
+ dev-python/gst-python
+ dev-python/nevow"
+RDEPEND="${DEPEND}
+ dev-python/axiom
+ dev-python/gdata
+ dev-python/feedparser
+ dev-python/tagpy"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ DOCS="docs/*"
+ distutils_src_install
+ newinitd "${FILESDIR}"/coherence-init coherence
+}